If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Force audio only transcoding, with direct play video

mikkovillemikkoville Posts: 7Members, Plex Pass Plex Pass
edited April 2014 in Plex Classic for Roku

Hi, 

I'm running Plex Server on QNAP and streaming MKV files to Roku 3.

I would need to disable video transcoding completely but still have the Plex to transcode the audio track (AC3) to something my system can handle (such as AAC).

If I convert the audio stream to AAC with MkvTools or such, the direct play with Roku 3 works fine, but i have to convert all files beforehand. If I don't convert the file beforehand the "direct play" only plays video without audio, because my system can't digest the AC3. On the other hand, the automatic transcoding tries to also transcode video which is too intensive for my QNAP's CPU. I think it could handle audio only transcoding, though, if that was somehow possible to set on Plex. I don't know why it even tries to transcode video since it plays fine without transcoding (tried looking at the log files, but didn't come up with anything..).

So, i guess the bottom line is:

Is there a way to force audio-only transcoding for MKV containers with AC3 audio stream without touching the video stream at all?

Thanks!
 

«1

Comments

  • leelyndsleelynds Posts: 1,019Members, Plex Pass Plex Pass
    edited April 2014

    Make sure the roku is set to stereo, not surround.  If that doesn't do it, try under Preferences for the Roku app -Direct Play - change the settings to -Direct Stream/Transcode instead of the default Automatic setting. 

    It seems to work for my son's roku, and he's about 600 km away from my server.  I think we also bumped up the quality settings on his roku too, but I don't think that setting really had any effect on the stereo surround part of it

  • mikkovillemikkoville Posts: 7Members, Plex Pass Plex Pass
    edited April 2014

    Leelynds, thanks a lot for the answer! 

    Yes, the Roku is set to stereo, but the trouble is that my sound system does not support AC3 so it needs to be transcoded. As far as I can see the problem is not the audio stream (Plex is able to transcode AC3 into something else and it plays fine for a while when transcoding is enabled), but the fact that Plex also unnecessarily transcodes the video stream at the same time and it's too CPU intensive for my QNAP, which results in constant stopping and restarting of the playback.

    I've also tried all the different quality settings as well as combinations with different transcoding settings to circumvent the video transcoding, but without success.

    Converting the audio stream to AAC with ffmpeg does the trick however because I can then simply use the direct play setting (so that no transcoding takes place either for audio or video), but it seems like a slow and unnecessary extra step in the process.

    What I would like to do is have Plex to only transcode audio and leave video stream untouched

  • leelyndsleelynds Posts: 1,019Members, Plex Pass Plex Pass

    I'm not positive, but I'm pretty sure that the new aac audio that plex creates is just remuxed with the original video into a new container.  The now playing window in plex web, or even the info display on Roku may say transcoded, but that's just because it's being remuxed into a new container and stream for the roku.  I use PlexNotify on my computer to notify me when someone is watching, and it reports video-copy, audio-transcode in this situation

  • MovieFan.PlexMovieFan.Plex Posts: 16,136Members, Plex Pass, Plex Ninja Plex Employee

    If you set the quality to higher than the actual bitrate of the original, and the video is a supported format, it won't transcode the video.

  • w-aiguow-aiguo Posts: 6Members

    This issue has been bothering me.

    I try to set up as a direct player in the app, but can not decode AC3 and DTS audio tracks, so there is no sound。

    Try setting mxplayer external player, but can not display subtitles.

  • MovieFan.PlexMovieFan.Plex Posts: 16,136Members, Plex Pass, Plex Ninja Plex Employee

    Did you set those settings in the profile to on?  If you turn it off, it should transcode the audio but leave the video alone.

  • axmadrigalaxmadrigal Posts: 6Members
    edited May 2014

    I would also like to be able to do this.  All my movies are mkv, h264, dts or ac3.  I'm using the android app and I don't want the video to transcode.  Forcing direct play gives me no audio but perfect video.  Without direct play sometimes video transcodes and sometimes it doesn't.  Seems like 480p videos transcode more than hd which is strange.

  • MovieFan.PlexMovieFan.Plex Posts: 16,136Members, Plex Pass, Plex Ninja Plex Employee

    You need to determine what is causing the transcoding of the video.  Check the birtate and ref frames.  In the app, what bitrate are you playing at?

  • axmadrigalaxmadrigal Posts: 6Members
    MovieFan wrote on May 13 2014, 7:19 PM: »

    You need to determine what is causing the transcoding of the video.  Check the birtate and ref frames.  In the app, what bitrate are you playing at?

    For example a movie that will direct play video and transcode audio has a bitrate of 12100 kbps and ref frames 5, 1080p, mkv, h264, ac3

    another movie will transcode both has a bitrate of 933 kbps and ref frames 4, 480p, mkv, h264, ac3

  • MovieFan.PlexMovieFan.Plex Posts: 16,136Members, Plex Pass, Plex Ninja Plex Employee

    That is odd.  Are the bitrates constant or are they variable?

    You did answer the second part of my question.  What quality are you viewing the videos at?  Also, are you trying within your local network or away, because there are local and remote quality settings?

  • axmadrigalaxmadrigal Posts: 6Members

    the quality is set to maximum and its on the local network.

    Looking at the android plex logs it looks like it scaling the 480p videos. Is there a setting I'm missing?

    D/Plex    (15538): [video] Video size is now 862x368
    D/Plex    (15538): [video] Scaling video view to 1280x546

  • MovieFan.PlexMovieFan.Plex Posts: 16,136Members, Plex Pass, Plex Ninja Plex Employee

    The scaling is just to show the video otherwise you would get a small video window with black borders.  It is actually receiving the 862x368 signal.  We'll need to look at the media server log when the transcoding takes place to see why it's doing it.

    Exit PMS and turn it back on to create a clean log.  Then play the 480p file.  Let it run for at least 2 minutes, then upload that log.

  • axmadrigalaxmadrigal Posts: 6Members

    here you go.

    thanks

  • MovieFan.PlexMovieFan.Plex Posts: 16,136Members, Plex Pass, Plex Ninja Plex Employee

    Hmm, odd.  Your original file is 720x352 and the transcoder is scaling it up to 844x352.  I haven't seen the transcoder ever scale up like that.  Anyone else have input on this?

  • axmadrigalaxmadrigal Posts: 6Members

    It does the same on both of my android devices.  Every 480p video i've tried and some 720p videos.  So far all the 1080p videos direct play.

  • klezklez Posts: 1Members
    edited July 2014

    I was wondering the same thing. mkv 1080p 5.1 audio, can direct play the video nicely with no audio OR transcode the stream down to 1.5Mbps, forcing trans on both audio and video. This seem to be the only 2 things that happen no matter what settings are changed.

  • mccomseymccomsey Posts: 18Members, Plex Pass Plex Pass

    This would be really nice to have an answer... I'm kind of frustrated. Direct Play plays the video perfectly, but with no audio. To get the audio, I need to set it to automatic or Direct Stream, but then it transcodes the video as well.

  • MovieFan.PlexMovieFan.Plex Posts: 16,136Members, Plex Pass, Plex Ninja Plex Employee

    I'm become a little wiser since my previous posts.

    If you get video but no audio with direct play there are 3 causes.

    1 - Incompatible audio format

    2 - Roku audio setting set to stereo when the audio in the video is surround or vice versa

    3 - You have 5.1 DTS or higher and no audio/video receiver

    If your playback bitrate is higher than the video, using automatic or direct stream should NOT transcode the video, unless there is something else out of spec with the file.  If you upload the XML file for your video, we can see what is causing the video to get transcoded.  Unless the devs put in this specific combination into the playback menu it will always be hit or miss due to specs of the video.

  • mccomseymccomsey Posts: 18Members, Plex Pass Plex Pass

    I understand that it will reencode the audio to stereo. That's what I want it to do... The problem is I want to direct stream the video since it is full quality and has no issues.

    In the log, it appears that the bit rate of the video is > than 20000, and that is why it is transcoding. Does that mean I have to reencode all my videos to be < 20000? That's a little confusing to me, considering if I tell the Roku to Direct Play, it plays the video fine, but does not transcode the audio (so no sound.)

  • MovieFan.PlexMovieFan.Plex Posts: 16,136Members, Plex Pass, Plex Ninja Plex Employee

    Basically yes.  There is no option to force direct play video and transcode audio.  Direct play is direct for both.  If it is transcode, it will examine both video and audio to see if either needs to be transcoded.  The devs will need to modify PMS and the clients to allow this combination.

    It will be faster and easier if you convert the audio and mux it in with your current file, then you can just direct play it.

«1
Sign In or Register to comment.