Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

How to diagnose Camera Upload issues

roguecoderoguecode Plex Dev TeamMembers, Plex Employee, Plex Pass, Plex Ninja Posts: 429 Plex Employee

The Camera Upload feature in Plex for Windows Phone was designed to just work (after enabling it of course). If you find that it doesn't work "automagically", please read through the following:

 

Open up the app and select settings (in the appbar) -> slide to camera upload. On that screen, is the feature enabled? And have you configured the library and album settings?

 

If so, then at the bottom it should say "next upload - photos taken since X", where X is the last time the app uploaded photos to the server.

 

Next please go select status (in the appbar) -> slide to camera upload. If the background task isn't working correctly, you'll likely see a bunch of images there that haven't been uploaded. Try tapping the upload now button in the appbar. That should upload all the images immediately. If that doesn't happen, and you're confident your Plex Media Server is contactable, then please post a new topic in this forum.

 

The most likely reason for the application not uploading in the background is that the Windows Phone OS isn't running our upload background task on schedule.

 

First, determine which OS version you have by going to the system's settings -> about, then reading the Software line.

 

WP 8.1

Open up Battery Saver -> Scroll to Plex, then make sure that Allow app to run in the background is on.

 

WP 8.0

Go to Settings -> slide to applications -> background tasks -> scroll to Plex and make sure it is allowed.

 

The task may be off if you have too many other tasks running in the background. After enabling it, be sure to open the Plex app again so it can get back on track.

Comments

  • NVader2000NVader2000 Members, Plex Pass Posts: 449 Plex Pass

    Cannot even see my photos in the Plex for Windows Phone. Just blank. So I have to check my PMS to make sure they have been uploaded, and of course they are being uploaded but to the wrong library. Again, PLEX, your product is broken. I never told Camera Upload to send my photos to "Photos\Camera Roll"

    PLEASE FIX!!!

  • LargrandeLargrande Members Posts: 6 Plex Pass

    The App always say "Unable to Upload Photo to Server" In Server Log i see /USR/SBIN/CRON[6197]: (root) CMD (Var/lib/Openmediavault/Cron.d/rsync-00b7f12a-3f5c-4b90-8c2a-6efc1a0cbce3 >/dev/null/ 2>&1 what is the Problem ?

  • LargrandeLargrande Members Posts: 6 Plex Pass

    So I tested the Android app today and it is working without a problem, so please work on the Windows Phone App. I wont pay for any further Plex-Pass until the app is working !

  • damianiwdamianiw Members, Plex Pass Posts: 50 Plex Pass
    edited November 2015

    Hi

    Camera upload was working but now isnt, tried all I can think of uninstalling, reinstalling - testing without moving app to SD Card, logging out and back in on both Phone and Server, upload from IOS is working just not Windows Phone :-( also noticed phone cannot see server unless allow insecure connections (on same network) is set ?

    I've reset the camera upload, cleared the trash on the plex server, made a new album to upload into within my photos library.

    The Error Given is 'unable to upload photo to server'

    Versions

    Lumia 830, windows os 8.10.15148.160, firmware 02177.00000.15184.36007, Plex for windows phone 2.1.2.5

    Plex Server for Windows 0.9.12.19

    The Error log I looked at from my windows phone shows this error:

    2015-11-08 18:08:47:8132 [3] DEBUG - [CameraUploadManager] - Posting image WP_20150406_15_10_57_Pro.jpg to /library/metadata?sectionID=11&locationID=12&filename=WP_20150406_15_10_57_Pro.jpg&type=13&createdAt=1428333064&subdirectory=Upload%20-%20Damo%20Nokia%5CCamera%20Roll
    2015-11-08 18:08:47:9200 [3] ERROR - [CameraUploadManager] - InvalidOperationException uploading image: A delegate was assigned when not allowed. (Exception from HRESULT: 0x80000018)
    

    Any ideas and can anyone confirm if their camera upload is working

    I made a new photo library (from phone) and it did upload 1 photo but shows error and on the phone is trying to upload the same photo each time:

    Server Activity screen:

    .
    7:21 PM Created WP_20150406_15_10_57_Pro in Mobile Photos2
    7:21 PM Created WP_20150406_15_10_57_Pro in Mobile Photos2
    7:21 PM Created Camera Roll in Mobile Photos2
    7:21 PM Library scan complete: Extra information may still be downloading from the Internet
    7:21 PM Scanning the "Mobile Photos2" section
    7:20 PM Created WP_20150406_15_10_57_Pro in Mobile Photos
    7:20 PM Library scan complete: Extra information may still be downloading from the Internet
    7:20 PM Created WP_20150406_15_10_57_Pro in Mobile Photos
    7:20 PM Created Camera Roll in Mobile Photos
    7:20 PM Scanning the "Mobile Photos" section

  • LargrandeLargrande Members Posts: 6 Plex Pass

    Ok after last updates ist working for me now.

Sign In or Register to comment.