Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Set Direct Play to default for ALL?

maxsteelmaxsteel Members, Plex Pass Posts: 6 Plex Pass

I apologize in advance if my previous searches were back, I did look for an answer to this, but I didn't seem to find the exact one.

 

I successfully have my roku (LAN hard wired) through an Amp/Receiver with Direct Play!  I have to say this is sooooo much better as my server just isn't powerful enough to transcode a 1080p for the roku (I tried it stutters).  But now that I have direct play it works like a charm.

 

What my question is, perhaps I missed the setting, but is there a way to set ALL videos on the ROKU so that the default method of playback is Direct Play? 

 

Thanks in advance!

Comments

  • ljunkieljunkie Plex Dev Team Members, Plex Employee, Plex Pass, Plex Ninja Posts: 4,799 Plex Employee
    edited August 2014
    Yep. It's in the preferences. Roku -> Plex -> Preferences -> Direct Play

    I'd just suggest to bump the quality high though and leave direct play automatic, because some media may not direct play. If you choose direct play and the media fails, then you'd have to choose transcode or convert that media into compatible format.
  • hackztor@gmail.comhackztor@gmail.com Members, Plex Pass Posts: 465 Plex Pass

    Sometimes a force of direct play will also give you video but no audio if the roku cant play the audio correctly. Best just to leave it on auto. It does a pretty decent job on auto.

  • ljunkieljunkie Plex Dev Team Members, Plex Employee, Plex Pass, Plex Ninja Posts: 4,799 Plex Employee
    edited August 2014
    Another thought, you might want to make sure your Roku audio is set to surround sound (since your using an amp). You can find that option in the Roku settings, not plex.
  • maxsteelmaxsteel Members, Plex Pass Posts: 6 Plex Pass
    ljunkie wrote on August 31 2014, 10:26 PM: »

    Another thought, you might want to make sure your Roku audio is set to surround sound (since your using an amp). You can find that option in the Roku settings, not plex.

    Yup! This was why I couldn't get sound to play 'direct' for the longest time!  I thought it was my amp, so I fiddled with the countless settings on it only to find out after that the roku is stereo only by default! lol!  d'oh!!!

  • maxsteelmaxsteel Members, Plex Pass Posts: 6 Plex Pass
    hackztor@gmail.com wrote on August 31 2014, 10:23 PM: »

    Sometimes a force of direct play will also give you video but no audio if the roku cant play the audio correctly. Best just to leave it on auto. It does a pretty decent job on auto.

    My amp pretty much covers this, hence the direct play.

  • maxsteelmaxsteel Members, Plex Pass Posts: 6 Plex Pass
    ljunkie wrote on August 31 2014, 9:49 PM: »

    Yep. It's in the preferences. Roku -> Plex -> Preferences -> Direct Play

    I'd just suggest to bump the quality high though and leave direct play automatic, because some media may not direct play. If you choose direct play and the media fails, then you'd have to choose transcode or convert that media into compatible format.

    Well that was simple, I think it's the sound piece that I was having trouble with before that just made me throw my hands up (After it being so simple) and yet another simple answer.

    Thanks!

    I'd be curious to know what formats the roku has problems with, 99.99% of my items are mkv containers... so far so good now that I set the darn roku to surround agh!

  • UruphredUruphred Members, Plex Pass Posts: 1 Plex Pass
    edited April 23

    Yes this works

Sign In or Register to comment.