Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

PlexAPI: We failed to reach a server. Reason: Unauthorized

aalexsonaalexson Members, Plex Pass Posts: 19 Plex Pass

I upgraded to plex 0.9.11.4 today and now my ATV through PlexConnect can no longer see my PMS.

 

I am unable to find any documentation in the forums.

 

PlexConnect Log:

 

 

00:46:23 PlexAPI: No Response from Plex Media Server

00:46:23 PlexAPI: We failed to reach a server. Reason: Unauthorized

 

I see nothing in the PMS logs.

 

Any help would be greatly appreciated.

 

 

Comments

  • wahlman.jwahlman.j Members, Plex Pass Posts: 2,560 Plex Pass
    edited December 2014
    A more detailed issue report would help:

    https://github.com/iBaa/PlexConnect/wiki/How-to-report-an-issue

    Use the template provided to report the issue in more detail.
  • drewbiedrewbie Members, Plex Pass Posts: 1,121 Plex Pass
    As wahlman.j pointed out, we need those details, also as your on 9.11.4 did you enable Plex home?
  • aalexsonaalexson Members, Plex Pass Posts: 19 Plex Pass
    It was plex home that killed my ATV/plexconnect.

    If I could make a suggestion, make a sticky with regards to ATV/PlexConnect no longer workng with 0.9.11.4 due to PlexHome. Disable PlexHome and life will ne restored to good again. I only suggest this as, after you mentioned Plex Home, did I find a single thread about it. Until then, I found nothing that references the problem.

    Any ETA for at least a work around with PlexHome enabled?

    Thanks!
  • baabaa Members, Plex Pass, Forum Moderator Posts: 3,954 Forum Mod
  • birgirrafnbirgirrafn Members, Plex Pass Posts: 2 Plex Pass

    I have the same problem.

    But how can I disable the PlexHome feature in order to get ATV/Plexconnect working again?

    I've done "Leave Home" and restarted PMS and Plexconnect but that did not fix it.

    Still PlexAPI gives the Unauthorized message.

    Thanks

    BR

  • baabaa Members, Plex Pass, Forum Moderator Posts: 3,954 Forum Mod

    I guess, in PMS you need to delete the other users. Or leave the home. Or something.

    Or do some reading over there...

    -> https://forums.plex.tv/topic/128879-plex-home/?p=837199

    It might just be what you need?

  • partizan76partizan76 Members, Plex Pass Posts: 41 Plex Pass

    Baa, in logs i see that:
    20:20:43 PlexAPI: No Response from Plex Media Server
    20:20:43 PlexAPI: We failed to reach a server. Reason: Unauthorized
    20:20:43 PlexAPI: Traceback:
    Traceback (most recent call last):
    File "/share/MD0_DATA/.qpkg/PlexConnect/PlexAPI.py", line 432, in getXMLFromPMS
    response = urllib2.urlopen(request, timeout=20)
    File "/share/MD0_DATA/.qpkg/Python/lib/python2.7/urllib2.py", line 154, in urlopen
    return opener.open(url, data, timeout)
    File "/share/MD0_DATA/.qpkg/Python/lib/python2.7/urllib2.py", line 437, in open
    response = meth(req, response)
    File "/share/MD0_DATA/.qpkg/Python/lib/python2.7/urllib2.py", line 550, in http_response
    'http', request, response, code, msg, hdrs)
    File "/share/MD0_DATA/.qpkg/Python/lib/python2.7/urllib2.py", line 475, in error
    return self._call_chain(*args)
    File "/share/MD0_DATA/.qpkg/Python/lib/python2.7/urllib2.py", line 409, in _call_chain
    result = func(*args)
    File "/share/MD0_DATA/.qpkg/Python/lib/python2.7/urllib2.py", line 558, in http_error_default
    raise HTTPError(req.get_full_url(), code, msg, hdrs, fp)
    HTTPError: HTTP Error 401: Unauthorized

    On ATV3 it shows empty Library section

  • partizan76partizan76 Members, Plex Pass Posts: 41 Plex Pass

    Of course Plex Home is disabled, IP address of ATV is added to server for allow connection without auth.

Sign In or Register to comment.