If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Newbie - Subtitles out of Sync

Hey,

 

I am very new to plex, i bought a NOW TV box and have managed to get plex on it.

 

I am running the plex server from my Mac.

 

The issue I am having is subtitles getting out of sync when pausing, forwarding, resuming. If i don't do any of these the subtitles are perfectly in sync. I am hard of hearing so use subtitles to help understand what is happening.

 

I have seen a few topics with similar issues but I am a complete novice when it comes to plex etc so need someone to help me get the correct settings.

 

I am adding a .srt file with the same name as the movie to get the subtitles to show.

 

Can anyone help with this issue?

 

Thanks

Comments

  • theuser86theuser86 Posts: 575Members ✭✭✭
    1. What are the specs of your Mac?
    2. If it is powerful enough you can transcode the video to burn in the subtitles. After selecting the subtitles, change the playback to "Transcode" rather than "Automatic". That should keep them in sync.
  • ElliotReeveyElliotReevey Posts: 7Members

    1. Its a MBP, Dual core, 2.8Ghz with 8GB RAM.

    2. This is done in the playback options? or on the server?

  • theuser86theuser86 Posts: 575Members ✭✭✭
    That is fast enough to transcode video.

    Yes it is in the Plex channel on the Roku under Playback options. It is not on the server.
  • arnoldburianarnoldburian Posts: 8Members, Plex Pass Plex Pass

    If you grabbed the SRT file of the internet, remember that you have to try a bunch until you find one that syncs with your video. Also, configure your Roku in the Plex settings to always transcode video and burn in subtitles. That will force everything to sync together.

  • ElliotReeveyElliotReevey Posts: 7Members
    Thanks, I'll give the suggestions a try. How do I burn in the subtitles? Can I do this with .srt files? Thanks
  • theuser86theuser86 Posts: 575Members ✭✭✭
    Yes you can, select the subtitles and then set it to Transcode under playback options. Do not use Automatic. That will cause the Plex Media Server to burn in the subtitles.
  • ElliotReeveyElliotReevey Posts: 7Members
    The subtitles sync if I watch on the desktop so I know it syncs. I have selected transcode from the playback options then enable close captioning once it's playing. Still out of sync if I fast forward. Any ideas? Thanks
  • theuser86theuser86 Posts: 575Members ✭✭✭
    edited December 2014
    You should not have to enable close captioning once it is playing if you select the subtitles from playback options and set it to Transcode. Select it from the playback options screen and set it to transcode, this is how subtitles get burned in.

    If you wait to select the subtitles from close captioning while playing, this will again make them soft subtitles, not burned in as I suggested.
  • ElliotReeveyElliotReevey Posts: 7Members

    Ok, at the moment my subtitles show up as "Unknown" which I put down to the fact I don't have .en for the language in the subtitle file name. If I add this perhaps it will auto load the subtitles. I will try it this evening.

    Thanks

  • theuser86theuser86 Posts: 575Members ✭✭✭
    Yes even if they show up as "Unkown*" you can still select them under Playback options.
  • ElliotReeveyElliotReevey Posts: 7Members

    Yes, but then I still have to select enable them once playback starts, they dont show automatically?

  • theuser86theuser86 Posts: 575Members ✭✭✭

    If you select the SRT subtitle file from the Playback options and then set it to Transcode, the subtitles should show up automatically without hitting the * button while playing. The * button while playing is for "soft" subtitles.

    In the Captions settings under the System settings (outside of Plex), the setting is "On" right?

  • stormensestormense Posts: 8Members ✭✭

    Same trouble here Auto or burn in don't matter. In Kodi it works perfect but on the Plex ap on my Samsung the subtitles comes to early. binhex-plex docker on a Unraid server.

Sign In or Register to comment.