If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Plex plugin / server won't start after upgrade

jdslistsjdslists Posts: 5Members, Plex Pass Plex Pass

I've updated to the most recent version of plex (v0.9.11.7.803-87d0708) using the plex pass method (shell update) from other threads.  I'm also running the most recent stable build of FreeNAS, FreeNAS-9.3-STABLE-201501241715 ,  but I cannot start the Plex plugin.  I toggle the switch from the off position, it spins for a few seconds, and then stays at Off.  I've rebooted the server several times to avail.

 

 

Can I try starting the plugin in verbose mode or something so we can see what's wrong?  If so, please let me know the terminal commands for that.  Otherwise, any other thoughts on getting the server started?  Thanks in advance!!

Tagged:
«1

Comments

  • mtritterbuschmtritterbusch Posts: 2Members, Plex Pass Plex Pass

    Similar situation, except I upgraded from the latest 9.2 and things weren't quite working right with the plex plugin, so I deleted from the interface (and the jail) and have tried unsuccessfully several times to get it to install successfully (from the web gui).

    I don't know if this helps:

    Request Method: GET Request URL: http://192.168.1.52/plugins/plexmediaserver/1/_s/ Software Version: FreeNAS-9.3-STABLE-201501241715 Exception Type: error Exception Value:
    [Errno 60] Operation timed out
    Exception Location: /usr/local/lib/python2.7/socket.py in create_connection, line 571 Server time: Sat, 24 Jan 2015 17:32:25 -0600
    Traceback
    Environment:
     
    Software Version: FreeNAS-9.3-STABLE-201501241715
    Request Method: GET
     
     
    Traceback:
    File "/usr/local/lib/python2.7/site-packages/django/core/handlers/base.py" in get_response
      112.                     response = wrapped_callback(request, *callback_args, **callback_kwargs)
    File "/usr/local/www/freenasUI/../freenasUI/plugins/views.py" in plugin_fcgi_client
      579.     status, headers, body, raw = app(env, args=args)
    File "/usr/local/www/freenasUI/../freenasUI/plugins/utils/fcgi_client.py" in __call__
      222.         sock = self._getConnection()
    File "/usr/local/www/freenasUI/../freenasUI/plugins/utils/fcgi_client.py" in _getConnection
      340.                 sock = socket.create_connection(self._connect)
    File "/usr/local/lib/python2.7/socket.py" in create_connection
      571.         raise err
     
    Exception Type: error at /plugins/plexmediaserver/1/_s/
    Exception Value: [Errno 60] Operation timed out 
  • samesongsamesong Posts: 7Members, Plex Pass Plex Pass

    I'm having issues as well. I can't access my library from external devices any more.

  • DiceOfSevenDiceOfSeven Posts: 1Members

    Having issue aswell...it will work on initial install and setup but if i restart freenas for any reason the service turns off and wont come back on and I lose connection to it on all devices

  • Magnus33Magnus33 Posts: 269Members ✭✭

    If you make any changes to the permission on the drive with the jail in it plex wont work.

    This is new as of 9.3 freenas.

  • pdonovanpdonovan Posts: 37Members, Plex Pass Plex Pass
    Magnus33 wrote on February 2 2015, 8:19 PM: »

    If you make any changes to the permission on the drive with the jail in it plex wont work.

    This is new as of 9.3 freenas.

    Can you elaborate on what you mean by this? I've had Plex working on FreeNAS 9.3 since it was in pre-release. But my recent upgrade to 0.9.11.7 from (0.9.11.1) has left me with a Plex server that no longer works. The Plex and Plex DLNA processes are running, but they don't log a single thing, and nothing is being served. I'm running FreeNAS 9.3 STABLE.

  • ralplpcrralplpcr Posts: 28Members, Plex Pass Plex Pass
    edited March 2015

    Does anyone have any additional advice for this issue?  I am running FreeNAS 9.2, and am having a similar problem.  My home router died and needed to be replaced, and now I can no longer get my Plex plugin to start.  All the media is there, and I can connect to the share via CIFS, but the plugin itself just says "Some error occurred" when I try to start the Plex server.

    I can install a new Plex jail successfully, but it doesn't have any of my media, settings, or custom artwork in it. 

    Is there any fix to resurrecting my old Plex plugin?  Or at least copying all the settings from my old jail to a new one that will start?

  • ralplpcrralplpcr Posts: 28Members, Plex Pass Plex Pass
    ralplpcr wrote on March 15 2015, 10:20 PM: »

    Does anyone have any additional advice for this issue?  I am running FreeNAS 9.2, and am having a similar problem.  My home router died and needed to be replaced, and now I can no longer get my Plex plugin to start.  All the media is there, and I can connect to the share via CIFS, but the plugin itself just says "Some error occurred" when I try to start the Plex server.

    I can install a new Plex jail successfully, but it doesn't have any of my media, settings, or custom artwork in it. 

    Is there any fix to resurrecting my old Plex plugin?  Or at least copying all the settings from my old jail to a new one that will start?

    So it seems that the mapping of the jail to my actual storage somehow failed?  I'm not sure how (or why), but at least it's repairable.  Just had to create a new plex jail, map the storage to the same location, and I'm good to go. 

    Now if I could just understand why this happened... and what to do so that it doesn't again?

  • markshihmarkshih Posts: 5Members, Plex Pass Plex Pass
    edited March 2015

    So on FreeNAS 9.3(FreeNAS-9.3-CURRENT-201503130047) I did the upgrade manually. Two issues. 1-Needed to change the file permissions on the new Plex directory to match the old one. Root:operator is the owner and group. 2-Needed to add symbolic links to two files within the plexmediaserver directory.

    libpython2.7.so -> libpython2.7.so.1

    Plex_Media_Server -> Plex Media Server

     After that, then it should start.

  • csgregocsgrego Posts: 5Members ✭✭

    Hoping you can help.  I just updated my FreeNas to 9.3.  My Plex service will not turn on.  I restored my FreeNas to factory settings and attempted to reconfigure everything, but Plex still does not turn on.

    I looked at your suggestion, but all four files already exist in my jail.  Any other ideas?

    I get the following error when trying to turn on Plex:

    plexmediaserver_1 su: pam_start: system error

  • SweetAndLowSweetAndLow Posts: 30Members, Plex Pass Plex Pass
    ralplpcr wrote on March 15 2015, 10:20 PM: »

    Does anyone have any additional advice for this issue?  I am running FreeNAS 9.2, and am having a similar problem.  My home router died and needed to be replaced, and now I can no longer get my Plex plugin to start.  All the media is there, and I can connect to the share via CIFS, but the plugin itself just says "Some error occurred" when I try to start the Plex server.

    I can install a new Plex jail successfully, but it doesn't have any of my media, settings, or custom artwork in it. 

    Is there any fix to resurrecting my old Plex plugin?  Or at least copying all the settings from my old jail to a new one that will start?

    I bet your ip address range changed and now your jails are configured incorrectly. Fix up your jails settings so your Plex server jail gets an ip on your new network.

  • SweetAndLowSweetAndLow Posts: 30Members, Plex Pass Plex Pass
    Hawg97 wrote on April 5 2015, 12:43 AM: »

    Hoping you can help.  I just updated my FreeNas to 9.3.  My Plex service will not turn on.  I restored my FreeNas to factory settings and attempted to reconfigure everything, but Plex still does not turn on.

    I looked at your suggestion, but all four files already exist in my jail.  Any other ideas?

    I get the following error when trying to turn on Plex:

    plexmediaserver_1 su: pam_start: system error

    You need to delete your plugin/jail. You modified the permission of your jail dataset and that breaks all jails in that dataset. Don't every make permission modification to the top level jail dataset because that changes the permissions of all the OS files for your jails.

  • jxb1234jxb1234 Posts: 20Members, Plex Pass Plex Pass

    I've just changed the jail permissions in freenas 9.3 so that i could copy a plugin to the plugins folder as access was denied before.

    Now guess what, it doesn't start. So what are the steps to getting plex to start again, did anyone get it going after changing jail permissions?

    I really don't want to have to reinstall plex again as I had to do significant modifications to meta data because quite a lot of my DVDs were not "matching" correctly.

  • jxb1234jxb1234 Posts: 20Members, Plex Pass Plex Pass

    Well i've had to delete and reinstall plex again as i messed up the jail permissions and due to the lack of docs for freenas i've lost all my meta, again.

    Can the devs please add a feature to export/import the meta and settings, and update the docs so it's possible to find the correct meta and settings folders for backup when reinstall is required? Please?

    There are 11,941 folders in the plex media server jail !! Insane!

  • davidjwbaileydavidjwbailey Posts: 1Members, Plex Pass Plex Pass
    Magnus33 wrote on February 2 2015, 8:19 PM: »

    If you make any changes to the permission on the drive with the jail in it plex wont work.

    This is new as of 9.3 freenas.

    THIS

    as a non-python-wielding amateur, my experience of plex on freenas is as follows:

    1 - dare to change any permissions or user or group that touches even a single volume of your media = will not restart next time
    2 - jail says "running" = this is a lie
    3 - change user name in windows and upload a file = file will never be read or indexed by Plex
    4 - mounted storage will unmount at random

    5 - integration with Transmission or CouchPotato needs several PhDs in computer science and a week in a dark room. It will then fall over for no reason what so ever, even if you don't touch anything and just let it run 


    Summary: absolutely NOT ready for domestic deployment. This is a "lab alpha" product at best, suitable only for hardcore technicians.

  • fzootafzoota Posts: 3Members, Plex Pass Plex Pass

    I recently had a thunder storm which blew out the USB storage my Freenas OS was installed. I had to reinstall Freenas and the Plex plugin. I eventually got both Freenas and Plex up and running, directing Plex to the location of all my media folders. I ordered a UPS to avoid any further blow outs. I shut down my server, plugged in the UPS and rebooted. Now the Plex plugin won't turn on.

    Am I understanding correctly? The only solution is to reinstall a new Plex plugin, which I believe gives me a new IP address, and point Plex to all the various media folder on my server? If so, this is a nightmare.

  • TeKEffectTeKEffect Posts: 2Members, Plex Pass Plex Pass
    You guys aren't alone. I just replaced my router with a new one and plex wouldn't start. I was upset at losing all my meta data and settings but I reinstalled and set up a new jail pointing to the media. Still no dice all I get is some error occurred. I thought I was technical enough to figure out how to set up a media server on mature software but this is turning into a painful ride
  • simpsnsimpsn Posts: 21Members, Plex Pass Plex Pass

    Same here. Dead Plex Media Server. Sad that nothing ever works with this setup.

  • kawausfamekawausfame Posts: 2Members

    I don't know what's wrong with freenas !!! It was cool at first : I installed plex, everything ran fine until I rebooted it.... Now, I must reinstall plex, EACH TIME I RESTART THE GODDAMN NAS for it to work normally until the next reboot... Seriously, i'm gonna switch to debian if there's no solution :(

  • tootsmcgeetootsmcgee Posts: 259Members, Plex Pass Plex Pass

    Maybe try getting a console into the plex plugin instance and checking the logs, or trying to start it from the command line? Hard to tell what is wrong without any info.

    If your problem is specific to the FreeNAS plugin, you might have better luck asking over at the freenas forums. If all else fails, you could try setting up a vanilla jail in freenas and installing plex via the freebsd package.

    However, if you are more comfortable administering debian, then maybe it would work out better for you.
    Anecdotally, I run plex in a plain jail on vanilla freebsd-10.2, and it has been pretty working well for me -- other than the occasional issue with plex itself of course. ;)

  • kawausfamekawausfame Posts: 2Members

    I think I'm gonna go full debian, because the jail system is really poorly documented and I just can't get a plugin working correctly : Vanilla jail ? Fail. Installing a plugin from the repository ? Fail. It's always telling me : "can't re-name node epair0b"... I'm losing my patience :'(

«1
Sign In or Register to comment.