Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

"Buffering..." got you down? Read here.

mattseeleymattseeley HawaiiPosts: 1,322 Plex Employee
edited February 2015 in PlayStation

I need Your help. Yes You with the files that play on all other devices but not your PS3/PS4. Also You seeing buffering of on ultra gigaMegaULTRABIT network. And You with the wireless access point is sitting on top of the PSX. And especially You who flirted with 20Mbps quality a couple times, got burned and went back to 8Mbps, saw more problems (why me? why?!) and are now desolate in the gutter with other lowly Mbps. Rally with me ladies, gentlemen, and canine!
 
Here's what I know of "Buffering...":

  • At about 50% of the way through playback of a movie the PlayStation 3 and 4 sometimes get "stuck". Customers are needing to exit and resume playback.
    • We've reproduced this ourselves and are working to isolate the issue. 
  • The PS3/4 (4 especially) is computationally fast enough to handle higher bitrate media but the memory available for buffering is too low. This is the primary cause of "Buffering..." in my estimation.
    • If you're playing at too high a quality, you're gonna have to turn the quality down.
    • A NAS may not have the horsepower to transcode / remux streams for PS3/4 depending on the source material.
  • I'm concerned with you seeing buffering on <= 8Mbps videos. Similar issues we've run into on other platforms are usually caused by a system library which wasn't written or isn't configured to work with enough media format disparity.
    • The only way we'll fix this is to be able to identify commonalities and reproduce the issue.

That last bit is huge. Plex customers, I need posts with actionable data.
 
When you have a problem with playback stopping/starting/buffering unusually, please post:

  • The XML media information for the library item you tried to play
  • Playing locally? What was the selected local quality?
  • Playing remotely? What was the selected remote quality?
  • Which audio stream were you listening too?
  • Does the bad behavior happen on all videos some of the time?
  • Or, some videos all of the time?
  • Are the problematic videos mostly MP4/M4V?

If you want serious, I mean serious, bonus points consider:

  • Generating a 5 minute sample of a video which shows the problem. Add this sample back to your library and give it a test play on the PS3/4. If the same problem exists then (EUREKA!) send me a private message. We can figure out a way to get the file from you. Sample files which reproduce the problem are worth double their bytes in gold.
This discussion has been closed.