Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

PlexPy - Another Plex Monitoring Program

12357313

Comments

  • drzoidberg33drzoidberg33 Members, Plex Employee, Plex Pass, Plex Ninja Posts: 2,562 Plex Employee
    mkennedy2547 wrote on June 30 2015, 8:30 PM: »

    It gave no response either as http or telnet to port 8181.  Something in the way I set it up first conflicted with the update you did with the latest git.  If he can get it running that fast, it shouldn't be this difficult.  I just need to start over and do it right from the start.  

    Does it put any config or settings anywhere besides the /opt/plexpy directory?

    Nope it's totally self-contained. All data resides in the PlexPy folder.

  • mkennedy2547mkennedy2547 Members, Plex Pass Posts: 74 Plex Pass
     tail -f plexpy.log
    30-Jun-2015 16:44:24 - DEBUG   :: MainThread : Git output: 0a170c20e6b5080906340275242a8cab1aec5123
    30-Jun-2015 16:44:24 - DEBUG   :: MainThread : Trying to execute: "git rev-parse --abbrev-ref HEAD" with shell in /opt/plexpy
    30-Jun-2015 16:44:24 - DEBUG   :: MainThread : Git output: master
    30-Jun-2015 16:44:24 - INFO    :: MainThread : Retrieving latest version information from GitHub
    30-Jun-2015 16:44:24 - DEBUG   :: MainThread : Requesting URL via GET method: https://api.github.com/repos/drzoidberg33/plexpy/commits/master
    30-Jun-2015 16:44:24 - DEBUG   :: MainThread : Latest version is 0a170c20e6b5080906340275242a8cab1aec5123
    30-Jun-2015 16:44:24 - INFO    :: MainThread : PlexPy is up to date
    30-Jun-2015 16:44:24 - INFO    :: MainThread : Daemonized to PID: 2870
    30-Jun-2015 16:44:24 - INFO    :: MainThread : Writing PID 2870 to /var/run/plexpy/plexpy.pid
    30-Jun-2015 16:44:24 - INFO    :: MainThread : Starting PlexPy web server on http://192.168.0.4:8181/
  • mkennedy2547mkennedy2547 Members, Plex Pass Posts: 74 Plex Pass
    edited June 2015

    I get no response from telnet or browser when going to that address. 

    Just to be sure, I disabled the firewall to test it. 

     sudo ufw disable
    Firewall stopped and disabled on system startup
  • hthighwayhthighway Members, Plex Pass, Plex Ninja Posts: 6,514 Plex Ninja
    mkennedy2547 wrote on June 30 2015, 8:47 PM: »
     tail -f plexpy.log
    30-Jun-2015 16:44:24 - DEBUG   :: MainThread : Git output: 0a170c20e6b5080906340275242a8cab1aec5123
    30-Jun-2015 16:44:24 - DEBUG   :: MainThread : Trying to execute: "git rev-parse --abbrev-ref HEAD" with shell in /opt/plexpy
    30-Jun-2015 16:44:24 - DEBUG   :: MainThread : Git output: master
    30-Jun-2015 16:44:24 - INFO    :: MainThread : Retrieving latest version information from GitHub
    30-Jun-2015 16:44:24 - DEBUG   :: MainThread : Requesting URL via GET method: https://api.github.com/repos/drzoidberg33/plexpy/commits/master
    30-Jun-2015 16:44:24 - DEBUG   :: MainThread : Latest version is 0a170c20e6b5080906340275242a8cab1aec5123
    30-Jun-2015 16:44:24 - INFO    :: MainThread : PlexPy is up to date
    30-Jun-2015 16:44:24 - INFO    :: MainThread : Daemonized to PID: 2870
    30-Jun-2015 16:44:24 - INFO    :: MainThread : Writing PID 2870 to /var/run/plexpy/plexpy.pid
    30-Jun-2015 16:44:24 - INFO    :: MainThread : Starting PlexPy web server on http://192.168.0.4:8181/

    From the linux box that is running plexpy what does the following return?

    sudo netstat -ntlp | grep :8181
    
    
    • Paul
  • mkennedy2547mkennedy2547 Members, Plex Pass Posts: 74 Plex Pass
    edited June 2015
     sudo netstat -ntlp | grep :8181
    tcp        0      0 192.168.0.4:8181        0.0.0.0:*               LISTEN      2776/python
     
     
     
     
    I have to take off for a bit, so I will check back on the thread later.  Thank you all for your time and assistance.  
     
     
    I might just do the Windows version.  I was just trying to save some load since I have around 20 people that use this server.  Transcoding can get a bit rough at times.  
  • hthighwayhthighway Members, Plex Pass, Plex Ninja Posts: 6,514 Plex Ninja
    edited June 2015

    EDIT: from your above post it seems the port is open

    Do you have any rules setup blocking that port?

    sudo iptables -L
    
    or 
    
    sudo ufw status
    
    • Paul
  • drzoidberg33drzoidberg33 Members, Plex Employee, Plex Pass, Plex Ninja Posts: 2,562 Plex Employee

    Your service should be running on 0.0.0.0:8181.

    Also, do you get any response if you query the page directly from the server like:

    curl http://127.0.0.1:8181

    Should return:

    This resource can be found at <a href="http://127.0.0.1:8181/home">http://127.0.0.1:8181/home</a>.
  • feat06feat06 Members, Plex Pass Posts: 5 Plex Pass

    latest update is causing this for me 

    [attachment=52429:plexpy error.PNG]

    tried force refresh in chrome, and incognito window. still pulls show data , charts, even history for a user etc, just when clicking history at the top doesn't work. 

  • mkennedy2547mkennedy2547 Members, Plex Pass Posts: 74 Plex Pass
    DrJohnZoidberg wrote on June 30 2015, 8:55 PM: »

    Your service should be running on 0.0.0.0:8181.

    Also, do you get any response if you query the page directly from the server like:

    curl http://127.0.0.1:8181

    Should return:

    This resource can be found at <a href="http://127.0.0.1:8181/home">http://127.0.0.1:8181/home</a>.

    When I do it at localhost(127.0.0.1) I get no response.  I do get the response when I use 192.168.0.4.  

      curl http://192.168.0.4:8181

    This resource can be found at <a href="http://192.168.0.4:8181/home">http://192.168.0.4:8181/home</a>.

  • mkennedy2547mkennedy2547 Members, Plex Pass Posts: 74 Plex Pass
    hthighway wrote on June 30 2015, 8:53 PM: »

    EDIT: from your above post it seems the port is open

    Do you have any rules setup blocking that port?

    sudo iptables -L
    
    or 
    
    sudo ufw status
    

    Status: active

    Logging: on (low)

    Default: deny (incoming), allow (outgoing), disabled (routed)

    New profiles: skip

     

    To                         Action      From

    --                        


          ----

    37/tcp                     ALLOW IN    Anywhere

    80/tcp                     ALLOW IN    Anywhere

    443/tcp                    ALLOW IN    Anywhere

    21/tcp                     ALLOW IN    Anywhere

    8080/tcp                   ALLOW IN    Anywhere

    25/tcp                     ALLOW IN    Anywhere

    110/tcp                    ALLOW IN    Anywhere

    143/tcp                    ALLOW IN    Anywhere

    8181/tcp                   ALLOW IN    Anywhere

    37/tcp (v6)                ALLOW IN    Anywhere (v6)

    80/tcp (v6)                ALLOW IN    Anywhere (v6)

    443/tcp (v6)               ALLOW IN    Anywhere (v6)

    21/tcp (v6)                ALLOW IN    Anywhere (v6)

    8080/tcp (v6)              ALLOW IN    Anywhere (v6)

    25/tcp (v6)                ALLOW IN    Anywhere (v6)

    110/tcp (v6)               ALLOW IN    Anywhere (v6)

    143/tcp (v6)               ALLOW IN    Anywhere (v6)

    8181/tcp (v6)              ALLOW IN    Anywhere (v6)

  • drzoidberg33drzoidberg33 Members, Plex Employee, Plex Pass, Plex Ninja Posts: 2,562 Plex Employee
    mkennedy2547 wrote on July 1 2015, 12:38 PM: »

    When I do it at localhost(127.0.0.1) I get no response.  I do get the response when I use 192.168.0.4.  

      curl http://192.168.0.4:8181

    This resource can be found at <a href="http://192.168.0.4:8181/home">http://192.168.0.4:8181/home</a>.

    Did you change the http_host variable in the ini file? That should stay 0.0.0.0, then you'll be able to access it via localhost.

  • mkennedy2547mkennedy2547 Members, Plex Pass Posts: 74 Plex Pass
    edited July 2015
    DrJohnZoidberg wrote on July 1 2015, 12:53 PM: »

    Did you change the http_host variable in the ini file? That should stay 0.0.0.0, then you'll be able to access it via localhost.

    yes, I changed that to the actual ip of the server since I will be accessing it from a different machine.  It is the server version of Ubuntu so there's only the text-only browser and no gui. 

    I just changed it back, and am rebooting. 

     
    I'm still unable to get it to load in a browser from another machine on my local network.
  • mkennedy2547mkennedy2547 Members, Plex Pass Posts: 74 Plex Pass

    I just updated to the latest commit.  I now get the same response from 192.168.0.4 as I do from localhost on 8181.  Still unable to load it from the local network going to the http://192.168.0.4:8181 address.  

  • hthighwayhthighway Members, Plex Pass, Plex Ninja Posts: 6,514 Plex Ninja
    mkennedy2547 wrote on July 1 2015, 2:41 PM: »

    I just updated to the latest commit.  I now get the same response from 192.168.0.4 as I do from localhost on 8181.  Still unable to load it from the local network going to the http://192.168.0.4:8181 address.  

    From the other machine can you "ping 192.168.0.4" and get a response?

    • Paul
  • drzoidberg33drzoidberg33 Members, Plex Employee, Plex Pass, Plex Ninja Posts: 2,562 Plex Employee
    mkennedy2547 wrote on July 1 2015, 2:41 PM: »

    I just updated to the latest commit.  I now get the same response from 192.168.0.4 as I do from localhost on 8181.  Still unable to load it from the local network going to the http://192.168.0.4:8181 address.  

    Everything that you've shown us so far suggests that PlexPy is up and running on the server. You can access the home page from the local host which says PlexPy is most definitely running.

    How many remote hosts have you tried to access it from? Maybe an issue with that one machine you're testing from?

  • mkennedy2547mkennedy2547 Members, Plex Pass Posts: 74 Plex Pass
    hthighway wrote on July 1 2015, 2:43 PM: »

    From the other machine can you "ping 192.168.0.4" and get a response?

    Yes, it responds to ping from local network.  

  • mkennedy2547mkennedy2547 Members, Plex Pass Posts: 74 Plex Pass
    DrJohnZoidberg wrote on July 1 2015, 2:45 PM: »

    Everything that you've shown us so far suggests that PlexPy is up and running on the server. You can access the home page from the local host which says PlexPy is most definitely running.

    How many remote hosts have you tried to access it from? Maybe an issue with that one machine you're testing from?

    I just added port fwding to my router and tried from an outside machine (OSX Mavericks) as well as my other 3 computers on the local network.

    2 Windows 7 64, 1 Mac OS X Yosemite.  

  • mkennedy2547mkennedy2547 Members, Plex Pass Posts: 74 Plex Pass

    At this point, it almost certainly has something to do with the LAMP stack and ISPConfig running on the Ubuntu Server don't you think? 

  • mkennedy2547mkennedy2547 Members, Plex Pass Posts: 74 Plex Pass

    Feel free to try from your own:   http://michaelkennedy.cc:8181  

    I'll even give you SSH access if you want to look at it yourself.  There is nothing of that much importance on it.  Just my own little sandbox.  

  • drzoidberg33drzoidberg33 Members, Plex Employee, Plex Pass, Plex Ninja Posts: 2,562 Plex Employee
    mkennedy2547 wrote on July 1 2015, 2:53 PM: »

    Feel free to try from your own:   http://michaelkennedy.cc:8181  

    I'll even give you SSH access if you want to look at it yourself.  There is nothing of that much importance on it.  Just my own little sandbox.  

    PM me the details and when I get a moment I can take a look for you.

Sign In or Register to comment.