If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Subtitles: Top Ten Ways to Screw Them Up in Plex on Roku

scrognoidscrognoid Posts: 31Members ✭✭

If you haven't had trouble with subtitles with Plex/Roku, then you're not trying. I found eight subtitles switches in less than an hour this morning (after spending 30 minutes last night trying unsuccessfully to get it to work so the gang could watch a movie.) Post your own and let's get this list to ten (or more).

1) Names - Folder name, .mv4, *.srt must be the same. *.srt next to *.mp4 but NOT in their own folder did not work
2) Roku Settings - Caption Mode = On
3) Plex Preferences on TV - Subtitles = Soft (recommended) is working for me
4) Video Playback Options for show on TV - Subtitle Stream = Unknown (SRT)
[one of the ways to toggle subtitles on/off]
5) * key on Roku remote while playing show [one of the ways to toggle subtitles on/off]
6) Plex Web Interface for the specific show - Subtitles = Unknown (SRT) [one of the ways to toggle subtitles on/off]
7) Plex Web Interface Settings>Server>Languages - Subtitle Mode = Always Enabled is working for me now
8) Plex Web Interface Settings>Web>Player - Subtitles = beats the hell out of me. I've got Burn Subtitles = Always and it's working

There's bound to be more software switches controlling subtitles. What have you found?

Comments

  • weirdboyweirdboy Posts: 7Members, Plex Pass Plex Pass
    edited July 2015

    The "Unknown (SRT)" is because the file should be named with the language included in the extension.

    e.g. for English subtitles, try naming the file *.en.srt or for, say, Italian subtitles, try *.it.srt. Plex will then correctly identify and display the language in the subtitle choices.

    However, I have still had issues with subtitles on Roku randomly not working for some things, but working for others. It remains a mystery to me because it's not like I'm going into my Roku or Plex settings and messing around with them all the time. I have a Chromecast as well, so usually when this happens now, I switch over to that where subtitles work more reliably.

  • diatodaydiatoday Posts: 2Members ✭✭

    How do you know the caption format?
    I have some tv shows recorded by Windows Media Center (file names are *.wpv) and some by Hauppage's WinTV 8 (file names are *.ts). Both come up on my Roku Plex player as format unknown.

  • TheSatmanTheSatman Posts: 227Members ✭✭

    I learned that even if you have Caption On in roku, and the correct name.language.srt format, and streaming modus from plex is set to whatever works best for you, sometimes Roku won't show subs at all.

    Apparently it has something to do with the text coding (save as) from when the file was srt file first originally was created.When this happens the fix for me is to :

    1. load the file in http://subsyncer.appspot.com/step1
    2. Do not change anything in step 2
    3. From step 3, save back to computer and overwrite the original file.

    Now exit Plex on your Roku, start Plex app again, and watch your TV show or Movie with working subs.

    The era of movie viewing in the dark has passed!!!

     

    Plex Media Server: Windows 10 Home x64 ,AMD A10-5800K 4,10 GHz, 16Gb RAM

    Media Storage: 2 + 1 TB Network shared USB Hard Drive // 

    8 TB Synology Hybrid Raid (with data protection of 1 disk fault-tolerance)on XPEnology DSM 5.0- 4458 VM on VMware ESXi 5.1.0, HP ProLiant N54L

    Plex Clients: Roku 3 // Xbox 360 // Multiple Android devices // iPad1 // iPad3 // iPod Touch // Plex/Web

    Home entertainment: Pioneer VSX-921 // Pioneer BDP-140 // 5500ANSI Full HD 1080P DLP 3D Projector // 85" Mocom 2D /HD, Passive/Active 3D Projection Screen - 20 Gain // 32" HDMI TV // 50Mb-50Mb Fiber internet connection

  • lleblleb Posts: 21Members ✭✭

    @TheSatman said:
    I learned that even if you have Caption On in roku, and the correct name.language.srt format, and streaming modus from plex is set to whatever works best for you, sometimes Roku won't show subs at all.

    Apparently it has something to do with the text coding (save as) from when the file was srt file first originally was created.When this happens the fix for me is to :

    1. load the file in http://subsyncer.appspot.com/step1
    2. Do not change anything in step 2
    3. From step 3, save back to computer and overwrite the original file.

    Now exit Plex on your Roku, start Plex app again, and watch your TV show or Movie with working subs.

    your link fails. i uploaded several working .srt files and it does nothing.

    I too am having the issue with Roku 3 failing to support .srt files. they are named properly, they are in the same folder as the video, they work flawlessly via any web based device (web browsers, phones (android), tables (ipad)), but after an update a while back about 80% of them stopped working on my Roku. This is most annoying when its a foreign language movie and I want native subtitles.

    The major problem here is Roku points to Plex, Plex points to Roku as the problem. Both of the companies need to get their act together to resolve this KNOWN issue.

  • TheSatmanTheSatman Posts: 227Members ✭✭

    @lleb : please attach your srt file, so I can have a look.

    The era of movie viewing in the dark has passed!!!

     

    Plex Media Server: Windows 10 Home x64 ,AMD A10-5800K 4,10 GHz, 16Gb RAM

    Media Storage: 2 + 1 TB Network shared USB Hard Drive // 

    8 TB Synology Hybrid Raid (with data protection of 1 disk fault-tolerance)on XPEnology DSM 5.0- 4458 VM on VMware ESXi 5.1.0, HP ProLiant N54L

    Plex Clients: Roku 3 // Xbox 360 // Multiple Android devices // iPad1 // iPad3 // iPod Touch // Plex/Web

    Home entertainment: Pioneer VSX-921 // Pioneer BDP-140 // 5500ANSI Full HD 1080P DLP 3D Projector // 85" Mocom 2D /HD, Passive/Active 3D Projection Screen - 20 Gain // 32" HDMI TV // 50Mb-50Mb Fiber internet connection

  • dstavrosdstavros Posts: 6Members, Plex Pass Plex Pass

    I use MCEBuddy to convert recordings done in Windows Media Center to MP4 format and also extract subtitles to an srt file. I found only about 1 in 3 subtitles would play on the roku with plex while all played fine on the PC. I now use Subtitle Edit to fix the subtitle files. Under "tools" there is an option "fix common errors" which apparently corrects the issues plex /roku has with many subtitle files. You can run this program in batch mode and correct many subtitle files in a few minutes.

  • dickydarkodickydarko Posts: 1Members, Plex Pass Plex Pass

    @dstavros Thank you so much for the Subtitle Edit info! This was driving me nuts but running the fix, you know, fixed it.

    While trying to figure this out I came across something kind of interesting; when streaming from the roku with the burn option set to automatic the subtitles did not work and the stream was direct. When telling it to always burn it did work (at the cost of transcoding). On my chromecast the subs worked without adjusting anything but the server transcoded. After running the Subtitle Fix on the subtitle file both now direct stream with subtitles no problem.

    I believe that since the chromecast does not have an interface for specifying subtitle burn in that it first tries without and the chromecast either tells plex it'll work or not and if not then the server is triggered to transcode. The Roku interface either does not communicate the success/failure of subtitles or the plex software isn't checking since the user has the ability to specify burn in if it's not working. Not that it matters a whole lot, just thought it was interesting.

  • mahjohnmahjohn Posts: 140Members, Plex Pass Plex Pass

    Bump....Cheers!

    Updated the link to the one below. I had edited my .SRT file at another site several times over to get it to sync, after which it played on the web, but not on my Roku 3. Uploaded, selected "FPS Resync", changed nothing...downloaded, uploaded, overwrote the original file. Subs now working.

    Note: Set Plex Captions Mode to On under Settings>Streams, and enabled Captions in Roku settings.

    subsyncer.com

  • kamikazi0495kamikazi0495 Posts: 7Members, Plex Pass Plex Pass

    Number two from the original post fixed my problem. Of course, I became well versed in finding and naming subtitles by the time I finally realized my ROKU settings was the problem.

    2) Roku Settings - Caption Mode = On (in my case - ROKU TV - Always On - did the trick).

Sign In or Register to comment.