Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

DTS audio issues

marcguidomarcguido Members Posts: 17 ✭✭
edited July 2015 in Plex Classic for Roku

I'm stumped, and could sure use some help and advice.

I'm having issues trying to direct play MKV files encoded with DTS 5.1 audio tracks. First, here's my setup:

  • Roku 3
  • Onkyo TX-SR505 AVR, which according to the owner's manual can process Dolby Digital EX and Dolby Pro Logic IIx, DTS, DTS-ES Matrix/Discrete, DTS Neo:6, DTS 96/24, and Linear PCM
  • LG Electronics 47LV5400 television
  • PMS running on a Dell Vostro 400 desktop machine

The Roku 3 is connected via HDMI cable to one of the receiver's two (yeah, it's an older model) HDMI inputs. The receiver is connected to the TV via HDMI output. In the Plex Roku channel's audio preferences I have 5.1 AC-3 Support and 5.1 DTS Support both enabled.

While I'm getting varying results depending on what movie file I'm playing, none of them result in the receiver indicating that the source file is DTS. This leads me to suspect that despite the receiver's support and my audio preferences, Plex is still transcoding the DTS audio into AC3. Here are two examples:

Example 1: For the following movie, I get no sound at all when using Direct Play. This movie only has a DTS audio track. Direct Stream/Transcode results in the receiver indicating that the source is PCM and the receiver displays "PLII Movie" as the listening mode. Even though DTS is the only audio track available in the file, DTS audio is not an available option when manually scrolling through the available listening modes on the receiver.

H:\Public\Shared Videos\Movies\The Magic Of Flight\The.Magic.of.Flight.1996.DOCU.1080p.BluRay.x264.DTS-FGT.mkv
General
Unique ID : 224186521982434803593355025021005728517 (0xA8A8C0EAB5EB399E931370AD57F00B05)
Complete name : H:\Public\Shared Videos\Movies\The Magic Of Flight\The.Magic.of.Flight.1996.DOCU.1080p.BluRay.x264.DTS-FGT.mkv
Format : Matroska
Format version : Version 2
File size : 3.55 GiB
Duration : 39mn 20s
Overall bit rate : 12.9 Mbps
Encoded date : UTC 2009-05-29 00:14:02
Writing application : mkvmerge v2.8.0 ('The Tree') built on May 14 2009 09:28:39
Writing library : libebml v0.7.7 + libmatroska v0.8.1
Video #1
ID : 1
Format : AVC
Format/Info : Advanced Video Codec
Format profile : High@L4.1
Format settings, CABAC : Yes
Format settings, ReFrames : 5 frames
Codec ID : V_MPEG4/ISO/AVC
Duration : 39mn 20s
Bit rate : 11.4 Mbps
Width : 1 920 pixels
Height : 1 080 pixels
Display aspect ratio : 16:9
Frame rate mode : Constant
Frame rate : 23.976 fps
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Progressive
Bits/(Pixel*Frame) : 0.230
Stream size : 3.07 GiB (86%)
Writing library : x264 core 67 r1153M 7b6ce6a
Encoding settings : cabac=1 / ref=5 / deblock=1:-3:-3 / analyse=0x3:0x113 / me=umh / subme=9 / psy_rd=0.8:0.8 / mixed_ref=1 / me_range=48 / chroma_me=1 / trellis=2 / 8x8dct=1 / cqm=0 / deadzone=21,11 / chroma_qp_offset=-4 / threads=6 / nr=0 / decimate=0 / mbaff=0 / bframes=5 / b_pyramid=1 / b_adapt=2 / b_bias=0 / direct=3 / wpredb=1 / keyint=250 / keyint_min=25 / scenecut=40 / rc=2pass / bitrate=11410 / ratetol=1.0 / qcomp=0.60 / qpmin=10 / qpmax=51 / qpstep=4 / cplxblur=20.0 / qblur=0.5 / ip_ratio=1.40 / pb_ratio=1.30 / aq=1:0.80
Default : Yes
Forced : No
Audio #2
ID : 2
Format : DTS
Format/Info : Digital Theater Systems
Mode : 16
Format settings, Endianness : Big
Codec ID : A_DTS
Duration : 39mn 20s
Bit rate mode : Constant
Bit rate : 1 509 Kbps
Channel(s) : 6 channels
Channel positions : Front: L C R, Side: L R, LFE
Sampling rate : 48.0 KHz
Bit depth : 24 bits
Compression mode : Lossy
Stream size : 425 MiB (12%)
Default : Yes
Forced : Yes

Example 2: For the following movie, which has both DTS and Dolby AC3 5.1 audio tracks, it will work with Direct Play, but even if I select the DTS audio track in Playback Options the receiver still indicates that the source is Dolby Digital. Once again, DTS audio is not an available option when manually scrolling through the available listening modes on the receiver.

H:\Public\Shared Videos\Movies\IMAX Grand Canyon Adventure River At Risk\IMAX.Grand.Canyon.Adventure.River.At.Risk.2008.1080p.BluRay.x264-CLASSiC_ac3.mkv
General
Unique ID : 221001039535501148911385853834272296368 (0xA6434081A4E7BA24A5EA6A98A561CDB0)
Complete name : H:\Public\Shared Videos\Movies\IMAX Grand Canyon Adventure River At Risk\IMAX.Grand.Canyon.Adventure.River.At.Risk.2008.1080p.BluRay.x264-CLASSiC_ac3.mkv
Format : Matroska
Format version : Version 2
File size : 4.51 GiB
Duration : 44mn 37s
Overall bit rate : 14.5 Mbps
Encoded date : UTC 2015-07-11 19:55:59
Writing application : mkvmerge v4.4.0 ('Die Wiederkehr') built on Oct 31 2010 21:52:48
Writing library : libebml v1.0.0 + libmatroska v1.0.0
Video #1
ID : 1
Format : AVC
Format/Info : Advanced Video Codec
Format profile : High@L4.1
Format settings, CABAC : Yes
Format settings, ReFrames : 4 frames
Codec ID : V_MPEG4/ISO/AVC
Duration : 44mn 37s
Bit rate : 12.5 Mbps
Width : 1 920 pixels
Height : 1 080 pixels
Display aspect ratio : 16:9
Frame rate mode : Constant
Frame rate : 23.976 fps
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Progressive
Bits/(Pixel*Frame) : 0.252
Stream size : 3.81 GiB (84%)
Writing library : x264 core 67 r1153 7b6ce6a
Encoding settings : cabac=1 / ref=4 / deblock=1:0:0 / analyse=0x3:0x133 / me=umh / subme=7 / psy_rd=1.0:0.0 / mixed_ref=1 / me_range=16 / chroma_me=1 / trellis=1 / 8x8dct=1 / cqm=0 / deadzone=21,11 / chroma_qp_offset=-2 / threads=6 / nr=0 / decimate=1 / mbaff=0 / bframes=3 / b_pyramid=1 / b_adapt=1 / b_bias=0 / direct=1 / wpredb=1 / keyint=250 / keyint_min=25 / scenecut=40 / rc=2pass / bitrate=12520 / ratetol=1.0 / qcomp=0.60 / qpmin=10 / qpmax=51 / qpstep=4 / cplxblur=20.0 / qblur=0.5 / ip_ratio=1.40 / pb_ratio=1.30 / aq=1:1.00
Language : English
Default : Yes
Forced : No
Audio #3
ID : 3
Format : AC-3
Format/Info : Audio Coding 3
Mode extension : CM (complete main)
Format settings, Endianness : Big
Codec ID : A_AC3
Duration : 44mn 37s
Bit rate mode : Constant
Bit rate : 448 Kbps
Channel(s) : 6 channels
Channel positions : Front: L C R, Side: L R, LFE
Sampling rate : 48.0 KHz
Bit depth : 16 bits
Compression mode : Lossy
Stream size : 143 MiB (3%)
Language : English
Default : Yes
Forced : Yes
Audio #2
ID : 2
Format : DTS
Format/Info : Digital Theater Systems
Mode : 16
Format settings, Endianness : Big
Codec ID : A_DTS
Duration : 44mn 37s
Bit rate mode : Constant
Bit rate : 1 509 Kbps
Channel(s) : 6 channels
Channel positions : Front: L C R, Side: L R, LFE
Sampling rate : 48.0 KHz
Bit depth : 16 bits
Compression mode : Lossy
Stream size : 482 MiB (10%)
Language : English
Default : No
Forced : No

Any advice or suggestions on what I'm doing wrong? Thanks in advance!

Comments

  • MovieFan.PlexMovieFan.Plex Members, Plex Pass, Plex Ninja Posts: 15,459 Plex Employee

    On the main preferences for the Roku (not within the Plex app), there is also an audio setting. Make sure that is set to surround.

  • marcguidomarcguido Members Posts: 17 ✭✭

    Looking through the receiver's owner manual, I may have found something:

    "Step 1: Connect your HDMI-compatible TV to the AV receiver’s HDMI OUT jack.
    Step 2: Connect your HDMI-compatible player to the AV receiver’s HDMI IN 1 or 2 jack.
    Step 3: Connect your HDMI-compatible player to an analog and/or digital audio input on the AV
    receiver.
    ✽ Audio and video signals received via the HDMI IN 1 and 2 jacks are output by the HDMI OUT jack as they
    are (HDMI pass-through), so even if you only make the connections in steps 1 and 2, your TV will output
    sound. However, if you want to listen through the speakers connected to the AV receiver, in addition to an
    HDMI connection, you’ll also need to make a separate analog or digital audio connection."

    I forgot about that. Because of that limitation, I have a digital audio coax cable running from my DirecTV Genie box to a coaxial audio input on my AVR. I also have TOSLINK optical audio cables running from my Blu-Ray player and from my TV to optical audio inputs on the receiver.

    My generation of LG TV doesn't support DTS audio, only Dolby Digital and DD+. So, unless I'm mistaken what's happening here is that the Roku's audio signal being sent to the receiver over HDMI is merely being passed through to the TV, which is sending the audio back to the receiver via the TOSLINK cable connecting the TV to the AVR. It's therefore the TV that's attempting to process the audio and not the receiver, right? And because my TV can't process DTS, Plex automatically recognizes this and is therefore transcoding the audio to something that the TV (and not necessarily the AVR) recognizes?

    Assuming that folks can confirm my assumptions above to be correct, because the Roku only has HDMI out, is my only (best?) solution to this problem an HDMI splitter that will allow me to strip the audio from the HDMI and send it directly to the receiver, which can process DTS?

  • MovieFan.PlexMovieFan.Plex Members, Plex Pass, Plex Ninja Posts: 15,459 Plex Employee

    Does your receiver has the standard L/R stereo outputs? Try connecting those to the TV and set your TV's audio input to stereo.

  • marcguidomarcguido Members Posts: 17 ✭✭

    @MovieFan_04 said:
    Does your receiver has the standard L/R stereo outputs? Try connecting those to the TV and set your TV's audio input to stereo.

    Yes, it does. However, I'm not quite following your idea here.
    a) I'm not using the TV to play audio, I'm using the receiver.
    b) I'm trying to get DTS 5.1 audio anyway, not 2-channel stereo.

    How does connecting the TV to the receiver via 2-channel analog cables deliver DTS 5.1 audio from the receiver?

  • MovieFan.PlexMovieFan.Plex Members, Plex Pass, Plex Ninja Posts: 15,459 Plex Employee

    Sorry, I misunderstood. I thought you were trying to get sound from your TV speakers as well.

    So your receiver can take hdmi input but does not process it, only processes when the source is non-hdmi? That is an odd limitation. Defeats the point of having the receive, you can just go straight from the Roku to your TV in this case. The receiver is basically an hdmi switch at this point.

    Does you TV have an optical out? Some can take the digital hdmi audio and convert it to optical which you can then feed back into your receiver.

  • marcguidomarcguido Members Posts: 17 ✭✭

    @MovieFan_04 said:
    So your receiver can take hdmi input but does not process it, only processes when the source is non-hdmi? That is an odd limitation. Defeats the point of having the receive, you can just go straight from the Roku to your TV in this case. The receiver is basically an hdmi switch at this point.

    Correct.

    Does you TV have an optical out? Some can take the digital hdmi audio and convert it to optical which you can then feed back into your receiver.

    Yes it does, and that's precisely how I have it connected now via a Toslink cable. However, because 2011 model year LG TVs don't support DTS, the Plex Media Server apparently realizes that and is transcoding the DTS audio. At least that's what I'm guessing.

    That's why I'm thinking about an HDMI audio splitter like this one:

    http://www.monoprice.com/Product?c_id=101&cp_id=10110&cs_id=1011002&p_id=7974&seq=1&format=2

    I could connect all 4 of my HDMI devices -- the DirecTV, Roku, Chromecast and Blu-Ray player -- to this switch and run one HDMI cable from the switch's output to the TV. I'd then connect the switch's digital audio output to the receiver via Toslink, giving the receiver the ability to process the audio without going through the TV first. I'd of course be able to eliminate the Toslink cable running from the TV output to the receiver input.

    I'm guessing that would allow the receiver to process both DTS and AC3, and the Plex server would therefore realize that no audio transcoding would be required. Am I correct in these assumptions?

  • MovieFan.PlexMovieFan.Plex Members, Plex Pass, Plex Ninja Posts: 15,459 Plex Employee

    What happens if you have HDMI directly from the Roku to your receiver? Does it detect the DTS signal? Does it then send the sound out through your speakers? if so, it might be easier to split the signal coming out from the Roku and have 1 to the TV for video and 1 to your receiver for audio.

    Otherwise, your idea above sounds ok. It would depend on that splitter though and if it can actually handle splitting out the dts signal, which I doubt. To convert from dts to digital (LPCM) you need some processing power and that device does not look like it has anything that would do it.

    Another option is to avoid dts and ac3 all together. If you have the Roku set to surround and the Plex App with AC3 and DTS off, PMS sound convert the audio to LPCM. Your TV should be able to accept that and send that though to your receiver through the TosLink. Give that a shot first.

  • marcguidomarcguido Members Posts: 17 ✭✭

    @MovieFan_04 said:
    What happens if you have HDMI directly from the Roku to your receiver?

    That's how it's connected now.

    Does it detect the DTS signal?

    Nope. Because this Onkyo receiver doesn't process audio it receives via HDMI and merely passes it through, it's only processing the audio that it gets back from the TV via the Toslink cable. I can't connect the digital audio source directly from the Roku to the AV receiver because the Roku only has HDMI out.

    it might be easier to split the signal coming out from the Roku and have 1 to the TV for video and 1 to your receiver for audio.

    That's precisely what the splitter would accomplish.

    Otherwise, your idea above sounds ok. It would depend on that splitter though and if it can actually handle splitting out the dts signal, which I doubt.

    According to the specs it actually does:

    "Supports compressed audio, such as DTS® Digital, Dolby® Digital, DTS-HD Master Audio™ and Dolby TrueHD™"

    To convert from dts to digital (LPCM) you need some processing power and that device does not look like it has anything that would do it.

    This would merely split it out to coax or optical audio; it wouldn't process it, that would be handed by the AVR.

    Another option is to avoid dts and ac3 all together. If you have the Roku set to surround and the Plex App with AC3 and DTS off, PMS sound convert the audio to LPCM. Your TV should be able to accept that and send that though to your receiver through the TosLink. Give that a shot first.

    That's what actually inspired this whole thing in the first place. I previously had both AC-3 and DTS disabled in the Plex app settings. If I tried to watch a movie with DTS, however, playback would inevitably hang every few minutes or so, and the only way to get past it was to fast-forward the movie momentarily. Odd behavior. AC3 audio played just fine. What I thereafter started doing was converting the audio from DTS to AC3 on any movies that had DTS audio only, which became a colossal PITA and something that I'm now trying to find a way to avoid doing.

  • MovieFan.PlexMovieFan.Plex Members, Plex Pass, Plex Ninja Posts: 15,459 Plex Employee

    "Supports compressed audio, such as DTS® Digital, Dolby® Digital, DTS-HD Master Audio™ and Dolby TrueHD™"

    Ok. Reading through the specs it does say the following, so in theory it should work.

    It has 4x HDMI inputs and features a built-in audio converter, which will convert the HDMI audio from any of the four HDMI inputs and distribute it simultaneously to the audio output in HDMI, Optical/TOSlink, and Digital Coax outputs.

  • theuser86theuser86 Members Posts: 571 ✭✭
    edited July 2015
    1. In the Roku System Settings, this is outside of the Plex channel, under Audio, what is the 'Audio mode' and 'HDMI' set to? Set the Audio mode to 'Auto' and the HDMI to 'DD, DTS'.
    2. In Plex, under Preferences, go to 'Audio Preferences', you should see '5.1 DTS Support:', what is it set to? Set it to 'Enabled'.
    3. Then when selecting a file for playback in Plex, go to 'Playback options', then for 'Transcoding:', set it to DirectPlay. This will force the Plex channel on the Roku to play the file without transcoding the audio. Let us know if you get sound.
  • theuser86theuser86 Members Posts: 571 ✭✭
  • marcguidomarcguido Members Posts: 17 ✭✭
    edited July 2015

    Great to know, thanks!! As far as I can tell that one's essentially identical to the one I'm looking at, except that on yours one of the HDMI inputs is on the front. I really don't want that and as I need all 4 I think that I'm willing to spend the extra $20 to have all 4 inputs on the back.

    First, though, I'm forcing myself to sell one of these that I have laying around that I've never used:

    http://www.monoprice.com/Product?c_id=101&cp_id=10110&cs_id=1011002&p_id=8462&seq=1&format=2

    That's identical to what you have except no separate audio out.

    @theuser86, have you by any chance tried using your switch with a Harmony remote?

  • marcguidomarcguido Members Posts: 17 ✭✭

    @theuser86 said:
    1. In the Roku System Settings, this is outside of the Plex channel, under Audio, what is the 'Audio mode' and 'HDMI' set to? Set the Audio mode to 'Auto' and the HDMI to 'DD, DTS'.
    2. In Plex, under Preferences, go to 'Audio Preferences', you should see '5.1 DTS Support:', what is it set to? Set it to 'Enabled'.
    3. Then when selecting a file for playback in Plex, go to 'Playback options', then for 'Transcoding:', set it to DirectPlay. This will force the Plex channel on the Roku to play the file without transcoding the audio. Let us know if you get sound.

    Thanks for the suggestion. I had the settings previously set as indicated in #1 and 2, above. I got no sound when trying to Direct Play a movie encoded in DTS with those settings.

  • theuser86theuser86 Members Posts: 571 ✭✭
    edited July 2015

    Sorry I only use the original remote with the switch. But I am thinking of getting a Harmony remote.

    But yes sounds like your AVR just does pass through, some old receivers did this.

  • marcguidomarcguido Members Posts: 17 ✭✭

    Watch the daily sales on Meritline. About every week or so they have the refurbished Harmony Touch priced anywhere from $105 to $120.

  • theuser86theuser86 Members Posts: 571 ✭✭
    edited July 2015

    Let us know how the HDMI switch goes and if you get DTS audio.

  • marcguidomarcguido Members Posts: 17 ✭✭

    @theuser86 said:
    Let us know how the HDMI switch goes and if you get DTS audio.

    Thanks, will do.

  • DTraceDTrace Members, Plex Pass Posts: 54 Plex Pass

    I know this is an old thread but I just had the same issue. Come to find out on that switch product page there is a fine print
    * The S/PDIF Optical (Toslink) and Digital Coax audio output formats are based on the HDMI audio output. If any of the sync devices (e.g., HDTV, Projector, etc.) connected to the output can only support stereo audio, then the S/PDIF Optical (Toslink) and Digital Coaxial outputs will be limited to PCM stereo audio.

    I had to use their newer switch to have DTS audio work.

    Basically because if your TV does not support the audio format nor will the switch. So in this case your AVR does not know it is DTS.

  • micphy007micphy007 Members Posts: 10 ✭✭

    Hi Guys,
    I'm having a problem with DTS too but I think mine is a little bit different. I'll try to explain it as best I can and hopefully someone will be able to help me.
    My server is my lappy and client is a Sony tv. Tv is connected to my receiver via optical. If I plug a HDD with movies directly into my tv I have no trouble getting DTS, so it's not the movies or the connection from tv to receiver. When I stream the same movies to my tv with Plex, DTS starts working but only for a second. I've tried changing every setting I can but it makes no difference. I've read heaps of post about DTS not working but if it works for a second surely that means it should keep working? I love Plex but not having DTS is really annoying.
    Thanks in advance for any help I can get.
    Cheers Mike

  • dollarsbills02dollarsbills02 Members Posts: 2

    Try this on Nvidia Shield.
    Go to plex setting. Under advance,
    change direct play to 'forced'.
    change direct stream to 'on'
    change audio passthrough from disabled to 'auto'
    I have display information overlay on and it says direct play after these changes.

Sign In or Register to comment.