If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Secure Connections and Chromecast

shad0wmanshad0wman Posts: 35Members, Plex Pass Plex Pass

This originally started when I was trying to figure out why I could not cast from Android Plex app to Chromecast.

I made a post about it and it was becuase my Secure Connections was set to "Required"

When I set it to preferred/disabled I was then able to cast everything fine. It got me thinking why can Chromecast use the secure connections?

As said in my previous post user "sa2000" mentioned that

It was mentioned when the SSL came in that chromecast cannot cope with SSL at the moment. So working as designed. To > Cast to Chromecast must not have Secure Connections set to Required. Should use Preferred.
Will try and find the relevant blog info on this
Read this and then search for Chromecast
https://blog.plex.tv/2015/06/04/its-not-easy-being-green-secure-communication-arrives/
and this
https://support.plex.tv/hc/en-us/articles/206225077

I asked why this was, why can the Chromecast not "cope" with SSL, response was:

I have discussed the documentation with the Plex Team and the view is that the existing documentation is explicit enough :
Support Page How to Use Secure Server Connections is clear in that it does not list Chromecast app as supporting SSL

I am a volunteer with Google in the Chromecast Buddy Program where I have access to Google Employees and report certain issues and help relay information back.

I have ran Nmap tests against both Chromecast and my Plex Server and they both match up. (output below)

I have reported this to the Chromecast team who is currently discussing it internally.

I was hoping for some more technical details as to why PLEX thinks the Chromecast can not support Secure Connections.

Any insight?

«1

Answers

  • shad0wmanshad0wman Posts: 35Members, Plex Pass Plex Pass

    Attached are my Nmap results.

    Chromecast supports strong ciphers with TLS 1.2
    Plex offered TLS 1.0, 1.1, and 1.2 with strong ciphers.

    They both use the same protocols/ciphers so I don't know to how Chromecast doesn't support SSL.

    The only thing I can think of is the way Plex hands out "wild card" certificates.

    I got a bit curious so I found this explanation of what Plex does with the certs
    https://blog.filippo.io/how-plex-is-doing-https-for-all-its-users/

    Looks like wildcard certs with dynamic dns. I'm not sure why that wouldn't work with the Chromecast, wildcard certs are used a lot. The certificates are real but they are sending you to your server address using DNS (fooling the SSL checks). Hopefully that won’t be an issue with Google’s DNS server that I believe is the only thing the Chromecast uses.

    I am here for the technical details why and so I can get the proper information to either the Chromecast team, or from my post on the private Chromecast forum to bring info here.

  • shad0wmanshad0wman Posts: 35Members, Plex Pass Plex Pass
    edited July 2015

    Ok so I just realized that there was an Android update today with the note:

    Resolve issue which prevented the Chromecast from using a secure connection to a server.

    I have not yet tested this at home while Requiring Secure Connections.

    Is this the fix for it? What was wrong if I am able to know?

  • fmstratfmstrat Posts: 130Members, Plex Pass Plex Pass

    +1. Would love to see a response from the Plex team here. Thanks.

  • shad0wmanshad0wman Posts: 35Members, Plex Pass Plex Pass

    I just tested it with Required and I got the dreaded "Unable to Cast - This Media is Currently Unavailable" message, so it does not seem fixed. Though the new interface is great.

  • fmstratfmstrat Posts: 130Members, Plex Pass Plex Pass

    That's a shame, the change log had me interested.

    Since Plex DNS is authoritative for Plex.TV, the DNS check should be clean, too. My guess is there is some negotiation code for checking if SSL is available that they can't get running on the Chromecast because it's a simple device. So if they enable SSL for Chromecast, it will be across the board. For that to work they've got to wait a while to be sure users have upgraded their servers, first.

    The only thing that throws me is why they couldn't check in the App, but I'm sure there is some reason we are just not seeing.

  • t1hom7ast1hom7as Posts: 48Members, Plex Pass Plex Pass

    I am quite interested in this now that iOS has now received it's long awaited update, which now supports SSL connections. So I guess this should be implemented soon, now android and iOS support it.

  • shad0wmanshad0wman Posts: 35Members, Plex Pass Plex Pass

    To update this. As of the latest builds of Plex and Chromecast I can now successfully cast from any source with Secure Connections set to REQUIRED. I will close this unless further issues arise.

  • t1hom7ast1hom7as Posts: 48Members, Plex Pass Plex Pass
    edited August 2015

    @shad0wman said:
    To update this. As of the latest builds of Plex and Chromecast I can now successfully cast from any source with Secure Connections set to REQUIRED. I will close this unless further issues arise.

    +1

    I figured this out when I set my PMS to 'Required' and then I could cast. However, still getting the play queue error.

    Found this:

    @chrisallen said:
    Unfortunately, the Chromecast does not currently support secure connections. In order for the iOS app to correctly cast to the Chromecast (Which results in the Chromecast talking to your Plex Media Server) you will need to set secure connections to "Preferred".

    So secure connections is not working/enabled currently still.

    Source: https://forums.plex.tv/discussion/176852/ios-update-bug-cannot-retrieve-the-play-queue-for-this-item-please-try-again#latest

  • tomatosmoothietomatosmoothie Posts: 78Members ✭✭

    Yeah,
    Settings > Server > Network > Secure Connections > Required!

    Not working from
    iOS
    Android

    Thanks!

  • Jong1Jong1 Posts: 6Members ✭✭
    edited August 2015

    So it seems the IOS update and the .5 server update enabled secure connections to Chromecast and this is the cause of extensive stuttering even on a 1Gbps wired network. It's discussed at length in other threads dating after the.4 update. Is this because Chromecast really cannot cope and SSL should be disabled even if preferred, or is it a bug?

  • shad0wmanshad0wman Posts: 35Members, Plex Pass Plex Pass

    So as I have mentioned above. This is no longer an issue on Chromecast's side. I worked extensively with both parties to figure it out. Make sure that Plex and Chromecast are the latest versions.

    As a workaround you can set the Secure Connections to Preferred.

    I have tested with multiple Chromecasts and Android devices that this bug has been fixed.

    Sounds like an iOS issue. With that I would start a new thread.

  • tomatosmoothietomatosmoothie Posts: 78Members ✭✭

    sigh
    Plex Media Server Version 0.9.12.8
    Android Version 4.8.1.390(c98c53aa)
    Settings > Server > Network > Secure Connections > Required!, not working!

    Sorry to say, setting it to "Preferred" is not a workaround it is Unsecured.

    Please specify versions that are working, because I just get a "unable to cast" on the screen.

  • Jong1Jong1 Posts: 6Members ✭✭
    edited August 2015

    @shad0wman There are numerous reports of problems of stuttering with secure connection enabled even on Android (https://forums.plex.tv/discussion/174054/lagging-with-the-new-plex-for-android-release). And now this is enabled by default people have to turn off all secure connections to get Chromecast to work. It seems some more work is needed - on Plex or Google side I do not know - else it needs disabling again in Plex.

  • SHOCKWAVESHOCKWAVE Posts: 372Members, Plex Pass Plex Pass

    It would make sense to just make connections to the chromecast SSL disabled or at least have a toggle to choose on or off so that no other plex app that uses SSL is affected because of this horrendous bug that seems like it will never be fixed.

  • Kyle VerryKyle Verry Posts: 293Members, Plex Pass Plex Pass

    There was a fantastic individual on Google+ that mentioned removing the secured connection to make Chromecast support 1080p+ streams like before! However, I agree, this needs to be somewhat of a selection choice. I have to now DISABLE SSL in order to have the Chromecast stream properly. I would prefer secure connections across the board and then have Chromecast NOT have the SSL if it struggles.

    In case it matters for anyone else looking, I have not been able to get a stream at 8Mbps 1080p to work at all, only dropping to 4Mbps 720p worked or lower. I usually had zero issue on any device or computer, meaning only the Chromecast was struggling with 1080p. Of course, I blamed it on the Chromecast, even though 1080p YouTube and more worked fine.

    This change has rectified the problem and Chromecast is the super streamer it used to be again!

  • eshudnoweshudnow Posts: 39Members, Plex Pass Plex Pass
    edited October 2015

    I have SSL disabled but still get a lot of stuttering. On 0.9.12.13.

  • shad0wmanshad0wman Posts: 35Members, Plex Pass Plex Pass

    make a new thread, video stuttering when SSL is disabled is a different issue than this thread.

    This thread is for "not being able to cast" when SSL is ENABLED

    If you have lag there are many other factors that can cause that

  • tomatosmoothietomatosmoothie Posts: 78Members ✭✭

    Is this still an issue? I've ordered a few Chromecasts 2nd gen. and one Chromecast audio.

  • kevroy314kevroy314 Posts: 17Members ✭✭

    I have a related thread going where I discovered this was my issue in not being able to cast. I'm wondering if I changed a setting or performed an update which suddenly made this problem appear. My current workaround is to change Settings->Network->Secure Connections setting to "Preferred". I'm not happy with it, but it's all I've got at the moment.

  • kevroy314kevroy314 Posts: 17Members ✭✭

    Woops, link to the related thread:

    https://forums.plex.tv/discussion/comment/1109306

«1
Sign In or Register to comment.