If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

unable to play movies via the plex app on my ROKU player

TV shows play fine, but in movies the status bar just sits there and then says cannot retrieve or something like that. Again TV Shows play fine. My tv shows and movies are on different drives and i've copied some movies to the tv show drive and added a new library but still nothing. If i play movies via the roku media player and then choose plex server some movies do play so the issue must lie with plex. I've reset, checked updates for roku and removed and re added librarys and drives but still nothing. The movies files vary between .avi .mp4 & .mkv and none work via the plex app. my TV shows are mostly .mp4 and play fine and as advised movies play via the roku media player just not plex!!!

All was working fine about a week ago but now nothing!!!

Please Please HELP!!!

Answers

  • JamminRJamminR Posts: 2,642Members, Plex Pass Plex Pass

    Did your movie drive letter change since it worked to begin with?
    Or the folder/location they were in. (example, you decided to move from X:\mymovies to x:\movies)
    You'll really need to give us proper logs to determine.
    See reporting issues

    Server - HW: Intel Core I5-4670K, 16GB DDR3 SW: Win10 Pro + PMS v1.9.1
    Misc. HW: HDHR Extend + 4TB RAID1 (Intel) + 4 x 4TB RAID5 (QNAP w/HGST drives)
    Shares - From: 1  - To: 20(6) - Potential lifetime PlexPass data generating product customer!
    ISP: ~25mbps up/1TB monthly "cap" - (Monthly avg. xfer ~450gb)
    Search the Plex WIKI before asking silly questions.
    Plex stuff I favor - PlexPy - UASv2 - PlexEmail - SS Plex - FMoviesPlus - G2G.FM
  • markgilbert84markgilbert84 Posts: 10Members
    via Email
    Thanks I'll take a look and see. The drive cable had been disconnected but when it was reconnected the drive letter remained the same. I did delete and re add the library though. But as I said I've added some movies to the drive where the tv shows are under a new folder called movies added that as a movie library which is fine in plex on my pc but not to play via the roku app. Also as advised when choosing plex server via roku media player most of the movies play fine from the drive that all the movies are on!!!
    Will look at reporting issues and come back.


    Sent from my Samsung device
  • markgilbert84markgilbert84 Posts: 10Members

    Here are the logs (i think) i look forward to hearing from you.

  • JamminRJamminR Posts: 2,642Members, Plex Pass Plex Pass

    If all we're dealing with is Plex/Roku not playing, I/we won't need the DLNA logs. Only the server log.
    Which brings me to the next issue, I'm not sure you included what is needed to determine your problem.
    The only thing I see in that log is that you started the server, played Finding Nemo for about 30 seconds on your Roku, then stopped it. I see no error playing it that log. Did you experience error?
    It seems that log was a current/running server with no shutdown.
    Quick summary of how to do it, again. Sorry if the wiki doesn't make it clear
    1) Restart server.
    2) Reproduce error. (use a movie that won't work on Roku)
    3) Reproduce error with another movie. (just to make sure (no, that steps not listed in wiki)
    Make sure 2 and 3 don't have a working movie in-between...plan out two known 'broken' movies.
    4) Restart server.
    5) grab Plex Media Server.log.1 and attach it here.
    That .1 is important. Each server restart causes each log session to move back 1*, hence the 1-5 you see there. (* = The server will also do this automatically for every ~5mb of log)
    Grabbing the .1 log will ensure you just grabbed the last/broken 2 movies log from the session before you restarted in step 4.

    Server - HW: Intel Core I5-4670K, 16GB DDR3 SW: Win10 Pro + PMS v1.9.1
    Misc. HW: HDHR Extend + 4TB RAID1 (Intel) + 4 x 4TB RAID5 (QNAP w/HGST drives)
    Shares - From: 1  - To: 20(6) - Potential lifetime PlexPass data generating product customer!
    ISP: ~25mbps up/1TB monthly "cap" - (Monthly avg. xfer ~450gb)
    Search the Plex WIKI before asking silly questions.
    Plex stuff I favor - PlexPy - UASv2 - PlexEmail - SS Plex - FMoviesPlus - G2G.FM
  • markgilbert84markgilbert84 Posts: 10Members
    via Email
    Yes I did get an error and it didn't play at all. The status loading bar was frozen for about a minute and the the error popped up. I'll try again later and resend the logs.


    Sent from my Samsung device
  • jllzjllz Posts: 27Members ✭✭

    I'm having a similar problem starting yesterday, Jul24/2015. Plex worked fine earlier in the day then suddenly I started having download and picture problems. The status bar either loaded slowly. Now it tells me that it can't see my videos and to check the server. I can watch the same video on my laptop thru Plex just fine. I've restarted everything. Very frustrating

  • JamminRJamminR Posts: 2,642Members, Plex Pass Plex Pass

    Curious - has any Roku firmware been updated?
    Things like this 'just happening' are often when Roku pushes firmware, if you're absolutely certain nothing in your networking/server environment changed.

    Server - HW: Intel Core I5-4670K, 16GB DDR3 SW: Win10 Pro + PMS v1.9.1
    Misc. HW: HDHR Extend + 4TB RAID1 (Intel) + 4 x 4TB RAID5 (QNAP w/HGST drives)
    Shares - From: 1  - To: 20(6) - Potential lifetime PlexPass data generating product customer!
    ISP: ~25mbps up/1TB monthly "cap" - (Monthly avg. xfer ~450gb)
    Search the Plex WIKI before asking silly questions.
    Plex stuff I favor - PlexPy - UASv2 - PlexEmail - SS Plex - FMoviesPlus - G2G.FM
  • 5stringdeath5stringdeath Ninja Posts: 1,402Members, Plex Pass, Plex Ninja Plex Ninja

    I have 2 Rokus and both are working fine. There has been no recent firmware update that I know of.

    Running PMS on a 2.6GHz i7 MacMini

    Clients include: 2xRoku, ATV, iPad Pro, iPad Air, iPhone 6 (x2), TiVO Bolt, PS4, Sony Android TV, PlexWeb in Chrome, Amazon Fire Stick & Secrets

     

     

  • JamminRJamminR Posts: 2,642Members, Plex Pass Plex Pass

    @5stringdeath - is it a Roku 2 XS? Think I remember seeing the original poster as that version in logs.
    I've got a Roku 3 with no issue. Don't have any of my 2XS's hooked up currently for testing.
    I really need to do that.
    *** JamminR scrobbles off to find the "borrowed" HDMI cable for his monitor/Roku that was re-purposed temporarily for something else.

    Server - HW: Intel Core I5-4670K, 16GB DDR3 SW: Win10 Pro + PMS v1.9.1
    Misc. HW: HDHR Extend + 4TB RAID1 (Intel) + 4 x 4TB RAID5 (QNAP w/HGST drives)
    Shares - From: 1  - To: 20(6) - Potential lifetime PlexPass data generating product customer!
    ISP: ~25mbps up/1TB monthly "cap" - (Monthly avg. xfer ~450gb)
    Search the Plex WIKI before asking silly questions.
    Plex stuff I favor - PlexPy - UASv2 - PlexEmail - SS Plex - FMoviesPlus - G2G.FM
  • markgilbert84markgilbert84 Posts: 10Members
    via Email
    Hi,
    Yes it's a 2 XS
    Will try and sort those logs out for you later today.
    Sent from my Samsung device
  • markgilbert84markgilbert84 Posts: 10Members
    via Email
    I'm not sure about roku updating as it's automatically. I haven't caged my server environment for some time and was working until recently.


    Sent from my Samsung device
  • markgilbert84markgilbert84 Posts: 10Members
    via Email
    Tell me about it. I'm still looking/ waiting for a fix. We'll see I guess!


    Sent from my Samsung device
  • JamminRJamminR Posts: 2,642Members, Plex Pass Plex Pass

    My 2xs is working fine also, and that's after a full update from Roku firmware 5.5 to 6.x_whatever.
    (I'd had it off network for quite a few months).
    I tried with both RarFlix (a custom Plex based on OLD plex for roku code, just to test), and PlexTest, which is at version 3.1.4 - both worked.
    @markgilbert84 - I recommend providing Plex Media Server.log and the Roku log (don't include your auth key in the file). See Reporting Issues

    Server - HW: Intel Core I5-4670K, 16GB DDR3 SW: Win10 Pro + PMS v1.9.1
    Misc. HW: HDHR Extend + 4TB RAID1 (Intel) + 4 x 4TB RAID5 (QNAP w/HGST drives)
    Shares - From: 1  - To: 20(6) - Potential lifetime PlexPass data generating product customer!
    ISP: ~25mbps up/1TB monthly "cap" - (Monthly avg. xfer ~450gb)
    Search the Plex WIKI before asking silly questions.
    Plex stuff I favor - PlexPy - UASv2 - PlexEmail - SS Plex - FMoviesPlus - G2G.FM
  • markgilbert84markgilbert84 Posts: 10Members
    via Email
    JamminR - here you go, I think/ hope!!!






    Sent from Windows Mail





    From: JamminR
    Sent: ‎Sunday‎, ‎26‎ ‎July‎ ‎2015 ‎14‎:‎19
    To: Mark Gilbert





    My 2xs is working fine also, and that's after a full update from Roku firmware 5.5 to 6.x_whatever.
    (I'd had it off network for quite a few months).
    I tried with both RarFlix (a custom Plex based on OLD plex for roku code, just to test), and PlexTest, which is at version 3.1.4 - both worked.
    @markgilbert84 - I recommend providing Plex Media Server.log and the Roku log (don't include your auth key in the file). See Reporting Issues
  • JamminRJamminR Posts: 2,642Members, Plex Pass Plex Pass

    @markgilbert84 - Apparently, you have to be logged into the forum to actually attach a log.
    Can't do it through email.

    Server - HW: Intel Core I5-4670K, 16GB DDR3 SW: Win10 Pro + PMS v1.9.1
    Misc. HW: HDHR Extend + 4TB RAID1 (Intel) + 4 x 4TB RAID5 (QNAP w/HGST drives)
    Shares - From: 1  - To: 20(6) - Potential lifetime PlexPass data generating product customer!
    ISP: ~25mbps up/1TB monthly "cap" - (Monthly avg. xfer ~450gb)
    Search the Plex WIKI before asking silly questions.
    Plex stuff I favor - PlexPy - UASv2 - PlexEmail - SS Plex - FMoviesPlus - G2G.FM
  • markgilbert84markgilbert84 Posts: 10Members
    via Email
    Ok.
    Will sort shortly.


    Sent from my Samsung device
  • markgilbert84markgilbert84 Posts: 10Members

    here are the logs for you.

  • JamminRJamminR Posts: 2,642Members, Plex Pass Plex Pass

    @markgilbert84 - my apologies. I've looked over the logs, and I'm unable to see why the Roku isn't playing.
    The server logs indicate it was ahead an average of 10 or more segments all the time. It thought it was playing to the Roku, right up until the moment log then says roku buffer status progress 0/###### and the transcoder job stops.
    I'm unable to replicate the problem on my end.
    I've seen similar in 2 or 3 other posts.
    Unfortunately, it's beyond my personal experience.
    I hope someone else can come and see the issue better than I.

    Server - HW: Intel Core I5-4670K, 16GB DDR3 SW: Win10 Pro + PMS v1.9.1
    Misc. HW: HDHR Extend + 4TB RAID1 (Intel) + 4 x 4TB RAID5 (QNAP w/HGST drives)
    Shares - From: 1  - To: 20(6) - Potential lifetime PlexPass data generating product customer!
    ISP: ~25mbps up/1TB monthly "cap" - (Monthly avg. xfer ~450gb)
    Search the Plex WIKI before asking silly questions.
    Plex stuff I favor - PlexPy - UASv2 - PlexEmail - SS Plex - FMoviesPlus - G2G.FM
  • RobjoderRobjoder Posts: 1Members

    I recently downloaded plex on my Roku 4. I tried playing videos but I get the error saying Video unavailable and that to make sure the server is running and that I have access to the video. I have an account made already. SO is there something that I need to do or is there a problem on Plex end?

Sign In or Register to comment.