If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Plex on Vizio Smart TV will not start - connection disconnected

Plex on my Vizio Smart TV was working great but recently I have been unable to load the app. Whenever I start the app the Plex logo comes up and then 30 sec later the app closes and I see "Connection Disconnected. Please check your TV's network settings." There is no issue with my connection. All other apps that I use work great, it is only Plex. I am running version 2.4.13 on the TV. I also have Plex Pass so that is not an issue.

«134567

Answers

  • StarrionStarrion Posts: 266Members, Plex Pass Plex Pass

    ATT, VERIZON, AND TMOBILE all had a HUGE Inet outage today.
    Could that be the issue?

    You need inet access to use the Vizio client as it's beta still.

  • ph0enix81ph0enix81 Posts: 4Members, Plex Pass Plex Pass

    Mine does the same thing. This is my first time setting up and trying to use the plex vizio app. It does it on both my TV's...

  • mattseeleymattseeley HawaiiPosts: 1,355Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

    @bphrampus said:
    Whenever I start the app the Plex logo comes up and then 30 sec later the app closes and I see "Connection Disconnected. Please check your TV's network settings."

    Do you have your server's Secure Connections setting set to Required? If so, will you please set it to Preferred and try again?

    (Please no private messages for support unless requested, please)

  • dayer4bdayer4b Posts: 12Members, Plex Pass Plex Pass

    This is happening to me too. On the Vizio M501d-A2R. App version is 2.4.21 on the TV.

  • thatoadmanthatoadman Posts: 2Members

    Same here. Plex ver 2.4.36 on the Vizio TV. Network test is successful. App is still failing.

  • thatoadmanthatoadman Posts: 2Members

    Any updates?

  • jasoncrossjasoncross Posts: 15Members, Plex Pass Plex Pass

    Here too. Secure connections set to Preferred. Worked until yesterday.

  • SeanPHayesSeanPHayes Posts: 3Members, Plex Pass Plex Pass

    Same issue. Version 2.4.36 / Vizeo M70-C3

    See the Plex spash screen with version # in the bottom right, it will stay like this for minutes or seconds sometimes. Eventually it will flash a window saying Network disconnected and you can either click a button that says network set up or close app. The network set up button just opens the TV's network set up but that tests fine. Netflix and Amazon streaming work without any problem.

  • dboroddborod Posts: 4Members Plex Pass

    I am having the same problem with my Plex media server. I can connect via apps and apple TV, but not from my vizio.

  • jasoncrossjasoncross Posts: 15Members, Plex Pass Plex Pass

    Vizio P502ui-B1. Plex 2.4.36. Wired connection. Plex works fine on all other devices on network.

    I get the "Unable to connect to a server. " screen. Server 0.9.12.19 running on Mac El Capitan. Secured connections set to Preferred but not Required. Tried Disabled as well with same issue.

  • chrislovessushchrislovessush Posts: 10Members ✭✭

    Same here. Just got the TV. App hangs for a bit when opening then Connection Disconnected.

  • jjlinkjjlink Posts: 2Members, Plex Pass Plex Pass
    edited January 2016

    Vizio M70-C3 it worked for me until a couple of days ago. Now I also get "Unable to connect to a server. ". I don't know what changed. Of course it works fine on Fire TV and Roku, etc.

    2.4.36
    Plex TV
    Vizio (Vizio Sigma 1.3.15-UHD)

  • chrislovessushchrislovessush Posts: 10Members ✭✭

    Tried Plex again today and it works great? No changes on the server. The only difference is that this time I opened Plex as soon as I turned on the TV and last time I was trying to open it after watching Netflix? Server connections have always been set to Preferred btw.

  • chrislovessushchrislovessush Posts: 10Members ✭✭

    I take that back. Error is back. No changes whatsoever. Turned the TV off and turned it back on and now Plex doesn't recognize the connection again. Tried wifi and wired.

  • jasoncrossjasoncross Posts: 15Members, Plex Pass Plex Pass

    Mine too. Problem back. Signed out and back in - no luck this time.

  • chrislovessushchrislovessush Posts: 10Members ✭✭

    Wondering if I should just buy a fire stick

  • jasoncrossjasoncross Posts: 15Members, Plex Pass Plex Pass

    Mine is working again. I believe I have my particular problem solved.

    I was using a VPN on my system hosting Plex and inadvertently had it set to send all traffic through the VPN. Once I changed this, it started working again.

    I believe what may be happening is that the Vizio app is ignoring that I have a local Plex install and is trying to connect to my system out and back over the Internet. When the host was treating the VPN as the Internet gateway, I had no remote access, and the Vizio didn't work (even though on the same wired local network). My other devices still worked as they saw the local Plex server.

  • jwatts721jwatts721 Posts: 2Members, Plex Pass

    PROBLEM SOLVED:
    I was having this problem for about 3 days straight. I thought that the app had an update that was broken across the board.

    It never occurred to me that I should consider the configuration of the Plex server on my local network. I had my network configuration set to require secure connections and network discovery was enabled.

    THE FIX: Set your network configuration to the following:

    • Secure Connections: Preferred
    • Uncheck "Enable local network discovery"

    I'm sure you can play with these settings to see which one actually broke it, but I'm leaving mine alone since things are working.

  • chrislovessushchrislovessush Posts: 10Members ✭✭

    PROBLEM NOT SOLVED
    That didn't fix the problem.

  • gazerrantgazerrant Posts: 19Members ✭✭

    Jwatts' solution didn't work for me either. I already had secure connections set to Preferred, and unchecking local network discovery didn't help.

«134567
Sign In or Register to comment.