If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

PlexConnect on Windows 10 failed to connect (RESOLVED)

iwill424iwill424 Posts: 13Members, Plex Pass Plex Pass

Hi, thanks for reading, I recently upgraded to Windows 10. Then my plex connect stopped working.
So I found a tutorial https://miapple.me/install-plexconnect-on-windows-10/#comment-11710
Followed step by step, still not working.

On the server side it keeps saying
"Failed to connect to HTTP on 192.168.106.130 port 80: [Errno 10013] An attempt was made to access a socket in a way forbidden by its access permissions".

here's the full report:

01:50:10 PlexConnect: ***
01:50:10 PlexConnect: PlexConnect
01:50:10 PlexConnect: Press CTRL-C to shut down.
01:50:10 PlexConnect: ***
01:50:10 PlexConnect: started: 01:50:10
01:50:10 PlexConnect: Version: 0.5-dev-020615
01:50:10 PlexConnect: Python: 2.7.10 (default, May 23 2015, 09:40:32) [MSC v.1500 32 bit (Intel)]
01:50:10 PlexConnect: Host OS: win32
01:50:10 PlexConnect: PILBackgrounds: Is PIL installed? False
01:50:10 PlexConnect: IP_self: 192.168.106.130
01:50:10 DNSServer: started: 01:50:10
01:50:10 DNSServer: ***
01:50:10 DNSServer: DNSServer: Serving DNS on 192.168.106.130 port 53.
01:50:10 DNSServer: intercept: [‘trailers.apple.com’] => 192.168.106.130
01:50:10 DNSServer: restrain: [‘mesu.apple.com’, ‘appldnld.apple.com’, ‘appldnld.apple.com.edgesuite.net’] => 127.0.0.1
01:50:10 DNSServer: forward other to higher level DNS: 8.8.8.8
01:50:10 DNSServer: ***
01:50:10 WebServer: started: 01:50:10
01:50:10 WebServer: Failed to connect to HTTP on 192.168.106.130 port 80: [Errno 10013] An attempt was made to access a socket in a way forbidden by its access permissions
01:50:10 WebServer: started: 01:50:10
01:50:10 WebServer: ***
01:50:10 WebServer: WebServer: Serving HTTPS on 192.168.106.130 port 443.
01:50:10 WebServer: ***

Here are all the versions of software I downloaded:

  • PlexConnect-master
  • Python: 2.7.9
  • Win32OpenSSL-1_0_2d

And on my ATV3, I just can't add new prpfile, it just stalls, which I believe it's because the server side is not working yet.

My windows account security setting is lowest. Firewall turned off.

Please let me know if there's anything I can do to fix this. Thanks a lot!

«1

Answers

  • wahlman.jwahlman.j Posts: 2,564Members, Plex Pass Plex Pass

    OSX apps : OpenPlex // UAS installer OpenPlex by Wahlman.j (Source Code), CyberGhost84 (GUI) & Flipman6 (Obj-C)

    iOS Firmware links: Firmware // Firmware Limits OpenPlex app or assistance. Donations appreciated US-$ // EUR

    Click my username and message me if you need Teamviewergif <----Install this for assistance.

    (1) Locally owned PMS Mac 10.9.5 i7-4770k haswell 32gb 1866 ddr3 with e-sata rocket raid 2302 Raid-5 set of (4) 5TB HD (15TB usable) in a 10-bay DAGE1040BL (2) Jailbroken aTV2's on iOS 5.3 (6.1.4) (portable PlexConnect host's) (9) aTV3's on mixed iOS (1) iPad 3, (1) iPad mini 2 retina, (4) iPhone 4s, all jailbroken on 8.1.1 all running latest official Plex for iOS & PlexConnect for iOS. Airbubble.apk (265 initial buffer frames) for android devices or airfloat for iOS devices to airplay aTV audio to Sol Republic Tracks HD V10.

  • iwill424iwill424 Posts: 13Members, Plex Pass Plex Pass

    Yeah I tried that already and I don't have anything that's using 80 port.

    Active Connections

    Proto Local Address Foreign Address State
    TCP 127.0.0.1:5354 lmlicenses:49414 ESTABLISHED
    TCP 127.0.0.1:5354 lmlicenses:49415 ESTABLISHED
    TCP 127.0.0.1:19872 lmlicenses:49771 ESTABLISHED
    TCP 127.0.0.1:27015 lmlicenses:49669 ESTABLISHED
    TCP 127.0.0.1:32400 lmlicenses:58607 ESTABLISHED
    TCP 127.0.0.1:49414 lmlicenses:5354 ESTABLISHED
    TCP 127.0.0.1:49415 lmlicenses:5354 ESTABLISHED
    TCP 127.0.0.1:49641 lmlicenses:65001 ESTABLISHED
    TCP 127.0.0.1:49669 lmlicenses:27015 ESTABLISHED
    TCP 127.0.0.1:49746 lmlicenses:49747 ESTABLISHED
    TCP 127.0.0.1:49747 lmlicenses:49746 ESTABLISHED
    TCP 127.0.0.1:49748 lmlicenses:49749 ESTABLISHED
    TCP 127.0.0.1:49749 lmlicenses:49748 ESTABLISHED
    TCP 127.0.0.1:49758 lmlicenses:49759 ESTABLISHED
    TCP 127.0.0.1:49759 lmlicenses:49758 ESTABLISHED
    TCP 127.0.0.1:49760 lmlicenses:49761 ESTABLISHED
    TCP 127.0.0.1:49761 lmlicenses:49760 ESTABLISHED
    TCP 127.0.0.1:49762 lmlicenses:49763 ESTABLISHED
    TCP 127.0.0.1:49763 lmlicenses:49762 ESTABLISHED
    TCP 127.0.0.1:49764 lmlicenses:49765 ESTABLISHED
    TCP 127.0.0.1:49765 lmlicenses:49764 ESTABLISHED
    TCP 127.0.0.1:49766 lmlicenses:49767 ESTABLISHED
    TCP 127.0.0.1:49767 lmlicenses:49766 ESTABLISHED
    TCP 127.0.0.1:49771 lmlicenses:19872 ESTABLISHED
    TCP 127.0.0.1:49783 lmlicenses:49784 ESTABLISHED
    TCP 127.0.0.1:49784 lmlicenses:49783 ESTABLISHED
    TCP 127.0.0.1:54968 lmlicenses:54969 ESTABLISHED
    TCP 127.0.0.1:54969 lmlicenses:54968 ESTABLISHED
    TCP 127.0.0.1:57971 lmlicenses:57972 ESTABLISHED
    TCP 127.0.0.1:57972 lmlicenses:57971 ESTABLISHED
    TCP 127.0.0.1:58607 lmlicenses:32400 ESTABLISHED
    TCP 127.0.0.1:65001 lmlicenses:49641 ESTABLISHED
    TCP 192.168.106.130:2869 router:49332 TIME_WAIT
    TCP 192.168.106.130:2869 router:49333 TIME_WAIT
    TCP 192.168.106.130:11781 70.50.21.141:53022 ESTABLISHED
    TCP 192.168.106.130:11781 CPE78cd8ed49028-CM78cd8ed49025:53546 ESTABLISHED
    TCP 192.168.106.130:49153 17.158.10.48:https CLOSE_WAIT

  • BSG_75BSG_75 Posts: 5Members, Plex Pass Plex Pass

    Some people including myself are having issues using Windows 10 and connecting to the plex media server from the internet. I was able to resolve this issue by noticing that since I upgraded my OS to windows 10 my IP address had changed slightly. I had to update the correct info in my router settings forwarding 32400 to the new ip: example on windows 7 before the upgrade I was 192.168.1.2. Now I am 192.168.1.4. after the upgrade. With this simple adjustment in my port forwarding settings of my router, I can now access plex through my phone and from anywhere in the world. I hope this helps.

  • iwill424iwill424 Posts: 13Members, Plex Pass Plex Pass
    edited August 2015

    Yeah I didn't have to do any port forwarding on my router. And my current issue is my PlexConnect not being to see the server it self and connect it.
    Thanks though!!!

  • SkullzySkullzy Posts: 119Members, Plex Pass Plex Pass

    My server would come up as offline from time to time and then back on.. "I'm on windows 10" but nothing as bad as your issue.. then again I installed the plex app from the windows store and remove the home theatre application..

    Try disabling all security on your system and seeing if that allows your server to appear on your player, if it does then the issue resides in your windows firewall, defender or third party security... if it doesn't then I'd usually suggest looking into your router/modem but then again this only occured when you upgraded to windows 10.. so it's obvious that the issue is a conflict somewere within the system.

  • baabaa Posts: 3,954Members, Plex Pass, Forum Moderator Forum Mod

    Running PlexConnect with admin privileges?

    Plex @ aTV - think different: PlexConnect

    -> the missing link between Plex Media Server and your AppleTV - 2 or 3, jailbroken or not.

    plex forums: [PlexConnect] -- github: [latest Sources], [Wiki] -- donations (paypal): [US-$][EUR]

  • iwill424iwill424 Posts: 13Members, Plex Pass Plex Pass

    Yeah I did that too, no antivirus no windows defender no firewall.
    Ugh it's frustrating lol
    I'm a technician but i hate network issues XD

    @Skullzy said:
    My server would come up as offline from time to time and then back on.. "I'm on windows 10" but nothing as bad as your issue.. then again I installed the plex app from the windows store and remove the home theatre application..

    Try disabling all security on your system and seeing if that allows your server to appear on your player, if it does then the issue resides in your windows firewall, defender or third party security... if it doesn't then I'd usually suggest looking into your router/modem but then again this only occured when you upgraded to windows 10.. so it's obvious that the issue is a conflict somewere within the system.

  • iwill424iwill424 Posts: 13Members, Plex Pass Plex Pass

    Did that, no go lol

    @baa said:
    Running PlexConnect with admin privileges?

  • SkullzySkullzy Posts: 119Members, Plex Pass Plex Pass

    @iwill424 said:
    Yeah I did that too, no antivirus no windows defender no firewall.
    Ugh it's frustrating lol
    I'm a technician but i hate network issues XD

    Same man, same :P

    Could the issue possibly be the python version you're using?, googling to see if there is anything to hint to what is causing this.. The following guide suggest using a version lower than the one you've got.. You could also try to run plexconnect and when you get the port 80 error, instantly run netstat or have a batch script set-up to constantly run netstat looking for the port 80 connection, if it finds it ends the loop.

    So then you run plexconnect, just to see if it might be trying to open port 80 twice.. or if plexconnect is starting something that takes port 80.. there has to be a conflict somewhere.. something that wouldn't show up in the log..

    https://miapple.me/install-plexconnect-on-windows-10/ <= Looks like a good guide for setting PlexConnect Up in windows 10

  • iwill424iwill424 Posts: 13Members, Plex Pass Plex Pass

    Yeah i agree! And that guide is the one I followed to setup PlexConnect for Windows 10 at the first place.
    I even uninstalled everything and started from the beginning still no go.
    I don't know how to do the batch script though.

    @Skullzy said:
    https://miapple.me/install-plexconnect-on-windows-10/ <= Looks like a good guide for setting PlexConnect Up in windows 10

  • SkullzySkullzy Posts: 119Members, Plex Pass Plex Pass

    @iwill424 said:
    Yeah i agree! And that guide is the one I followed to setup PlexConnect for Windows 10 at the first place.
    I even uninstalled everything and started from the beginning still no go.
    I don't know how to do the batch script though.

    Here is a batch script, this will search for port 80, if it is not found it will continue searching until you press CTRL+C TO cancel, whilst the cmd window is active, if it finds the port is being used it will pause showing you the IP:PORT.

    Click the button below for the code to appear
    Copy to text file, and save as PortScan.bat

    @echo off
    @echo.
    @echo. Timeout: 2s
    
    :Scan
    
    @echo. PRESS CTRL+C to quit; Searching for port 80
    @echo.
    
    REM To change search speed, replace 1 with a higher or lower value
    TIMEOUT /T 1 /NOBREAK >NUL
    
    @echo. [#############- TABLE -#############]
    REM If you want to try a different port, replace 80 with the port number.
    
    netstat -an | findstr ":80.*:[^:]*$"
    
    If %ERRORLEVEL% equ 0 (
     @echo. [##########- PORT IN USE -##########]
    ) ELSE (
     @echo. [#########- PORT AVAILABLE -########]
     @echo. [#############- TABLE -#############]
     GOTO Scan
    )
    @echo. [#############- TABLE -#############]
    pause
    
    :EOF
    exit /b
    

    Proof of it working, I searched for a local port I knew was in use, then I searched for port 80 since it's currently not in use on my system. Image below shows the script in use.

  • SkullzySkullzy Posts: 119Members, Plex Pass Plex Pass

    I should also note that this will only scan ports under local address since the issue is your system.. However if you want this to scan ports for foreign addresses (such as remote computers connecting to your system), Then replace the following code

    netstat -an | findstr ":80.*:[^:]*$"

    With

    findstr ":80[^:]*$"

  • iwill424iwill424 Posts: 13Members, Plex Pass Plex Pass
    edited August 2015

    Man thank you so much!!! I appreciate this! So nice of you!
    I ran the script and it does say that it's in used. How do I find out what it is though?

    Timeout: 2s
    PRESS CTRL+C to quit; Searching for port 80

    [#############- TABLE -#############]
    TCP 0.0.0.0:80 0.0.0.0:0 LISTENING
    TCP [::]:80 [::]:0 LISTENING
    [##########- PORT IN USE -##########]
    [#############- TABLE -#############]
    Press any key to continue . . .

    And I still believe it's the port issue, because I went into the Settings.cfg file, changed the port number to 8080 just to test, then it said server is serving as port 8080 no problem. Even though it's still not working but at least I know it's something to do with the fact that port 80 can't be accessed.

    @Skullzy said:

  • iwill424iwill424 Posts: 13Members, Plex Pass Plex Pass
    edited August 2015

    OMFG I GOT IT!!!!!!
    It's the freaking "World Wide Web Publishing Service (W3SVC) is listening to the 80 port!!!!!!!!!
    I had to Google it because it's not showing in either NetStat or anything else...
    On Windows 10 it's LISTENING to Port 80. That's why it's not showing in NetStat as in used. As it's a system service so it's under 0.0.0.0:80 Listening. THANK YOU SO MUCH for your help Skullzy!!!

  • SkullzySkullzy Posts: 119Members, Plex Pass Plex Pass

    @iwill424 said:
    OMFG I GOT IT!!!!!!
    It's the freaking "World Wide Web Publishing Service (W3SVC) is listening to the 80 port!!!!!!!!!
    I had to Google it because it's not showing in either NetStat or anything else...

    ... that's what @wahlman.j basically give you at the very start of this post..

    If you go to that topic and look at the answer, it literally tells you to disable W3SVC.. Posted the image below

  • iwill424iwill424 Posts: 13Members, Plex Pass Plex Pass
    edited August 2015

    I know! The thing is, it was not there when I checked it. I even took a screen shot just to make sure I was not crazy because everyone elses who had that issue was resolved by disabling that service.

    Though today I deleted the old Windows 7 system folder, uninstalled AVG as well.
    Then reboot the system, then that service showed up!

    Now I just feel like a dumb dumb ugh

    @Skullzy said:

  • iwill424iwill424 Posts: 13Members, Plex Pass Plex Pass

    So I found out what actually happened.
    I went back to check the AVG firewall log, I kept a copy of the data so that when I install again I get to know what's not supposed to be allowed. The W3SVC service was on the list for some reason, yet it didn't disable it or stop it, it just blocked the access.
    I don't know if that's why I couldn't see it in the service list in task manager.

  • SkullzySkullzy Posts: 119Members, Plex Pass Plex Pass

    @iwill424 said:
    So I found out what actually happened.
    I went back to check the AVG firewall log, I kept a copy of the data so that when I install again I get to know what's not supposed to be allowed. The W3SVC service was on the list for some reason, yet it didn't disable it or stop it, it just blocked the access.
    I don't know if that's why I couldn't see it in the service list in task manager.

    I'm not an AVG fan, I'm more Eset Smart Security.. I have that set so that I know every connection coming in and or out of my computer.

  • SkullzySkullzy Posts: 119Members, Plex Pass Plex Pass

    @iwill424 said:
    Now I just feel like a dumb dumb ugh

    Even the smartest minds have their dumb moments ;)

  • iwill424iwill424 Posts: 13Members, Plex Pass Plex Pass

    Haha honestly I was not a fan of any Anti-Virus software, after years of experiences you kinda have a good idea what not to touch anyway XD But I put AVG just cuz i dont have much good experience with others, McAfee was pretty good. Never tried Eset Smart Security though so I'll check it out!

    @Skullzy said:
    I'm not an AVG fan, I'm more Eset Smart Security.. I have that set so that I know every connection coming in and or out of my computer.

«1
Sign In or Register to comment.