If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Popping/Crackling audio

Greetings team. I have a popping audio issue.
This will occur in 5.1 or 2.0 modes, and I believe I have narrowed the issue down to PLEX. All audio is handed off to the receiver via a decent quality non-kinked optical cable. Standard broadcast (antenna) 5.1 and 2.0 over the same link do not seem to experience this issue.

What occurs: frequently, maybe during loud sound or just standard dialog, static pop through the speakers. I can record this if you want to know the type of noise specifically.

Expected: smooth audio playback

Occurs quite often in the crunchyroll plugin, and I bring this up since I can't select video mode (direct play/stream, transcode) in this app so I do not know if this contributes.

Willing to test if I just knew what to test.

Thanks all

Answers

  • mprizzlemprizzle Posts: 16Members ✭✭

    I can almost confirm this is a Plex only issue. no other input causes this problem, nor does TV antenna audio over the same unkinked Toslink cable.Is there an issue with decoding 6 channel audio that would cause popping and crackling?

  • OrcaOrca Plex for Samsung Developer Posts: 7,400Members, Plex Pass, Plex Ninja Plex Ninja

    I'm afraid I have no control over what a channel does.
    If the audio on this channel gives you problems, please contact the developer.

    Have you checked if your answer might be in the User Manual?
    My Samsung environment:

    2010 BD-C5500 Blu-Ray,
    2011 UE46D7000 LED-TV,

    2012 BD-ES6000 Blu-Ray,

    2014 UE55HU8500L UHD LED TV

    If you enjoy this free app, you can buy me a beer by making a Donation

  • mprizzlemprizzle Posts: 16Members ✭✭

    It occurs on all PLEX related viewing so long as the audio is 6 channel. It isn't necessarily on any channels (I don't view other channels) it is just where I first noticed it.

    I have no idea how to go about testing this, though.

  • OrcaOrca Plex for Samsung Developer Posts: 7,400Members, Plex Pass, Plex Ninja Plex Ninja

    If it doesn't happen when using the TV speakers, it might be related to your audio set.

    Have you checked if your answer might be in the User Manual?
    My Samsung environment:

    2010 BD-C5500 Blu-Ray,
    2011 UE46D7000 LED-TV,

    2012 BD-ES6000 Blu-Ray,

    2014 UE55HU8500L UHD LED TV

    If you enjoy this free app, you can buy me a beer by making a Donation

  • mprizzlemprizzle Posts: 16Members ✭✭

    It doesn't happen when my TV Tuner is decoding the antenna 5.1 DDS signal and sending it over the same optical cable to the audio system. It does happen, though, when PLEX is decoding it. Maybe it is a memory limitation maxing out audio buffers on the stream? I am not too sure how the PLEX audio pipeline works so I can only guess. There is no popping on any other sources played over the same audio equipment.

  • OrcaOrca Plex for Samsung Developer Posts: 7,400Members, Plex Pass, Plex Ninja Plex Ninja
    edited October 2015

    It's hard to tell why that happens without knowing what kind of audio is inside your movies.
    Audio channels might not be in the spot that they need to be, which might cause the TV to output a wrong signal because it can't decode that signal correctly.
    If you have HDMI (ARC) on your amp, use that, it might fix the problem.

    Have you checked if your answer might be in the User Manual?
    My Samsung environment:

    2010 BD-C5500 Blu-Ray,
    2011 UE46D7000 LED-TV,

    2012 BD-ES6000 Blu-Ray,

    2014 UE55HU8500L UHD LED TV

    If you enjoy this free app, you can buy me a beer by making a Donation

  • mprizzlemprizzle Posts: 16Members ✭✭

    Ok... Resurrecting this because it keeps happening and not just on any channel. I am still using optical/digital because ARC breaks external laptop video (thanks Samsung for that).

    This needs a deep dive - I've played the same video format through Samsung Link (BLEGH) and through Plex, and I will get occasional channel popping through Plex that I will not get through Link. If there is any way I can send audio logs back I would be thrilled to help test on this. I wanted it to be just me wishful thinking or a shoddy wiring job, but I've traced my cables through the basement, any A/C crosses are at 90 degree perpendicular, good solid cables (I've stripped enough wire and used good banana plugs so it should be) and now, using different players, I can definitely determine the issue occurs only when any DTS 6 file is played through Plex. Again I'm not trying to be adversarial; I have a decent amount of tech knowledge. I am willing to test and reproduce this in any way possible to get it working right. I also understand it can be supremely difficult to reproduce issues like this as the software can be compiled perfectly but still have small quibbles that cause random issues under certain conditions. Maybe an audio buffer is maxing out? That would be my newb assessment without knowing the backend.

  • zentsangzentsang Posts: 2Members, Plex Pass

    mprizzle ... I am experiencing the exact same issue as you. First my specs because everyone always asks for them.

    • I am running Windows 10 (64-bit) on an Intel i7 PC with 16GB RAM, 250GB SSD, and an Nvidia GTX 970.
    • My network is all Gigabit and I ran all quad-shielded Cat 6 cables in my house.
    • I am using Roku 2, 3, and Stick on my HDTVs (Samsung, Vizio, and Emerson) connected with HDMI 1.4 HDCP-compliant cables.

    About 5 or 6 Plex versions back I know i didn't have the issue. Then slowly I started noticing the issue after each new update. I tried to rollback to version 1.0.3 and then 1.0.2 as mentioned in other forums, but so far no luck. I can hear the popping and crackling really well on Reality TV shows like "America's Got Talent" and "Big Brother". But it exists on all the MKV videos it seems. I don't get the issue on MP4s. I was thinking of trying the Plex 0.x.x version just before the 1.0.x versions then it hit me... I needed to try the latest 1.1.4 version on my Linux Mint 18 machine. Guess what? No popping or crackling on the exact same MKV file I had with Windows 10. So I tossed a few more videos at it and same results. There is no popping on the Linux 1.1.4 version of Plex. SOOO... I made a connection. I wasn't the versions of Plex causing my issue... it's Windows 10! Because if the same version of Plex works fine on Linux with the same videos... but I get the popping on Windows 10... process of elimination is pointing at something in Windows 10. So for testing... I'm going to install Windows 7 on another PC I have and see if I get the popping with the latest Plex 1.1.4 version.

    I have bookmarked this page and promise I will report my findings. I know a lot of us are having this issue and I seem to be the first person reporting the popping/crackling connection with Windows 10 versus Linux.

  • Ujura6655Ujura6655 Posts: 5Members, Plex Pass Plex Pass

    Hello everyone, I know this is an old thread but I am experiencing the exact same issue. crackling audio from the plex app on roku.

    Has this been resolved in any way?

  • OrcaOrca Plex for Samsung Developer Posts: 7,400Members, Plex Pass, Plex Ninja Plex Ninja

    This forum section is about the Samsung SmartHub app. For Roku questions go here.

    Have you checked if your answer might be in the User Manual?
    My Samsung environment:

    2010 BD-C5500 Blu-Ray,
    2011 UE46D7000 LED-TV,

    2012 BD-ES6000 Blu-Ray,

    2014 UE55HU8500L UHD LED TV

    If you enjoy this free app, you can buy me a beer by making a Donation

  • dpz86dpz86 Posts: 1Members

    @zentsang said:
    mprizzle ... I am experiencing the exact same issue as you. First my specs because everyone always asks for them.

    • I am running Windows 10 (64-bit) on an Intel i7 PC with 16GB RAM, 250GB SSD, and an Nvidia GTX 970.
    • My network is all Gigabit and I ran all quad-shielded Cat 6 cables in my house.
    • I am using Roku 2, 3, and Stick on my HDTVs (Samsung, Vizio, and Emerson) connected with HDMI 1.4 HDCP-compliant cables.

    About 5 or 6 Plex versions back I know i didn't have the issue. Then slowly I started noticing the issue after each new update. I tried to rollback to version 1.0.3 and then 1.0.2 as mentioned in other forums, but so far no luck. I can hear the popping and crackling really well on Reality TV shows like "America's Got Talent" and "Big Brother". But it exists on all the MKV videos it seems. I don't get the issue on MP4s. I was thinking of trying the Plex 0.x.x version just before the 1.0.x versions then it hit me... I needed to try the latest 1.1.4 version on my Linux Mint 18 machine. Guess what? No popping or crackling on the exact same MKV file I had with Windows 10. So I tossed a few more videos at it and same results. There is no popping on the Linux 1.1.4 version of Plex. SOOO... I made a connection. I wasn't the versions of Plex causing my issue... it's Windows 10! Because if the same version of Plex works fine on Linux with the same videos... but I get the popping on Windows 10... process of elimination is pointing at something in Windows 10. So for testing... I'm going to install Windows 7 on another PC I have and see if I get the popping with the latest Plex 1.1.4 version.

    I have bookmarked this page and promise I will report my findings. I know a lot of us are having this issue and I seem to be the first person reporting the popping/crackling connection with Windows 10 versus Linux.

    I have the same issue with my Windows 10 setup and LG WebOS TV. I have it with "The Grand Tour".

  • d3myzd3myz Posts: 1Members, Plex Pass Plex Pass

    I am also experiencing this issue on plex content playing from my Samsung PN60f8500. It seems no matter what content I Play, MKV, MP4, I experience a crackling/studdering sound at random, sometimes it's every 3 seconds, sometimes they are minutes apart. The issue is not limited to Plex, it also occurs in Netflix and Hulu, but much less frequently. I'm Running an optical cable from the TV to my Denon receiver. I have not tested it through ARC as i've never been able to get it to work successfully through my receiver. I am also running my server on Windows 10. 16GB, GTX 780.

  • CBMFellowsCBMFellows Posts: 93Members, Plex Pass Plex Pass

    Any progress? I keep getting popping noises/bleeps on PMP on Windows 10. Sometimes when the sound pops, it goes off altogether and I have to exit and play the file again to get it back.

  • zzenz5zzenz5 Posts: 1Members

    I also have been having this issue on Windows 10 - HDMI direct to TV... Started to happen a few updates ago as well.
    Popping and then sometimes audio goes off completely etc.

    What pisses me off the most is that I have been trying to find an answer for this for ages BUT no one seems to ever report a fix.You would think that with so many people reporting this that a plex engineer would be able to be recreate the issue on windows 10 and see if there was a fix..... Even if it is a Windows 10 issues, it makes Plex itself look bad.

  • CBMFellowsCBMFellows Posts: 93Members, Plex Pass Plex Pass

    It’s not been that bad for me lately - sometimes some videos have a quick bleep but not as bad as before. What are your settings like in the Windows Sound settings?

Sign In or Register to comment.