Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Player could not render this content, Media might be corrupt or the media type is not supported

harold.hannahharold.hannah Members, Plex Pass Posts: 17 Plex Pass

I have a UN55F6300AF TV. When attempting to watch a movie from cloud sync on my Samsung TV, I receive this error. The same movie plays perfectly from cloud sync on an ipad.

I have attempted changing the settings to direct play, direct stream etc. Still does not work. I believe since it lays fine on the ipad this is either a plex for samsung or a samsung error.

Any ideas?

Best Answer

Answers

  • OrcaOrca Plex for Samsung Developer Members, Plex Pass, Plex Ninja Posts: 7,267 Plex Ninja

    Have you tried a different storage provider?
    I had some issues with Google as well, but Dropbox worked fine for me.

    Have you checked if your answer might be in the User Manual?
    My Samsung environment:

    2010 BD-C5500 Blu-Ray,
    2011 UE46D7000 LED-TV,

    2012 BD-ES6000 Blu-Ray,

    2014 UE55HU8500L UHD LED TV

    If you enjoy this free app, you can buy me a beer by making a Donation

  • harold.hannahharold.hannah Members, Plex Pass Posts: 17 Plex Pass
    edited November 2015

    1) Why would google work on ipad but not on Samsung TV's?
    2) Google also works on my Roku stick but not plex for samsung.

    So Google works on 2 of 3 platforms with no problem. That indicates to me that it is a problem with the Samung app.

  • TripleHBKTripleHBK Members Posts: 10 ✭✭

    I've just started experiencing this problem as well though it's related to 1080p content. I have several locally hosted 3 TB drives that have hosted my media for some time and are all working fine. Episodes of certain shows in 1080p.mp4 format started misbehaving about a month or two ago. The solution at that time was to change the container from .mp4 to .mkv which seemed to solve the issue.

    Starting today however files will now refuse to play at all and instead trigger the "Player could not render..." message. This is happening on files that played fine months ago all the way up until this past week before installing the latest server update. I typically have left my settings set to "Auto" on the app, however for these specific episodes I've now had to change the play type to "Transcoding", at which point the file now works. Auto, Direct Play, Direct Stream, all result in the same error message... Transcoding however for the moment is a temporary work around. In my case the files affected are very small so transcoding works ok... however if this was a large file/movie, there's no way this would be a viable option.

  • OrcaOrca Plex for Samsung Developer Members, Plex Pass, Plex Ninja Posts: 7,267 Plex Ninja

    Renaming a file, doesn't make it a different container, so if that worked, it was pure luck.
    Files that played before do not suddenly become unplayable, unless there is something wrong with your discs.

    Have you checked if your answer might be in the User Manual?
    My Samsung environment:

    2010 BD-C5500 Blu-Ray,
    2011 UE46D7000 LED-TV,

    2012 BD-ES6000 Blu-Ray,

    2014 UE55HU8500L UHD LED TV

    If you enjoy this free app, you can buy me a beer by making a Donation

  • TripleHBKTripleHBK Members Posts: 10 ✭✭

    @Orca said:
    Renaming a file, doesn't make it a different container, so if that worked, it was pure luck.
    Files that played before do not suddenly become unplayable, unless there is something wrong with your discs.

    I used avidemux to change the container, Not a simple rename... and in this case, files that played fine have become problematic due to some problem between the Plex server, the Plex for Samsung App and the Samsung Smart Hub interface as nothing else has changed besides the Plex Server software, and the Smart hub. (Correct me if I'm wrong but the Samsung App hasn't had an update in sometime)

    I have used plex without much problem since 2012 and am familiar with the various bugs that have came with each revision and update and normally don't post unless it's a serious issue and I feel I can add something to the conversation and not just complain. I've never had the issue with 1080p content until the last few months, (I originally posted about the tv restarting while trying to play the 1080p .mp4 files... an issue that was resolved by remuxing the files into .mkv's) I've never once experienced the "Player cannot render.." message until today despite having nearly 12TB worth of files saved over the previous 4+ years. I've made bit for bit copies, and I've used handbrake to shrink files down, all without problem. This is a new problem that has come about in the last few months after the previous 2 or 3 Server updates and however many Smart Hub updates. I have uninstalled Plex from my smart Hub in the past and it's made no noticeable difference as to how the files behave just to throw that out there as well.

    Samsung Smart Hub is about the clunkiest interface I've ever seen, and I have no doubt that the updates to that service are what have caused the instability between the Plex app and my media. I understand you're the only person that works on the Samsung App, so I don't expect any kind of update with any regularity, however I post my notes on whats happening and what I've found as temporary fixes so you can look at what I and others are saying and see if there's something that can be changed/fixed. The exact same files play fine on my roku and when sent to my phone or tablet, this is very clearly a Samsung app issue.

    I'm using Plex Server Web Version 2.4.23 (Version 0.9.12.19) on my Windows 8.1 Machine. All settings are in the default position on the Server and on the Samsung App. The Samsung App is the most recently released version. (2.001) on my 2012 Samsung PN60E7000 Plasma Smart tv. I can take 720p files of any format and they work fine... .mp4, .mkv .avi .mpeg makes no difference. Large file sizes, small file sizes as long as the resolution is 720p everything runs silky smooth, however when I jump into the 1080p area particularly as it relates to .mp4's... that's where these new issues have started to crop up over the last 2-3 months, even on files as small as 100mb. I appreciate the work you do and you taking the time to even bother responding on the forums like this, so hopefully something somewhere in what I've said will be of some use.

  • ladridgeladridge Members Posts: 1

    Hello, on a similar thread, I get the same error message when reading videos from a channel added to my server, on a Samsung TV.

    Server version is now 0.9.15.2.
    Plex App (TV Samsung) is 2.004

    The problems started when I updated the Samsung App. The problem is only happening when using TV app. I can run the video on Plex Web, and it does not happen with all kind of channels.
    eg: Canal plus does not work, but StartCraft II pod cast works fine (actually even better with the newest TV app).

    Any idea?
    I already tried removing all and brand new instal :/.

    Appreciated.

  • AltayreAltayre Members Posts: 1

    I have the same problem. I can run the video on Plex Web, but when I tried run the same video on Plex in my Samsung Samrt TV, it crash and show "Player could not render this content media...". It's so annoying.

  • OrcaOrca Plex for Samsung Developer Members, Plex Pass, Plex Ninja Posts: 7,267 Plex Ninja

    Please read the manual on how to activate transcoding, that will help with playing files that are not natively supported on the TV.

    Have you checked if your answer might be in the User Manual?
    My Samsung environment:

    2010 BD-C5500 Blu-Ray,
    2011 UE46D7000 LED-TV,

    2012 BD-ES6000 Blu-Ray,

    2014 UE55HU8500L UHD LED TV

    If you enjoy this free app, you can buy me a beer by making a Donation

  • II_LEI_IIII_LEI_II Members Posts: 1

    So I've got the same Problem as Altayre and others have. I can play all my files from my Qnap in the Plex Web, but when I try to play them on my Samsung Smart TV (UE55JU7080) I sometimes (recently more and more) get the "Player could not render this content media...". All my files are usually .mkv files and they are the ones that get the error message sometimes. I have checked and updated everything (TV app, Plex Web, Plex Server client). I have tried to change the transcoding settings (after having read the User manual) but nothing has worked out for me yet. Can anybody help me out here? It is very annoying.....

  • OrcaOrca Plex for Samsung Developer Members, Plex Pass, Plex Ninja Posts: 7,267 Plex Ninja

    It could be the audio codec that is used. Please have a look at this topic.

    Have you checked if your answer might be in the User Manual?
    My Samsung environment:

    2010 BD-C5500 Blu-Ray,
    2011 UE46D7000 LED-TV,

    2012 BD-ES6000 Blu-Ray,

    2014 UE55HU8500L UHD LED TV

    If you enjoy this free app, you can buy me a beer by making a Donation

Sign In or Register to comment.