Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Low volume audio on ATV 4?

LundmarkLundmark Posts: 450 Plex Pass

I'm finding that I have to crank up the volume on Plex on my ATV 4 quite a lot compared to other media (though this is an issue with HBO Nordic too). Is there a way to boost the audio, or is this a known issue?

«1

Answers

  • AgentMaxAgentMax Posts: 359 Plex Pass
    edited November 2015

    Audio boost can be set in options of plex app.

  • LundmarkLundmark Posts: 450 Plex Pass

    @AgentMax said:
    Audio boost can be set in options of plex app.

    That is only for downmixed multichannel audio. Or so it says.

  • AgentMaxAgentMax Posts: 359 Plex Pass

    Thats the only way you can control the volume. AC3 is not processed and is "pass thru".

  • QuasarQuasar Posts: 267 Plex Pass

    I've noticed this too. Though it seemed like all apps.

  • Allan68Allan68 Posts: 497 Plex Pass

    It is definitely lower, I have to crank my amp quite a bit more than usual, and then turn way down when using other apps on the Apple TV. I also have reduce loud sounds off.

  • LundmarkLundmark Posts: 450 Plex Pass

    Music via AirPlay is plenty loud on Apple TV, though. Maybe it's not a Plex issue, but there sure is something going on.

  • chazplexchazplex Posts: 87 Plex Pass
    edited November 2015

    @Lundmark said:
    Music via AirPlay is plenty loud on Apple TV, though. Maybe it's not a Plex issue, but there sure is something going on.

    Definitely not Plex -- especially noticeable when listing via Bluetooth headphones and any audio or video app. Some media requires the headphones be turned all the way up, but only a couple notches for the same media on my MacBook. Hopefully it's something they can improve with a future firmware update. I get the same results with media AirPlay'd from my iPhone or MBP to the ATV as I do from playing direct on the ATV.

  • JanstieJanstie Posts: 53 Plex Pass

    Same here AppleMusic is way louder than everything else, but Plex seems to be quieter than Netflix.

  • LundmarkLundmark Posts: 450 Plex Pass

    Not just Apple Music for me. Other streaming services, including video, have "normal" volume levels comparable to those of other sources and the previous Apple TV.

    So: some content sources are as loud as they should, and some are way too quiet. Weird.

  • chrisandsallychrisandsally Posts: 29 Plex Pass

    There is definitely some thing wrong with low volume on the ATV4. Volume on amp maxed out to hear it. Find when playing through vnc etc

  • DapnessDapness Posts: 25 Plex Pass

    Anyone notice the volume jumps substantially when you pause and replay the media. It does on my like every time.

  • JanstieJanstie Posts: 53 Plex Pass

    Not happening here…

  • skippa79skippa79 Posts: 3 Plex Pass

    I've noticed this the first couple of times I watched someting.. There is a setting within the Apple tv for Automatic adjusting of the sound volume, perhaps changing this will get you sorted?

  • Definitely having this issue too. Every other Apple TV app sounds good at around ~30% TV volume. Plex sounds the same at ~60%.

    Needs some sort of volume booster?

  • LundmarkLundmark Posts: 450 Plex Pass

    This seems to be resolved with yesterday's tvOS update. Nice.

  • Not for me. :/

  • Ashok77Ashok77 Posts: 3 Plex Pass

    Any updates on this? I'm having the same issue, Apple Music plays at normal volume settings but anything on Plex I need to crank the volume up significantly. I have to double check but I have some FLAC files on Plex and off the top of my head I think they played fine...maybe only an issue with TV or Movies? Anyhow, just bumping the thread to see if there as been any work arounds or tips. Cheers!

    Oh and for reference I have an ATV4 --> Pio vsx 92txh (receiver) --> Pio 5010fd all connected via HDMI

  • lauridsdlauridsd Posts: 117 Plex Pass

    Same problem here. Apple Music blows me away on 100% volume with headphones while Plex is a bit too low on volume for my likings also at 100%.

  • wrcwillwrcwill Posts: 9 Plex Pass

    Is everyone here using a stereo speaker setup (2.0)? Might be related to a problem i have.

  • wrcwillwrcwill Posts: 9 Plex Pass
    edited February 2016

    fixed by changing audio.channel limit to 2 on all file types in xml profile of tvOS.

    Looks like the ATV wasn't downmixing to 2.0 even if we set it to stereo. So you weren't getting all the channels, which is why volume appears lower. modifying the xml forces plex to do the downmix instead. Still a bug that needs to be fixed by apple tough.

    below is a comment i wrote replying to someone on reddit:

    i had been trying to mod it since this morning (another part of it though), but it didn't seem to have any effect. Turns out you need to restart the plex server for the changes to be read, lol


    1) Is this the proper way of doing it?

    <VideoAudioCodec name="aac">
      <Limitations>
        <UpperBound name="audio.channels" value="2" />
      </Limitations>
    </VideoAudioCodec>
    
    <VideoAudioCodec name="ac3">
      <Limitations>
        <UpperBound name="audio.channels" value="2" />
      </Limitations>
    </VideoAudioCodec>
    
    <VideoAudioCodec name="eac3">
      <Limitations>
        <UpperBound name="audio.channels" value="2" />
      </Limitations>
    </VideoAudioCodec>
    
    <VideoAudioCodec name="mp3">
      <Limitations>
        <UpperBound name="audio.channels" value="2" />
      </Limitations>
    </VideoAudioCodec>
    
    <VideoAudioCodec name="pcm">
      <Limitations>
        <UpperBound name="audio.channels" value="2" />
      </Limitations>
    </VideoAudioCodec>
    

    or could I have written it like this:

    <VideoAudioCodec name="aac,ac3,eac3,mp3,pcm">
      <Limitations>
         <UpperBound name="audio.channels" value="2" />
      </Limitations>
    </VideoAudioCodec>
    

    2) What do these do:

    <Setting name="DirectPlayStreamSelection" value="true" />
    <Setting name="StreamUnselectedIncompatibleAudioStreams" value="true" />
    

    3) In this case, the movie I was testing with wasn't eligible for direct play, since it was an mkv container and direct play requires mp4:

    <DirectPlayProfiles>
    <VideoProfile container="mp4" codec="h264,mpeg4" audioCodec="aac,ac3,eac3" subtitleCodec="mov_text,tx3g,ttxt,text" />
    

    However, if there is a movie that does fit these criteria, will it still consider the audio.channel limitations I set? Because in my understanding direct play doesn't touch the files at all.


    4) Why did I even have to do this? I can't be the only one playing movies with a 2.0 setup, can I? Shouldn't the ATV do the downmix by itself, since I set it to stereo? I'm asking because if there is a problem with my ATV, i can just return it and get a new one since i purchased it yesterday. I don't want to patch it now only to find out in a year that mine was defective, haha

«1
Sign In or Register to comment.