Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Music library problems

moody_bluemoody_blue Posts: 2,112Members, Plex Pass Plex Pass

I don't know if PlexConnect is working as intended, or if the following situations are bugs, can you please clarify ?

  1. If I select "All Artists" in the top level menu I get an almost all black screen, with an horizontal line in the middle, and a "More" box that, when selected, give me the available albuns. It would be nicer to have a single screen, if possible
  2. If I select "By Genre" in the top level menu I get an almost all black screen, identical to situation 1. above, but this time the "More" button is not able to find any album
  3. If I select "By Decade" or "By Year" in the top level menu I get a list of available decades/years, but from then on I get no album list at all
  4. If I select "More..." I get the "Accessing Trailers" message with a never ending rotating circle. If I press "Menu" I return to the previous screen

Best Answer

Answers

  • baabaa Posts: 3,954Members, Plex Pass, Forum Moderator Forum Mod
    edited December 2015

    Sounds like a bug to me... Music or Premium Music section?
    Did you update your PMS recently? I currently tent to blame that one for changing interface XMLs...

  • moody_bluemoody_blue Posts: 2,112Members, Plex Pass Plex Pass

    Thanks baa,

    Music section (not premium)
    I've tested with PMS 0.9.12.19 and 0.9.14.4
    In the PMS log I have this error message -> ERROR - Error resizing an image, we don't trust what we cached [/volume1/Plex/Library/Application Support/Plex Media Server/Cache/PhotoTranscoder/9c/9cca471bda559007dce37a7fd1922551326f1036.jpg]
    Dec 01, 2015 08:34:27

  • baabaa Posts: 3,954Members, Plex Pass, Forum Moderator Forum Mod

    Well, open that image if it is familar. Or delete it to have PMS rebuild it from scratch?

  • moody_bluemoody_blue Posts: 2,112Members, Plex Pass Plex Pass
    edited December 2015

    Further tests seem to indicate that situation 1) is apparently caused by a malfunctioning PIL. I've updated PIL sometime ago, and now I notice that I do not have fanart anywhere (films, tv shows, etc), even though PlexConnect says that PIL support is Ok... I've requested the previous version to Synology to confirm (I'm using Python Module 0008, and I'm almost sure that with 0006 fanart was Ok).

    Situations 2) 3) and 4) seem to have nothing to do with the error that appears in the PMS log. That PMS error also appears in a number of other situations, and they seem to work. Do you need more info to investigate what may be causing these errors ?

  • baabaa Posts: 3,954Members, Plex Pass, Forum Moderator Forum Mod

    A log ("High") might be helpful... try to keep it small, just diving into "All Artists" for a start. :-D

  • moody_bluemoody_blue Posts: 2,112Members, Plex Pass Plex Pass
    edited December 2015

    Here are the logs for All Artists. With fanart:

    • On - When I select an artist, the next screen has the top half black, a blank horizontal line, and below the line a thumnail and the more... button that, when clicked, shows the second screen, where I see the thumbnails of the various albuns
    • Off - When I select an artist, the next screen has a large thumbnail (the same image that appears when fanart is on, but larger), no blank line, and the more... button that, when clicked, shows the second screen, where I see the thumbnails of the various albuns

    I see nothing wrong here, except for no fanarts appearing, but I don't know if they are supposed to appear when fanart is active. In my opinion the two screens could be combined in a single one, that would make navigation easier.

    Edit - I have several multi-CD albums. In PlexWeb I see this
    Disk 1
    |- Track1
    |- Track2
    Disk 2
    |-Track1
    |-Track2

    In PlexConnect I see this:
    |- Track1
    |- Track2
    |-Track1
    |-Track2

    Therefor, with PlexConnect, I loose the info of CD1/2/etc.

  • moody_bluemoody_blue Posts: 2,112Members, Plex Pass Plex Pass

    Sorry for not replying earlier, but I'm struggling to fix my fanart problem (fanart is no longer working for me, films, series, etc., but that's another problem, for another thread).

    With fanart active I do not see the "more" button, I can roll down to the next screen, but his is not very "intuitive". With fanart disabled I see the "more" button. What happens in your case ? Do you see "more" button when fanart is active ?

    About multi-CD support, here is what I see in PlexWeb

    In PlexConnect I do not have a "Disk 2" line separating track 21 of the 1st CD and track 2 of the 2nd CD. As in this case the music album has 5 CD's, when I scroll to the bottom it's not easy (in PlexConnect) to know if I'm on CD 3, 4 or 5.

  • baabaa Posts: 3,954Members, Plex Pass, Forum Moderator Forum Mod

    multiple discs...
    how are they ordered on your hard drive? Each one in a distinct folder? With disc number as additional ID to the track?

  • moody_bluemoody_blue Posts: 2,112Members, Plex Pass Plex Pass
    edited December 2015

    Case 1 - Separate folders

    Case 2 - Single folder, manual update in PlexWeb to indicate which tracks are in disc2

    Case 3 - Single folder

  • baabaa Posts: 3,954Members, Plex Pass, Forum Moderator Forum Mod

    moody_blue:
    And with all "cases" you have the issue that PlexConnect doesn't differentiate between the CDs? I double-checked, only case 1 (separate folders) and it seems to work fine.

    FanArt on/off should give you the following views:

    And both link to the albums view - in this case one collection of 3 CDs:

    At least in no-FanArt mode, the Albums could live in a shelf on the bottom of the artists' page, yes.

  • moody_bluemoody_blue Posts: 2,112Members, Plex Pass Plex Pass
    edited December 2015

    Thank you very much. Your information was very valuable to guide me on how to debug the situation. I had a general problem with fanarts, they did not show up anywhere, even in films, so I made a Refresh All in PMS, library by library, until I had fanarts in all libraries again.

    Then I've gone to PlexConnect to show fanarts of a specific artist (Eric Clapton) and they do not show up. This specific fanart shows up in Plex for android in my phone. I do not see anything strange in PMS logs, but PlexConnect logs contain an error. I'm attaching the relevant info.

    Also I do not see multi-CD albums separated with identical thumbnails, as you have in Bruce Springsteen. I have a single thumbnail (both in PlexWeb and PlexConnect), therefore I can play the whole album, with all its CD's. In PlexWeb (and also in Plex for Android), when I open this single thumbnail, I see a list of all tracks, but the tracks of CD1 have "Disc 1" top label, the tracks of CD2 have "Disc 2", and so on. This is what I would like to have also in PlexConnect.

    Edit - If you want, you can use PlexWeb to give the same name to your Bruce Springsteen CD's and they will appear under the same thumbnail

  • baabaa Posts: 3,954Members, Plex Pass, Forum Moderator Forum Mod

    Those 3 CDs were held in separate folders. Not sure, if this influences the way PMS grabs and orders them?
    I will see to do some tests with different naming configurations as you suggested.

Sign In or Register to comment.