Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Plex app stops playing with some movies

straycat264straycat264 Members, Plex Pass Posts: 11 Plex Pass

Movies stop playing with an error when they get to a particular point. The point seems to depend on the encoding quality - some of the higher quality movies are generally stopping around the 27-28 minute mark while I've had other DVD-quality movies stop much later. Playback simply stops reporting an error (unspecified). Any attempt to fast forward past that point, and the movie resets back to the beginning. This does limit what I can watch.

Playback before this point is generally very smooth and trouble-free - no stutter or issues of any kind.

The server is running on a Raspberry Pi 2, which reports as being too slow to transcode anything - so I've encoded everything as MP4 or H264.

This is happening on a Sony KDL-32W705C, and a Sony KDL50W706 - both on wifi.
This happened on the previous versions of the player & server (0.9.15.2, I think, & 2.4.36) - now on 0.9.15.3 & 2.5.5, and the problem is identical)

Log attached.

I hope you guys can suggest something, because this limits the length of stuff I can watch! Which is a shame.

Edit: Removed the logs. Thanks! - mseeley

Best Answer

Answers

  • straycat264straycat264 Members, Plex Pass Posts: 11 Plex Pass

    Oh - a couple of things I forgot - the movies play fine outside of Plex, and they fine over a web player, and over the OSX Plex Media Player. I can't comment on whether the built-in player can do it, because for some reason it can't see the Plex server - although I assume this is a different issue.

  • mattseeleymattseeley HawaiiMembers, Plex Employee, Plex Pass, Plex Ninja Posts: 1,332 Plex Employee

    Hi @straycat264. I'm having trouble reading through those log files. I can see an error occurs at the end but cannot see where the stream starts. I see some logs in there, I think, from generating an optimized version of the video file.

    Will you please follow these instructions to generate really concise logs? While the you're gathering the logs would you mind not using the media server from other clients too?

    Also, please uncheck the Allow Plex Media Server tokens in logs check box in the Server > General settings in the Plex Web app before starting to gather logs. It'll help keep the logs posted here more private. Thanks!

    (Please no private messages for support unless requested, please)

  • straycat264straycat264 Members, Plex Pass Posts: 11 Plex Pass

    Apologies. I didn't follow the log instructions very well - I hope this attempt is better.
    The error popped up at around the 16:04.50 mark.

  • straycat264straycat264 Members, Plex Pass Posts: 11 Plex Pass

    Update to this - I wasn't happy about the network speed for the Pi, so I added a fast USB3 network adapter to it. Everything now seems a bit faster - it's quicker to get content listings, quicker to load movies and so on, but the problem persists.

    I tried a suggestion made elsewhere on this forum, and turned off Direct Play on the client. Interestingly, the movies will now play beyond the point where they'd previously stop - but I now get a lot of stuttering and long random pauses instead, so it's all still pretty much unwatchable.

  • mattseeleymattseeley HawaiiMembers, Plex Employee, Plex Pass, Plex Ninja Posts: 1,332 Plex Employee

    Hi @straycat264 sorry I got a bit swamped fixing the Vizio startup issues. Will look into this on Friday morning. Cheers!

    (Please no private messages for support unless requested, please)

  • straycat264straycat264 Members, Plex Pass Posts: 11 Plex Pass

    Thanks. I know how hard it is to diagnose stuff like this. Let me know if you need any more info.

  • straycat264straycat264 Members, Plex Pass Posts: 11 Plex Pass
    edited February 2016

    Added note - as far as I can tell, the stuttering & pauses only happen after the point where the movies would have quit if Direct Play is on. Before that point, they play just fine.

    Oh - and I tried playing over DLNA on the TV's built-in media client. The movie bombed out at a similar time - although I only had time to try this once.

  • straycat264straycat264 Members, Plex Pass Posts: 11 Plex Pass

    More investigation. It's the TVs. Both of them. There must have been a software upgrade which broke it, because the built-in DLNA client used to work, but it now fails in exactly the same way with a Plex server, with a Minidlna server, and with Serviio (off a different, much beefier) machine - so I think it's safe to say Plex is off the list of suspects.

    Time to contact Sony. Still - if anyone has come across this (weird that it's happening with two different models of TV), and has any ideas, I would be extremely grateful...

  • straycat264straycat264 Members, Plex Pass Posts: 11 Plex Pass

    Thanks for the advice. I've been playing around with different Handbrake settings (I've lost count of how many times I've ripped my Avatar bluray now), and I am getting some success - the key seems to be to turn Direct Play off on the player, which allows it to play all the way through, then to find some ripping settings which don't cause all the stuttering I've been experiencing. I've got rid of the stuttering now, but haven't quite got the quality I'd like - so I'm going to keep working on that until I have. Then I can re-rip all my blurays (luckily, I haven't got that many)

    Anyway - thanks again.

  • ikramericaikramerica Members Posts: 2

    I know this is a year old but I was/am having the same problem with my Sony non-Android TV. I tried reripping but it made no difference. "Seven" would stop at 29 minutes. I watched "Risky Business" all the way through but by the end audio was close to a second out of sync. Other movies won't play or stop near 30 minutes.

    I changed settings on Plex app to max 3Mbit 720p (my rips are from dvds anyway so who cares), turned off direct play, and set to 4.1 rather than the default 4.0.

    So far Seven is playing fine. I can't tell yet if audio is losing sync.

    I figured it was the TV not Plex when I was able to play Seven on my small LG tv with WebOS

  • ikramericaikramerica Members Posts: 2

    I turned the quality back to original to see if that mattered. The lip sync still is fixed. And Seven plays past 29 minutes. So I'm just going to say the solution, for DVD rips anyway, for Sony TVs without android is to turn off direct play and set to 4.1. I see no degradation in quality this way so I assume that my Mac mini server can handle the repackaging of the content in real time. I don't have HD content to see if it chokes at higher rates.

Sign In or Register to comment.