If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Have a problem with multiple IPs on different subnets?

mattseeleymattseeley HawaiiPosts: 1,377Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

Opera (Vizio, Sony, etc) based devices have particular limitations in place that make life for Plex hard. Netflix, YouTube, Hulu, other devices don't have the same limitations. This frustrates a lot of users who see other applications on their TV and Plex on other devices working as expected. So what the heck is going on?

Well, when your Plex Media Server (PMS) starts up it publishes its network information to plex.tv. Your computer running PMS may be on multiple networks at once. For example, your server:

  • may have multiple physical wifi and/or ethernet interfaces to your LAN
  • or, it may have a virtual interface to a VPN provider
  • or, it may have a virtual interface set by virtual machine (eg VirtualBox, VMWare, etc) software

With this in mind, a particular media server may have many network addresses.

Typically this isn't an issue for Plex. When our client apps start up they'll test all connections and choose the one that responds. That's why your Plex app works fine. Frustratingly, Plex on devices running the Opera SDK can't do that. The Opera SDK has a security feature which causes all of our tests to connections on private IP ranges to fail. Practically speaking there's no way to know which connection is the right one. That's why you see this message:

Your Plex Media Server is on multiple private subnets. We cannot determine which IP is safe for connections from this device.

So, how to resolve?!

Our "VPN on the Plex Media Server Computer" covers the basics. Here's the unabridged version. Please follow these steps exactly and carefully. If you have troubles after following these steps please provide accurate and details information.

  1. Verify you see the "multiple private subnets" warning quoted above.
  2. Confirm our website presents the same IP addresses shown by the error message on your TV.
    • You'll be accessing our API using a web browser on a computer. Please make sure the computer is on the same network as the television.
    • You should see your media server Device. It should have multiple Connection elements with local="1".
  3. Eliminate all non-essential network interfaces.
    • Eliminate virtual network interfaces.
    • Disconnect and quit all VPN software running on the PMS machine. Make sure there aren't other users signed into the machine which may have the VPN software running.
    • Quit any virtual machine software running. Make sure there aren't other users signed into the machine which may have the virtual machine software running. Ensure the virtual machine software hasn't left any network interfaces configured.
    • @NewEnglandNole provided a great analysis and workaround of an issue with VirtualBox. It's a recommended read.
    • Eliminate physical interfaces on different subnets.
    • Is your computer connected to multiple wifi and/or ethernet interfaces and the interfaces are on different subnets? If so, disable/eliminate all interfaces except you want PMS to be accessed using.
  4. Force PMS to publish the new network configuration.
    • Quit PMS.
    • Restart PMS after a couple moments.
    • Return to Step 2 a minute or two after PMS restarts. You should now only see one Connection for your PMS with local="1"?
    • If you still see multiple Connection entries with local="1" please:
    • try again after a few minutes
    • make sure that Step 3 is complete
    • if the problem persists we need to know
  5. If you've made it through this point successfully you should now be able to access Plex Smart TV application.
  6. Slowly restore the other network interfaces and monitor our API for problems (Step 2).

That didn't work! I still see the same error!

  1. Do you see multiple Connection entries with local="1" after carefully going through the steps above?
    • Yes: This is a bug. Please create a new forum post with very detailed information explaining which network interfaces are present on your PMS machine and your experiences running through the steps above.
    • No: the old information is cached on the TV and its not letting go.
    • Sign out of the Plex app on the television
    • Exit the Plex app on your television, turn off the TV, unplug it for a couple minutes then plug it back in.
    • Remove the device from your account using the Plex Web app
    • Restart the Plex app on your television
    • Re-link the device by following the on screen directions
    • You should now see your library content. If not this is a bug. Please create a new forum post with very detailed information explaining when (time+timezone) you went through the linking activity. We'll look into it.

(Please no private messages for support unless requested, please)

This discussion has been closed.