Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

[UPDATED 28/07/17] Buglist - Plex for Android TV App on Nvidia SHIELD TV

danjames92danjames92 Members, Plex Pass Posts: 3,117 Plex Pass

UPDATED 10/06/17

Here is some useful information regarding the limitations / bugs of the current Plex for Android TV client.

Device - Nvidia SHIELD TV
AVR - Yamaha RX-V675 (5.1) via HDMI / CEC / ARC
Direct Play - Auto
Direct Stream - Auto
Passthrough - Auto
Burn Subtitles - Automatic
Refresh Rate Switching - ON
Local Quality - Original Quality
Remote Quality - Original Quality

Supported Formats inside the Plex client on Nvidia SHIELD TV (see spoiler):

Containers: MKV | MP4 | .TS (kind of, limitations present)

VIDEO: VC-1 | H.264 | HEVC | MPEG-2
AUDIO: AC3 | EAC3 | LPCM 8/16/24bit | DTS | DTS-HD MA | TrueHD | Atmos | DTS: X | MPEG-1 | MPEG-2 | FLAC | DTS-HD MA 6.1 | DTS-ES | AAC_LATM (via software decoding)

Currently Unsupported formats inside the Plex client on Nvidia SHIELD TV (see spoiler):

Containers: .AVI (forces video transcode, audio can direct play) .M2TS (won't be fixed.)
AUDIO: ANY 4.1

FIXED ISSUES:

*Lack of VC-1 support. FIXED.
*Lack of TrueHD / Atmos / DTS: X. Now supported with the 3.3 update.
*Lack of LPCM support. 8 | 16 | 24bit now supported. FIXED.
*Some DTS-HD MA files playing back as DTS core. This appears to be fixed for me after reanalyzing. Noticed files were showing DTS for DCA-MA.
*Lack of FLAC 5.1 support. FIXED with 5.8.0.454-beta.
*Stuttering / frame drops after fast forwarding. FIXED with ExoPlayer update.
*Stuttering on 24p playback. (pausing and resuming seems to fix TEMPORARILY) FIXED with ExoPlayer update.
*Headphones disconnected popup upon starting / stopping media. FIXED.
*Subtitles looping / out of sync. 99% sure this was fixed with client update.
*Lack of PGS subtitle support within MKV containers. FIXED.
*Lack of media info in preplay screen, i.e. audio codec, resolution. FIXED. Audio codec / resolution implemented in v4.32.0.363.
*Lack of audio / subtitle selection before playback. FIXED.
* Player jumping 24 hours in the future. More info here - https://forums.plex.tv/discussion/222120/nvidia-shield-tv-weird-issue-skipping-to-25-hours
*Lack of considered 'normal' FF / RW. FIXED with v5.0.0.503-beta. 30s skip with single click, hold for seek.
* DTS-HD MA 6.1 tracks pass only core DTS (1500kbps) stream when they should pass full DTS-HD MA stream. Resolved with Nvidia SHIELD Experience 5.2 update preview. DTS-ES 6.1 is also passed through correctly.
*VC-1 transcoded when a supported audio codec is not found i.e. w/TrueHD. See spoiler for details.

Ian's Reply: 'ExoPlayer only natively supports VC1 when contained within MKV. This means that when we transcode, we can't handle >!remuxed VC1 in HLS. I looked at how much effort it would be to support this, but at the moment it's hard to justify due to the number >!of devices (and users) that actually support and use VC1. I've already made the recommendation to NVIDIA that they look to add >!support themselves, which we'd then pick up. **No longer an issue thanks to TrueHD now being supported! **'

OUTSTANDING BUGS:

@Andrroid: "I just watched 3 episodes of a show. During the 4th episode, I paused it. I waited. Eventually, the Android TV screensaver >!appeared. I then pressed a button on my remote, which ended the screen saver and returned me to Plex. However, I was placed at the >!details screen for the first episode I watched, not the current, 4th episode, I was watching."

Quote from @jesusMC "@Andrroid Hey, sorry for the delay!
Yeah, that issue should be fixed as part of 5.6.0. Could you check that it works correctly for you?
Thanks in advance!"

This does not appear to be the case and is not fixed according to beta tester @Andrroid.

UNAVOIDABLE (UNTIL NVIDIA / GOOGLE FIX EXOPLAYER) ISSUES:

  • Lack of .AVI container support. (Video and audio is always transcoded, despite being MPEG4 / AC3 audio, something that should be able to be direct played or direct streamed at the very least. **Ian Reply: "I spoke to the server/transcoder team and they confirmed that they have had to blacklist mpeg4 video from AVI files to prevent them from ever being remuxed. Apparently they have had a lot of issues with this combination in the past and have found the only reliable way to stream the video is to perform a full remux. This means that unless Google, or someone else adds AVI support to ExoPlayer, MPEG4 will be transcoded when contained within an AVI on the Android client."

A ExoPlayer dev has stated that a AVI Extractor would need to be written but there is currently no demand for this.
Source - https://github.com/google/ExoPlayer/issues/2092

DESIGN FEATURES YET TO BE IMPLEMENTED:

  • Pressing the play key (HDMI-CEC, Harmony, Nexus Player remote) does nothing on posters of movies/episodes/tv shows/seasons. Ian's Reply: "Known feature that we haven't yet implemented. We should be allowing users to skip preplay pages, etc if they hit a "Play" button. The reason it hasn't been prioritized is that only a few Android TVs actually have a Play button on the remote."

LIMITATIONS:

  • Lack of thorough USB amp support.
  • Unable to decode all audio formats as LPCM when Audio Passthrough is disabled. Side note: A new Android TV beta has enabled software decoding for AAC_LATM as seen on DVR recording with more formats "to come in the future", paraphrasing @sixones comments.
  • .m2ts container is unsupported. Unlikely to be fixed as disc based formats. Plex do not want to use disc-based formats.
  • MPEG-TS containers are unsupported and provide unexpected results. DVR users will want to enable remux to MKV or use an appropriate post-processing conversion script. As of PMS 1.7.1, Plex now recorded to .MKV containers directly instead of .TS presumably for better compatibility. As of 1.7.5, the choice to switch to .MKV for DVR was reverted back to .TS (presumably for better compatability with USA subtitle ota formats).

NOTABLE CHANGES:

Plex for Android 5.10.0.55-beta - Upgrade ExoPlayer to r1.5.16. (I believe we were at custom ExoPlayer r1.5.12 previously)

Mac Mini (2.7GHz, Late 2012, Windows 10, Kodi DSPlayer) | SATV 16GB | Panasonic TX-P50GT50B | Yamaha RX-V675 | Q Acoustics 2010i (FL, FR, Left S, Right S), Q2000ci Center, Q2070si Sub

 

Best Answer

«1345678

Answers

  • dmende03dmende03 Members, Plex Pass Posts: 23 Plex Pass
    edited March 2016

    I agree with @danjames92

    Some feedback would be nice! I have posted questions like this in the past and it seems that the developers do not watch (care?) about the forums. I have pretty much gone Kodi full-time now.

  • YamanotefyYamanotefy Members Posts: 10 ✭✭

    @dmende03 said:
    I agree with @danjames92

    Some feedback would be nice! I have posted questions like this in the past and it seems that the developers do not watch (care?) about the forums. I have pretty much gone Kodi full-time now.

    Me too, Kodi and PlexBMC are currently the only way to enjoy video.
    In lack of any profund answer of the developers, I really much doubt they care about the quality of their app on Android TV so far ...

  • iforgotiforgot Members, Plex Pass Posts: 82 Plex Pass

    Plex is also the sole reason i have a shield tv. A few bug fixes and it would be without question the best hardware to run plex on. However it appears that not a lot of people are working on the android app, compared to the IOS one for instance which gets updates really quite often.

  • MovieFan.PlexMovieFan.Plex Members, Plex Pass, Plex Ninja Posts: 15,442 Plex Employee

    Hi guys. I don't have an Android TV so I haven't been tracking these issues. If you can provide me links to the original topic for these issues, I'll see if I can find out any info for you. I do have a few comments.

    @danjames92 said:
    LPCM transcodes to AC3. (WIP?)

    Why would you want LPCM to transcode to AC3? You will not gain any benefit and most devices support LPCM.

    Subtitles looping / out of sync (Plex force transcodes as a workaround for now)

    This is a firmware issue AFAIK.

    Lack of PGS subtitle support within MKV containers.

    What do you mean by this? PGS subtitles should get burned in. If you mean direct played, the Shield can't do that.

  • danjames92danjames92 Members, Plex Pass Posts: 3,117 Plex Pass
    edited March 2016

    @MovieFan.Plex said:
    Hi guys. I don't have an Android TV so I haven't been tracking these issues. If you can provide me links to the original topic for these issues, I'll see if I can find out any info for you. I do have a few comments.

    @danjames92 said:
    LPCM transcodes to AC3. (WIP?)

    Why would you want LPCM to transcode to AC3? You will not gain any benefit and most devices support LPCM.

    Subtitles looping / out of sync (Plex force transcodes as a workaround for now)

    This is a firmware issue AFAIK.

    Lack of PGS subtitle support within MKV containers.

    What do you mean by this? PGS subtitles should get burned in. If you mean direct played, the Shield can't do that.

    I don't want LPCM transcoding to AC3 but it is happening on some files AFAIK.

    R.E subtitles, is it a firmware issue on Lollipop or Marshmallow? I didn't get a chance to test on Lollipop before I upgraded. It was working a few versions from what I remember with people reporting back so not sure how it's firmware?

    On the PGS front, don't believe Kodi has an issue with PGS subtitles, it doesn't burn them in there?

    DTS not always working (don't know if logs) - https://forums.plex.tv/discussion/209759/shield-tv-dts-ma-not-working#latest

    My comment regarding 24Hz stuttering (with logs) - https://forums.plex.tv/discussion/comment/1140664/#Comment_1140664

    Some more logs comparing different file types with VC-1 mostly / subtitle test tracks- https://forums.plex.tv/discussion/comment/1131344/#Comment_1131344

    If there are more logs you need please let me know and I can test further.

    Mac Mini (2.7GHz, Late 2012, Windows 10, Kodi DSPlayer) | SATV 16GB | Panasonic TX-P50GT50B | Yamaha RX-V675 | Q Acoustics 2010i (FL, FR, Left S, Right S), Q2000ci Center, Q2070si Sub

     

  • MovieFan.PlexMovieFan.Plex Members, Plex Pass, Plex Ninja Posts: 15,442 Plex Employee

    Thanks for the info. Let me look around a bit and see what I can find. It might not be quick, but know that someone is looking into these issues.

  • danjames92danjames92 Members, Plex Pass Posts: 3,117 Plex Pass

    @MovieFan.Plex said:
    Thanks for the info. Let me look around a bit and see what I can find. It might not be quick, but know that someone is looking into these issues.

    Ok. I would appreciate any sort of update. Please let the devs know if they are active in the forums I will happily test whatever they send my way / provide with logs if needed.

    Mac Mini (2.7GHz, Late 2012, Windows 10, Kodi DSPlayer) | SATV 16GB | Panasonic TX-P50GT50B | Yamaha RX-V675 | Q Acoustics 2010i (FL, FR, Left S, Right S), Q2000ci Center, Q2070si Sub

     

  • kegobeer-plexkegobeer-plex Members, Plex Pass Posts: 5,274 Plex Pass

    @danjames92, do you have a test file with lpcm I can try? I only have a few titles that have lpcm audio, and they all play ok. I'd like to try one and see if I can replicate it on my Shield.

    Where are my log files?

    How do I properly name my media files?

    NVIDIA SHIELD SMB/NAS Sharing How-To - / - NVIDIA SHIELD Support Documents

    Plex Server: 1.8.0 running on ThinkServer TS140 w/Server 2012 R2 Essentials
    Primary Plex Player: Shield TV, always the latest beta build, always the latest firmware revision

  • danjames92danjames92 Members, Plex Pass Posts: 3,117 Plex Pass
    edited March 2016

    @kegobeer-plex said:
    @danjames92, do you have a test file with lpcm I can try? I only have a few titles that have lpcm audio, and they all play ok. I'd like to try one and see if I can replicate it on my Shield.

    Sure! If I remember correctly, it's VC-1 and LPCM that have trouble using the app. I only have 1 test file though (don't think it's PCM). I'll upload to dropbox and put a link here.

    Link: https://www.dropbox.com/s/a3p4flwmnpd6o3a/LPCM.mkv?dl=0

    Mac Mini (2.7GHz, Late 2012, Windows 10, Kodi DSPlayer) | SATV 16GB | Panasonic TX-P50GT50B | Yamaha RX-V675 | Q Acoustics 2010i (FL, FR, Left S, Right S), Q2000ci Center, Q2070si Sub

     

  • cayarscayars Members, Plex Pass, Plex Ninja Posts: 3,962 Plex Ninja

    @MovieFan.Plex any chance we could get a dedicated sub-forum under Android for the shield?
    Right now the shield is different enough Plex from the standard Android client that a sub-forum could be quite useful.

    Carlo

    9,500 Movies, 380 Shows - 32,860 TV Episodes, 380 Christmas Movies, 400 Documentary, 270 3D Movies, 1300 NFL Games, 1280 Educational Videos, Premium Music: 215,560 Tracks, 715 GB Plex Meta-Data.
    Thread on my setup with some tips and tricks: https://forums.plex.tv/discussion/131308/cayars-setup-walk-through-and-some-tips-and-tricks/p1
  • kegobeer-plexkegobeer-plex Members, Plex Pass Posts: 5,274 Plex Pass

    @danjames92 said:

    @kegobeer-plex said:
    @danjames92, do you have a test file with lpcm I can try? I only have a few titles that have lpcm audio, and they all play ok. I'd like to try one and see if I can replicate it on my Shield.

    Sure! If I remember correctly, it's VC-1 and LPCM that have trouble using the app. I only have 1 test file though (don't think it's PCM). I'll upload to dropbox and put a link here.

    Link: https://www.dropbox.com/s/a3p4flwmnpd6o3a/LPCM.mkv?dl=0

    Thanks. I've already duplicated the VC-1 + forced direct problem. Hoping to replicate the LPCM issue. Are you saying that it's a combination of VC-1 and LCPM that's the issue, or just any file with LCPM?

    Where are my log files?

    How do I properly name my media files?

    NVIDIA SHIELD SMB/NAS Sharing How-To - / - NVIDIA SHIELD Support Documents

    Plex Server: 1.8.0 running on ThinkServer TS140 w/Server 2012 R2 Essentials
    Primary Plex Player: Shield TV, always the latest beta build, always the latest firmware revision

  • danjames92danjames92 Members, Plex Pass Posts: 3,117 Plex Pass
    edited March 2016

    @kegobeer-plex said:

    @danjames92 said:

    @kegobeer-plex said:
    @danjames92, do you have a test file with lpcm I can try? I only have a few titles that have lpcm audio, and they all play ok. I'd like to try one and see if I can replicate it on my Shield.

    Sure! If I remember correctly, it's VC-1 and LPCM that have trouble using the app. I only have 1 test file though (don't think it's PCM). I'll upload to dropbox and put a link here.

    Link: https://www.dropbox.com/s/a3p4flwmnpd6o3a/LPCM.mkv?dl=0

    Thanks. I've already duplicated the VC-1 + forced direct problem. Hoping to replicate the LPCM issue. Are you saying that it's a combination of VC-1 and LCPM that's the issue, or just any file with LCPM?

    It's been a while since I tested it but I believe it was any file with LPCM as well transcoded to AC3 / AAC. I will test on the latest app and get back to you.

    Mac Mini (2.7GHz, Late 2012, Windows 10, Kodi DSPlayer) | SATV 16GB | Panasonic TX-P50GT50B | Yamaha RX-V675 | Q Acoustics 2010i (FL, FR, Left S, Right S), Q2000ci Center, Q2070si Sub

     

  • danjames92danjames92 Members, Plex Pass Posts: 3,117 Plex Pass
    edited March 2016

    @kegobeer-plex
    @MovieFan.Plex

    I have just done some further testing with a lot of different files formats. Logs start from 6PM GMT (UK time) todays date (12th).

    Using latest Plex app.
    Only Image formats as subtitle option.
    Refresh rate switching - on.
    Direct Play Auto - Original.
    Hardwired via CAT6.

    All VC-1 content is transcoded so definite bug there.
    LPCM is being transcoded to AAC when it should be passed through.
    ASS subtitles are being burned into the videos. (didn't test others)
    Stuttering occurred on a lot of the files as well.

    I also don't understand why there isn't a Android TV specific subforum. :)

    Mac Mini (2.7GHz, Late 2012, Windows 10, Kodi DSPlayer) | SATV 16GB | Panasonic TX-P50GT50B | Yamaha RX-V675 | Q Acoustics 2010i (FL, FR, Left S, Right S), Q2000ci Center, Q2070si Sub

     

  • kegobeer-plexkegobeer-plex Members, Plex Pass Posts: 5,274 Plex Pass

    @danjames92, I think we talked about how the lack of file information displayed on the Shield makes testing a pain. I wrote a small batch file using MediaInfo that scans all directories and outputs a text file with video and audio codec information. Let me know if you're interested.

    Where are my log files?

    How do I properly name my media files?

    NVIDIA SHIELD SMB/NAS Sharing How-To - / - NVIDIA SHIELD Support Documents

    Plex Server: 1.8.0 running on ThinkServer TS140 w/Server 2012 R2 Essentials
    Primary Plex Player: Shield TV, always the latest beta build, always the latest firmware revision

  • kegobeer-plexkegobeer-plex Members, Plex Pass Posts: 5,274 Plex Pass

    Testing PCM, results from my collection.

    Cars: AVC / PCM
    With LPCM audio track, get occasional blocky video; transcoding done on server. With AC3 5.1 audio track, no video problems; no transcoding.

    Championship Winning Freestyle: MPEG / PCM
    Transcoding done on server

    Monster House: MPEG / PCM and AC3 5.1
    With LPCM audio track, sometimes converts to AC3 and sometimes passes PCM; transcoding happens both times. With AC3 5.1 audio track, no transcoding.

    Ratatouille: AVC / PCM and AC3 5.1
    With LPCM, transcoding. With AC3 5.1, no transcoding.

    I'm just starting to do some VC-1 testing, but that will probably wait until tomorrow. So far I've checked A Christmas Story and Batman Begins. Both transcode, and Batman Begins stops playback fairly quickly with a message about the server not being powerful enough to transcode, then it resumes and pauses every so often like it's buffering. No CPU or memory or network spikes on the server. Might have something to do with the TrueHD and AC3 5.1 audio tracks.

    Where are my log files?

    How do I properly name my media files?

    NVIDIA SHIELD SMB/NAS Sharing How-To - / - NVIDIA SHIELD Support Documents

    Plex Server: 1.8.0 running on ThinkServer TS140 w/Server 2012 R2 Essentials
    Primary Plex Player: Shield TV, always the latest beta build, always the latest firmware revision

  • MovieFan.PlexMovieFan.Plex Members, Plex Pass, Plex Ninja Posts: 15,442 Plex Employee

    Thanks for testing but to be clear, when you say transcoded, so you mean the audio only? Can you also include what the video is doing?

  • danjames92danjames92 Members, Plex Pass Posts: 3,117 Plex Pass
    edited March 2016

    @kegobeer-plex said:
    @danjames92, I think we talked about how the lack of file information displayed on the Shield makes testing a pain. I wrote a small batch file using MediaInfo that scans all directories and outputs a text file with video and audio codec information. Let me know if you're interested.

    Yes we did. I would be interested yes definitel thank you.

    .> @MovieFan.Plex said:

    Thanks for testing but to be clear, when you say transcoded, so you mean the audio only? Can you also include what the video is doing?

    In the sample I tested, a VC-1 file with LPCM, both the video and the audio gets transcoded. I've not seen VC-1 be Direct Played yet. I only tried it the once so will try it again today and see if the result is the same.

    Mac Mini (2.7GHz, Late 2012, Windows 10, Kodi DSPlayer) | SATV 16GB | Panasonic TX-P50GT50B | Yamaha RX-V675 | Q Acoustics 2010i (FL, FR, Left S, Right S), Q2000ci Center, Q2070si Sub

     

  • kegobeer-plexkegobeer-plex Members, Plex Pass Posts: 5,274 Plex Pass

    @MovieFan.Plex said:
    Thanks for testing but to be clear, when you say transcoded, so you mean the audio only? Can you also include what the video is doing?

    Tonight I will get the server logs and verify audio and/or video transcoding.

    Where are my log files?

    How do I properly name my media files?

    NVIDIA SHIELD SMB/NAS Sharing How-To - / - NVIDIA SHIELD Support Documents

    Plex Server: 1.8.0 running on ThinkServer TS140 w/Server 2012 R2 Essentials
    Primary Plex Player: Shield TV, always the latest beta build, always the latest firmware revision

  • kegobeer-plexkegobeer-plex Members, Plex Pass Posts: 5,274 Plex Pass

    @danjames92, I'll zip everything up and send you a PM tonight with the link.

    Where are my log files?

    How do I properly name my media files?

    NVIDIA SHIELD SMB/NAS Sharing How-To - / - NVIDIA SHIELD Support Documents

    Plex Server: 1.8.0 running on ThinkServer TS140 w/Server 2012 R2 Essentials
    Primary Plex Player: Shield TV, always the latest beta build, always the latest firmware revision

  • kegobeer-plexkegobeer-plex Members, Plex Pass Posts: 5,274 Plex Pass
    edited March 2016

    @MovieFan.Plex, here is a zip file containing a file list along with start/stop times and two server logs. Both logs are for the same movie - Cars. Log 2 is with the movie starting with the AC3 soundtrack, and a minute later switching to the PCM track, and Log 3 is with the the movie starting with the PCM soundtrack, and a minute later switching to the AC3 track.

    Shield TV -> hdmi -> Onkyo TX-SR608 -> hdmi -> Sharp LCD (video only)

    Where are my log files?

    How do I properly name my media files?

    NVIDIA SHIELD SMB/NAS Sharing How-To - / - NVIDIA SHIELD Support Documents

    Plex Server: 1.8.0 running on ThinkServer TS140 w/Server 2012 R2 Essentials
    Primary Plex Player: Shield TV, always the latest beta build, always the latest firmware revision

«1345678
Sign In or Register to comment.