Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

"Your connection to the server is not fast enough to stream this video. Check your Network."

2456711

Answers

  • Rowge1Rowge1 Members Posts: 33 ✭✭

    Ok, this seems to be an Apple thread but I'm going to chime in anyway lol. I have the same message/problem with my Windows 7 PMS (Quad core 2.83Ghz CPU, 8GB RAM, 7200rpm HDD) on a Sony Android 4K TV, wireless N network. It pauses every several seconds to catch up and only happens with 4k or 10 bit movie files (in any format/container) all other rez and 8bit files play fine. I have tried the same files (4k, 10bit) on the TVs built-in video player with PMS as the DLNA server, and they play just fine, which would seem like an acceptable work around, but it's really not (I won't bore you with a long explanation). Any suggestions, PMS or Android TV app updates coming to correct this? (Don't say get an Apple)

  • arobe79arobe79 Members, Plex Pass Posts: 225 Plex Pass
    edited April 2016

    Some more testing tonight. When I play files that should be direct play with out issue, H264, m4v, ac3 and all the other settings done using the Apple TV 3 preset on handbrake I notice that my network usage tops out at 54 Mbps and I get the error we have been mentioning along with buffering issues. When I toggle Direct Play to no and only use Direct Stream my Network usage will go as high as 200 Mbps and I have no error or buffering issues. The server shows transcoding and both audio and video are direct stream. This would be a fine solution except I lose chapters and chapter thumbnails. Not a deal breaker but a little disappointing. This testing was done over wifi but as I have mentioned I have had the issues over Ethernet as well.

  • arobe79arobe79 Members, Plex Pass Posts: 225 Plex Pass

    Here is a log file that has three different files that had the issue that has been described. Let me know if any more information is needed.
    Thanks in advance.

  • alexw1982alexw1982 Members, Plex Pass Posts: 17 Plex Pass

    I am having the same issue with the latest plex pass version (0.9.16.4) and the latest tvos and app on a pure Ethernet 1gbit connection. Forcing transcode and setting quality to 4mbit/720p fixed it for now ...

  • pjvpjv Members, Plex Pass Posts: 93 Plex Pass

    Given the total lack of response by Plex devs to lots and lots of different reports of buffering issues on the ATV (here's one thread I participated in), I'm pretty sure that they are all working and testing under relatively pristine networking conditions and are silently marking all these various buffering issues reports as "works for me" in their heads.

    I'm sure that there are plenty of people who don't have any trouble streaming to the ATV. But there are enough reports of poor buffering performance on the ATV under a wide variety of differing network topologies and infrastructures that it is obvious that whatever the streaming architecture is for the ATV - especially for direct play - it is not robust and I can only imagine that is because the developers working on the ATV app are developing and testing under conditions that do work, rather than under a variety of real-world conditions.

    So I repeat my plea to plex:

    Dear Plex, please require at least one of your ATV devs to develop and test with a remote server and downstream bandwidth of 2-4mbps. I'm sure that experience will make the app more usable for everyone.

  • morbergmorberg Members Posts: 144 ✭✭
    edited April 2016

    Yeah, my problems are back.

    If someone from Plex is listening I would be happy to help you debug this. 802.11ac network, no problems streaming video in other apps.

    The wheel keeps spinning on Apple TV (indicating buffering), yet the Activity Monitor on the Mac running PMS doesn't transmit any data.

    Can someone confirm that SimpleX solves these problems? I'd be happy to pay for a working solution.

  • infiniteloop23infiniteloop23 Members Posts: 2

    Today i watched half a movie, went to do something else, saw that my server was out of date (not sure the version) and replaced it with the new one.
    When I started the movie again, i constantly got this message + buffering.
    Went back to an older server (late feb) and it's fine now.
    Been on latest Plex app, tvos version since release, no issues previously.

  • arobe79arobe79 Members, Plex Pass Posts: 225 Plex Pass
    edited April 2016

    What release did you roll back to and how did you roll back if I might ask? Did you have any issues with your roll back?

  • infiniteloop23infiniteloop23 Members Posts: 2

    I did continue to have issues rolling back after all, but not as bad as with the current version.

    Have Plex indicated they are aware if this issue?

  • techguy888techguy888 Members Posts: 64 ✭✭

    I am seeing this error message now as well, though I do not actually have any buffering issues. I only see the message when using the Siri remote to fast forward (whether with the track pad or by voice). The message flashes up on the screen for a couple seconds and then I won't see it again until the next time I fast forward. I never saw this message before this week under the exact same usage and hardware/network configuration. The only thing that would have changed would be a client update for the ATV4. So for me at least, this is just an incorrect error message and not an actual buffering problem as others are seeing.

  • morbergmorberg Members Posts: 144 ✭✭

    @infiniteloop23 said:

    Have Plex indicated they are aware if this issue?

    Not that I've seen.

  • Riverboy1959Riverboy1959 Members Posts: 1 Plex Pass

    OK so I thought it was the new drives in my NAS causing this, but perhaps not. I only see this when I FF with the Siri remote on the ATV4, although it I tell Siri by voice to FF xx minutes it works fine.

  • techguy888techguy888 Members Posts: 64 ✭✭

    @Riverboy1959 said:
    OK so I thought it was the new drives in my NAS causing this, but perhaps not. I only see this when I FF with the Siri remote on the ATV4, although it I tell Siri by voice to FF xx minutes it works fine.

    I see the error message in both instances, odd that Siri fast forwarding works fine for you.

  • arobe79arobe79 Members, Plex Pass Posts: 225 Plex Pass

    Anyone make any progress with this issue?

  • brittas11brittas11 Members, Plex Pass Posts: 1 Plex Pass

    I get this but I thought it was down to my laptop I'm using as a media server. My Plex setup was always an experiment and I keep meaning to buy a server/NAS in future.

    Is there anything I can do to help this issue by playing with settings (lower quality or something) or is it an ATV issues?

  • arobe79arobe79 Members, Plex Pass Posts: 225 Plex Pass

    Brittas11 If all of your files are in an Apple TV format h254, m4v AAC and or AC3 audio and the correct max bit rate and profile both of which I cannot remember right now, then I believe it is an issue with the Plex app since many of us are getting this. Try going into settings on the Apple TV app and turn of direct play, leave direct stream on and test. That fixes it for me.

  • mrCrumbSnatchermrCrumbSnatcher Members, Plex Pass Posts: 5 Plex Pass

    @arobe79 Thank you. This worked for me. Been streaming flawlessly since making the change. FYI for people who may be interested:

    -all of my files are iTunes compatible
    -my setting is not to transcode (original quality).
    -my Mac mini server, with synology NAS, is wireless 'N'. (The NAS is connected to router via Ethernet though).
    -direct play is off
    -direct stream is on
    -All my other devices do not need this change. Just the Apple TV 4. My other devices work as expected

    @arobe79 said:
    Brittas11 If all of your files are in an Apple TV format h254, m4v AAC and or AC3 audio and the correct max bit rate and profile both of which I cannot remember right now, then I believe it is an issue with the Plex app since many of us are getting this. Try going into settings on the Apple TV app and turn of direct play, leave direct stream on and test. That fixes it for me.

  • arobe79arobe79 Members, Plex Pass Posts: 225 Plex Pass

    @mrCrumbSnatcher said:

    @arobe79 Thank you. This worked for me. Been streaming flawlessly since making the change. FYI for people who may be interested:

    -all of my files are iTunes compatible
    -my setting is not to transcode (original quality).
    -my Mac mini server, with synology NAS, is wireless 'N'. (The NAS is connected to router via Ethernet though).
    -direct play is off
    -direct stream is on
    -All my other devices do not need this change. Just the Apple TV 4. My other devices work as expected

    @arobe79 said:
    Brittas11 If all of your files are in an Apple TV format h254, m4v AAC and or AC3 audio and the correct max bit rate and profile both of which I cannot remember right now, then I believe it is an issue with the Plex app since many of us are getting this. Try going into settings on the Apple TV app and turn of direct play, leave direct stream on and test. That fixes it for me.

    Glad it worked. I just want to say It's to bad that we have to do this as we lose out on features such as chapter thumbnails with direct stream. If all are videos are Apple TV ready I don't understand why we have to make the concessions. Our content should direct play. Something is broken.

  • BastardSheepBastardSheep Members, Plex Pass Posts: 267 Plex Pass

    I had been ignoring this thread because I assumed it was just my wifi network (AC1900 WIFI but a fair distance through numerous double-brick walls). I'm starting to wonder otherwise now, after reading this thread more thoroughly.

    Right now I can't go more than 3 days without getting that message. If SD content I can usually (but not always) just pause for a few seconds, then play again and all good. If HD content though I usually need to reboot either the router or ATV4.

    I'll try changing the setting to direct streaming and see how I go. I don't use chapter markers so I won't miss them. See if I can go a week without this message.

  • BastardSheepBastardSheep Members, Plex Pass Posts: 267 Plex Pass

    Turned off Direct Play and left on Direct Streaming. That pause before something starts playing which I had just accepted as being how this app works is completely gone. Starts immediately. Quality indistinguishable. Something's definitely broken with Direct Play (what I thought was meant to be the preferred/lowest bandwidth/least problems way to play things) if Direct Streaming is this much better.

Sign In or Register to comment.