Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

"Your connection to the server is not fast enough to stream this video. Check your Network."

1234568

Answers

  • BastardSheepBastardSheep Posts: 234Members, Plex Pass Plex Pass

    @DanneFrank said:
    @BastardSheep I understand that but I have seen plenty of people suggest posting in the Apple developers forums to help with this and no one from Plex has replied.

    Are you honestly suggesting they don't know about said forums? I'd suggest maybe they're just not dignifying such basic and obvious suggestions with a response. That's how I felt when I saw those suggestions, and I'm not even a dev of any sort. In regards to functions to use, all of those that went alongside the dev forums suggestions were ones the devs had already said they had tried and do nothing but limit the caching further, rather than opening it up.

    @DanneFrank said:
    Also they keep releasing pointless features when they haven't even got the app to work properly.

    So you're now saying you're the be all and end all of what features are useful and have a point and what aren't?

    @DanneFrank said:
    Seems their resources are being used in various other ways instead of getting the apps functionality right.

    You sure know a lot of what's going on behind the scenes if you can make such righteous claims with such authority. Either that, or you need to pull your head in.

  • DanneFrankDanneFrank Posts: 38Members, Plex Pass Plex Pass

    @BastardSheep LOL. Well when there is no response from the devs, one can only assume. So maybe some communication with the people who are paying for their products would be a good idea, that is business 101. Well when a product doesn't work, adding features is redundant when the core product doesn't work as intended. Also the word 'seems' was pretty crucial to that whole sentence. So instead of bashing me for having an opinion when I am an unhappy customer with every right to voice that opinion, maybe you should go about your day good sir :)

  • DanneFrankDanneFrank Posts: 38Members, Plex Pass Plex Pass

    Ok so since I updated my Plex app to 1.7 most of my films now don't play more than 5-10 minutes before getting this message. Some even every 1-2 minutes. Is there any update or anything about this? It's making Plex unusable for me, which is extremely frustrating

  • OnDemand2.0OnDemand2.0 Posts: 61Members, Plex Pass Plex Pass

    Same here. Tired wired and wireless. Previously wireless worked like a charm. Now I have to transcode at 4Mbps/720p in order to play more than a few minutes. Haven't tested it on iOS apps in general but super frustrating.

  • bryanandersonbryananderson Posts: 50Members ✭✭

    I've seen a bunch of people say this problem is due to the native Apple TV player, but also seen several folks saying transcoding solves their problem. I guess I don't get it, wouldn't the native player be used regardless?

  • tsheleytsheley Posts: 148Members, Plex Pass Plex Pass

    What type of router is everyone using? I had this problem all the time when using a Time Capsule. Got rid of it and bought a Nighthawk Router and haven't had the problems since. Been going on 4 months now. Can't be a coincidence.

  • HappyPig0HappyPig0 Posts: 206Members, Plex Pass Plex Pass

    @tsheley same for me too... I was hard wired (router to 3 year old time capsule to ATV4).... got rid, same set up but now through an Airport Extreme (months old)... no problems ever since!

  • OnDemand2.0OnDemand2.0 Posts: 61Members, Plex Pass Plex Pass

    Definitely not the router. Been running off a Synology router for almost a year. Literally just started having this issue 1-2 weeks ago. Prior to that, was streaming 30k bitrate direct play no problem.

  • DanneFrankDanneFrank Posts: 38Members, Plex Pass Plex Pass

    Yea definitely not the router.. this issue only started when I updated to 1.7 and this version seems quite buggy anyways, sluggish and the play bug which has been addressed in a separate thread. Just annoying every time an update is released another problem occurs.

  • yodookayyodookay Posts: 12Members, Plex Pass Plex Pass

    I guess I'll trow my hat into the ring. I am on a Google Fibre connection and getting this error. My Up/Down speed is 985Mbps (just tested). So I can assure you, I have plenty of bandwidth.
    Anyone know how to fix this? (sorry, I haven't read all 8 pages...ugh, forums.)

  • OnDemand2.0OnDemand2.0 Posts: 61Members, Plex Pass Plex Pass

    Yeah. Something is up. Works perfectly on iOS. Gotta be with the AppleTV build.

  • laturiuslaturius Posts: 2Members, Plex Pass Plex Pass
    edited March 16 via Email
    - sorry for this post -
  • ladrosladros Posts: 29Members, Plex Pass Plex Pass

    @bryananderson said:
    I've seen a bunch of people say this problem is due to the native Apple TV player, but also seen several folks saying transcoding solves their problem. I guess I don't get it, wouldn't the native player be used regardless?

    Be warned, I'm making this up, all speculation :)

    The assumed problem with the native player is that it is not buffering sufficiently, presumably there is a maximum size to the buffer, lets say it is 40 mbit max. If you are playing a 20mbit stream then only 2 seconds worth of data can fit into the buffer on the Apple TV, but if you force transcoding down to a lower bit rate, say a 2mbit stream, 20 seconds worth of video could fit in the same buffer. There are lots of assumptions in here around the design, there could also be a maximum duration allowed to buffer and what not that affects the lower bit rate stream buffering, but I think it is useful to illustrate one possible reason.

    There could be other root causes as well, possibly the way the apple TV player makes requests to the server is causing some sort of race condition or lock contention within the server. If this is the case, changing the cadence of communications by changing the bit rate could affect the behavior.

    There could be some sort of issue on the ATV where it just stops asking for packets too.. some minor behavior difference between a plex server and apples (and several other) streaming server implementations. Changing the bit rate has a significant impact on the network pattern and could avoid the problem.


    All that said, this particular error message appears to end up being a catch all for everything from client or server bugs to bad network hardware / cables or even unrealistic end user expectations (trying to shove a 20mbit stream through a 5mbit upload pipe). Till Plex adds some additional intelligence to the client/server such as the ability to do a bandwidth / latency network micro benchmark at time of failure, it is hard to tease apart those various issues without significant manual testing and settings verification by us, the end user.

    One of the plex devs have offered to provide debug builds to anyone seeing this to help debug. All of my systems have started working well enough that I can't reliably create the drop outs like I used too. You can try PM @Stevenson-Price and see if he still needs reproducers to collect logs from.

  • ladrosladros Posts: 29Members, Plex Pass Plex Pass

    On a side note, I'm wondering about the 'buffer too small' being the only contributing factor. When I try to run a high mbit video through a skinny pipe on other clients (iPads) and get this issue, the video often restarts if I give it enough time to buffer, though quickly runs out of data and shows the error again.

    On many of the ATV events I would have a similar but much shorter pause (fraction of a second to just a few seconds of this message), but then the video would make progress for a bit. I could see this be a buffer size vs request latency (which includes both network and server response time).

    The second behavior is once the error shows the ATV never recovers even after letting sit for an hour. I'd have to kick back to the plex menu and resume playing to get things moving again. This doesn't seem to map to just a buffering size issue, seems like either the client or the server get wedged.

    Those of you still reproducing, what symptoms are you seeing?

    Anyone have a packet capture you can share (either SSL decrypted or no SSL enabled)?

  • vdkplexservervdkplexserver Posts: 2Validating, Plex Pass Plex Pass

    I was also getting this error after I upgraded my server to the latest build. I rolled back to my previous build "plexmediaserver_1.1.3.2700-6f64a8d_amd64.deb" and issue was solved. Seems like it is a plex media server issue in the latest builds.

  • vdkplexservervdkplexserver Posts: 2Validating, Plex Pass Plex Pass

    Strike that former comment, still having intermittent "connection not fast enough" even after the rollback. It must be the appletv app causing the issue.

  • OnDemand2.0OnDemand2.0 Posts: 61Members, Plex Pass Plex Pass

    I just updated my Shield to the new 1.4.4 release. Seemed to have fixed it (but yet to stress test).

  • ValdhorValdhor Posts: 471Members, Plex Pass Plex Pass

    @vdkplexserver said:
    It must be the appletv app causing the issue.

    I don't understand how you can say that. I have had it happen on my ATV4 as well as on my i7 iMac chrome web player as well as on my i5 Windows 10 Kodi Plex Plug-in player.

    All of my components connect via a 24 port managed HP Gigabit switch with CAT-6 cabling to a Dual Xeon PMP with 72GB RAM.

    To say this is limited to the ATV4 and the Apple player is folly.

  • ThierryClauThierryClau Posts: 2Members

    I got the very same issue just yesterday after an (auto) update of the Apple tv app. The Apple TV has always been on Wifi. My local network is full 1GB/s and wireless was 802.11n on the Apple tv at the time of "incident", my Plex server running on openmediavault has an outdated yet working version 1.3.4.3285 (no update available from openmediavault packagers).

    Nevertheless, everything was working well until yesterday night, the streaming stopped suddenly with that silly message that my network was too slow (????) LOL, if 1GB on the NAS side and 72MB-150MB on the wifi side are too slow...man, what do you need to run Plex nowadays?

  • ThierryClauThierryClau Posts: 2Members

    Update: I got an update of Plex Server package for Openmediavault to 1.4.4 and I have checked the settings in the Apple TV app, they where reset by default. I wonder if the Plex app is trying to transcode files on a higher rate than needed, I mean my files rarely exceed 2MB/s and default settings for the app is 8MB/s on local network. I always set it to original. I also switched the Wifi on the Apple TV to a 802.11ac @80 MHz connection.

    Let see tonight.

Sign In or Register to comment.