Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Bug - Shield TV Plex app reports server error when using headphones

kegobeer-plexkegobeer-plex Members, Plex Pass Posts: 4,381 Plex Pass

If you plug in headphones into either the gamepad or the remote and try to watch any movie with HD audio tracks while passthrough is set to auto, the app will report a server and app error and the file will not play. When passthrough is set to disabled the files will play perfectly.

It's a pain to have to switch that setting back and forth just because I use headphones occasionally. The app should query the OS and detect headphones connected, and then temporarily disable passthrough until the headphones are disconnected.

Comments

  • KiliаnKiliаn Members, Plex Pass Posts: 4 Plex Pass

    I have exactly the same issue with the latest version (4.26.1.653). It took me a while to correlate the errors with plugging headphones in the remote...

  • kegobeer-plexkegobeer-plex Members, Plex Pass Posts: 4,381 Plex Pass

    @kilian@jknet.org said:
    I have exactly the same issue with the latest version (4.26.1.653). It took me a while to correlate the errors with plugging headphones in the remote...

    I reported this to a dev in another thread, so hopefully it gets attention and a fix.

  • kegobeer-plexkegobeer-plex Members, Plex Pass Posts: 4,381 Plex Pass
    edited July 2016

    @MovieFan.Plex, here's an update on the headphone issue:

    The latest update fixes the crash when using headphones, however there is a small problem with the execution.

    1. Start a movie.
    2. Plug in headphones. The app doesn't crash, and the audio is transcoded.
    3. Unplug headphones. Audio continue to be transcoded. It should revert to using what is supported by the audio receiver/TV/etc.
    4. To revert the audio, you have to stop the movie and restart it.

    When I first tried this, it got stuck in a loop and even exiting the app and restarting it didn't resolve the audio - it was stuck in PCM. I restarted the Shield and that seems to have solved the audio problem, and now the only issue is having to restart the movie in order to get the audio stream back to passthrough.

Sign In or Register to comment.