If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

kodi can't find media servers

DronetedDroneted Posts: 21Members, Plex Pass Plex Pass

I am using PlexBMC app on my Kodi. It signs me in to my Plex account but can't find any media servers. I am running a VPN on my media server and I turned it off but no go. All my other plex apps are working, that is Roku etc. I can get to my media server by browsing but not Plex.

Answers

  • ChasVaChasVa Posts: 1Members

    I'm having a similar problem - I have multiple Plex servers Tower 1 and Tower 2. Even though Tower 1 is set as the Master server in Kodi, it only sees Tower 2. I've tried everything I know, including uninstalling Kodi completely and starting over with a fresh install of Kodi and PlexBMC. Any ideas? (Plex via the web sees both servers just fine.)

  • johniieboyjohniieboy Posts: 2Members, Plex Pass Plex Pass

    Hi, I'm new to Plex (3days)....
    I spun up a Ubuntu v14.04 VM and istalled Plex 1.4.4 all ok. I have mounted CIFS & NFS shares from my NAS and Windows shares all ok. Installed the Win10 client and was able to setup and configure libraries and managed users. All was going OK until the VM crashed (Ubuntu tried to auto update and filled the filesystem!). I have rebuilt a new VM for the Plex server (this time with more virtual disk), rebuilt and configured everything and I can manage browse / play files from my Win10 PC client.

    Now, the problem is the KODI (On RPi3b) add-on wont work anymore - keeps reporting it cant find the server (but it was working previously). I have tried uninstall of the add-ion, reboot, re-install the add-on. But when I select the Plex add-on, it goes straight in to look for the old server - it doesn't ask me to login again. I suspect that OSMC/KODI has some detail stored somewhere (maybe cached) that isn't getting deleted when I un-install the Plex add-on?

    As a side note, I had similar issue with the android client. But i did an uninstall/re-install of the app, and it asked me to login again, and it was all good again.
    Any thoughts out there, on how to ensure a proper uninstall / reset on the KODI / Plex add-on? Thx.

  • johniieboyjohniieboy Posts: 2Members, Plex Pass Plex Pass
    edited April 6

    Ok, so after a few more days of messing about I have discovered the fix for my RPi3/OSMC/KODI/Plex issue.

    I discovered that when you delete an add-on from kodi, it doesn't actually delete all the files associated with the add-on.
    (maybe some of the more experienced users knew that - I didn't, but did suspect it).
    I eventually found that there is a settings file that is left behind. So when I re-installed the Plex add-on, it was immediately picking up the old settings info - which was no good given my Plex server had changed, etc.

    For the benefit of those who may follow:
    1. Un-install the Plex add-on
    2. Use the file manager in kodi (Settings> File Manager)
    3. rename the settings.xml to something else (like: settings.xml.old)
    located here: /home/osmc/.kodi/userdata/addon_data/script.plex/settings.xml
    4. re-install the Plex add-on.
    5. Happy days!

    As an additional note:
    If you have Kodi installed on OpenELEC, the file location is: /profile/addon_data/scriptplex/settings.xml

Sign In or Register to comment.