Hey folks, there is a new Podcast category for forums https://forums.plex.tv/categories/podcasts
If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

VLC for IOS native Plex support: connection failed

Zillion_Zillion_ Posts: 82Members, Plex Pass Plex Pass

Hello all,
I have a specific need for needing VLC for IOS to play Plex-based videos.
I watch a lot of documentaries and like to watch them at 1,5 or 2 x speed, which unfortunately no Plex clients do (PHT can fast-forward at 2x, but without sound unfortunately).
So while I'm very happy with the various Plex clients to watch movies and series, for documentaries, I'm looking for something else, but preferably still using the Plex server... and it needs to support (.SRT) subtitles as well, so DLNA and directly opening the files on the NAS through SMB are out of the question as well (until external subtitle support is enabled there as well, even though I have a limited number of files with internal subtitles).

Now I found out that recent versions of VLC for IOS (I have 278.1) have included some form of native Plex support (Local Network -> Connect to Server -> Plex -> fill in details -> Connect) but I've never been able to make it work. I wasn't able to find any information on this on the net (anything I find is about using DLNA or SMB, but hardly anything about VLC's native Plex support).

When I connect using IP + port + username & password, the VLC client gives an error "Plex login error: check your Plex account in settings". Nothing at all appears in the Plex server debug logs when doing this.
The credentials used are correct (it's my Plex user ID & password; tried both the username and the e-mail address as well). On the same client device (iPad Pro), connecting through the Web Interface or Plex client using the same user Id work fine. I'm on the same local network as my Plex server so no firewall or routing issues here. I'm on the latest PlexPass server release (

When I connect using IP + port but no username & password, and have "List of networks that are allowed without auth" set to "" on the (OSX) Plex server, I get the error "Server connection failed: please check your server address and credentials". But in that case, a few lines appear in the Debug log on the server:

Jun 22, 2016 22:51:25.679 [0x70000021d000] DEBUG - Request: [] GET /library/sections (4 live) GZIP
Jun 22, 2016 22:51:25.680 [0x700000635000] DEBUG - Completed: [] 401 GET /library/sections (4 live) GZIP 1ms 349 bytes

Here's the log entries for another attempts using IP + port but no user or pwd:

Jun 22, 2016 23:03:05.028 [0x700000117000] DEBUG - Request: [] GET /library/sections (2 live) GZIP
Jun 22, 2016 23:03:05.029 [0x7000006b8000] DEBUG - Completed: [] 401 GET /library/sections (2 live) GZIP 0ms 349 bytes

That's really all there is for this client's connections in the logs... all other entries I find relate to connections from my PC (Web interface) and other clients.



  • dash82dash82 Posts: 1Members

    Had the same problem. Basically you need to fill in the ip and the port. Even though the port shows, it doesn't use it. Then you will be able to see the connect button. Hope that helps you.

  • Zillion_Zillion_ Posts: 82Members, Plex Pass Plex Pass
    edited October 2017

    Sorry which port ? As stated above, connecting with IP and port, with or without username and password, don’t work.

  • NicolasppNicolaspp Posts: 6Members ✭✭
    edited March 22

    I’ve managed to make it work:
    Server: type your local or public IP depending on what you want BUT remove the "http://" if it gets there automatically, you just want the numbers, for instance "" if it’s local.
    Port: fill with what you’ve set, mine was 32400 (and check that you’ve actually opened that port on your router).
    Username: when I tried to use the local connection with my normal web browser using http://ip:port the page I landed on asked me if I wanted to sign in but instead of my username it was my email address that was suggested so in VLC I’ve put my email address in the username section, I haven’t tested if it changes anything by using your real username instead.
    Password: your password

    But if your on your local network the DLNA solution is far better than that IMO.

Sign In or Register to comment.