If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Python.app not accepting incoming network connections

pberkloopberkloo Posts: 3Members ✭✭

I have been running PlexConnect and Plex Media Server on my 2009 iMac with Yosemite 10.11 without any issues. I am using an Apple TV 3rd gen and it plays movies and TV shows with no problems. I just installed El Capitan 10.11.5 and my PMS and ATV3 still play movies and TV shows fine. However, now when I start my iMac (with El Capitan), I have 3 of the same pop ups (sometimes just 2) asking "Do you want the application "python.app" to accept incoming network connections?". I found an explanation from another post in October 2015 for the similar problem. I followed the steps here:
I turned off the firewall in Security & Privacy.
I booted into recovery mode (option key at start), in terminal - "csrutil disable"
Reboot into 10.11.5, in terminal "sudo codesign -f -s - /Library/Frameworks/Python.framework/Versions/2.7/Resources/Python.app"
Reboot into recovery mode, in terminal - "csrutil enable".
Reboot into 10.11.5 and all is fine. I can run Plex Media Server and watch on my aTV3. As long as I don't enable my El Capitan firewall, I do not receive the 2 or 3 pop ups "Do you want the application python.app.....
When I do enable the firewall, the pop ups come back, but I still can watch on my aTV3 just fine.
I do see that I have Python 2.7 in my applications which must have been from past years. I read that python is now built in to OSX? I don't know much more than this about how it functions.
Can anyone help me to stop these pop ups? It is greatly appreciated.

Best Answer


  • pberkloopberkloo Posts: 3Members ✭✭

    @wahlman.j Thanks for the correction. I will give it a try and get back to you.

  • pberkloopberkloo Posts: 3Members ✭✭

    Everything continues to work fine with no pop-ups.

  • zonetukezonetuke Posts: 8Members, Plex Pass Plex Pass

    Yes, this worked for me today and I hope it sticks! Running 10.11.6, El Capitan.

Sign In or Register to comment.