If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Transcoding issues with Sony Bravia Opera TV and Plex 1.0

I have a Sony Bravia KDL32W705C with Plex from Opera TV and Plex Media Server version 1.0.2.2413 running on a Ubuntu server. I have some video files that were encoded in MPEG4part2 (DivX or XVid, can't remember) that, as far as I can remember, used to direct play, but now they force video transcode to h264. More details:

  • The TV supports this file format, in fact if I put the files on a USB stick and use the TV media player they play flawlessly. Not all "MPEG4" files play on the Bravia from USB, but these do.
  • I remember that this file direct played before, I updated the server to 1.0 when it was out and it worked, yesterday I noticed that some files were not direct playing anymore. After updating the server to 1.0.2.2413 still no luck.
  • From the logs I see
    Jul 23, 2016 10:04:43.285 [0x7fc3dbfff700] DEBUG - MDE: analyzing media item 870 Jul 23, 2016 10:04:43.285 [0x7fc3dbfff700] DEBUG - MDE: Dreamer (1984): Direct Play is disabled Jul 23, 2016 10:04:43.285 [0x7fc3dbfff700] DEBUG - MDE: Dreamer (1984): media must be transcoded in order to use the hls protocol Jul 23, 2016 10:04:43.286 [0x7fc3dbfff700] DEBUG - MDE: Dreamer (1984): no direct play video profile exists for http/avi/mpeg4 Jul 23, 2016 10:04:43.286 [0x7fc3dbfff700] DEBUG - MDE: Dreamer (1984): no direct play video profile exists for http/avi/mpeg4/ac3 Jul 23, 2016 10:04:43.287 [0x7fc3dbfff700] DEBUG - MDE: Dreamer (1984): no remuxable profile found, so video stream will be transcoded

except "Direct Play" is enabled in the Opera TV Plex app, so it seems it's a matter of profiles. The same goes for files with MPEG4 video and MP3 audio, the TV can play it from USB but Plex transcodes both audio and video. Also on Sony Website there's a comprehensive list of supported codec combinations: http://pdf.crse.com/manuals/14XM070111/EN/codeclist.html

I'll try to downgrade to see if it's a server problem.

Best Answer

Answers

  • zpaolo11xzpaolo11x Posts: 1,229Members, Plex Pass Plex Pass

    Update: downgraded to 0.9 and same issue with movies that play from USB but don't play from Plex with the same log "Direct Play is disabled. media must be transcoded in order to use the hls protocol". Is there a way to completely reset/reinstall an Opera TV app? Couldn't find a way

  • mshoward82mshoward82 Posts: 86Members, Plex Pass Plex Pass

    Sorry I don't have an answer for you. I just wanted to express my sympathy for you. I too have the Sony Bravia with Opera. Really disappointed in the capabilities with the Opera TV. Android base supports so much more. Really wish I knew more about the android system before I bought this version. I didn't realize there were different systems, I use the Plex App all the time on my TV. Just hate how most channels don't play well with Opera. Very annoying.

  • zpaolo11xzpaolo11x Posts: 1,229Members, Plex Pass Plex Pass

    @mshoward82 said:
    Sorry I don't have an answer for you. I just wanted to express my sympathy for you. I too have the Sony Bravia with Opera. Really disappointed in the capabilities with the Opera TV.

    Actually I like the Opera TV Plex app much better than the Android TV. I'm not even sure that there's an issue here since I don't remember exactly a file with MPEG4 encoding that direct play so I might just be mistaken

  • mshoward82mshoward82 Posts: 86Members, Plex Pass Plex Pass

    Really? Seems I have been having a different experience. I think most of my troubles come from the channels. A lot of the channels aren't supported on Opera. Like FOX and CBS and NBC, etc....
    As for the playing my own media I have had no problems. :) Everything works great for me on that end. My server runs an Intel G3258 on a synology system and don't have any performance issues.
    So I guess I am with you and am very happy with it for playing my own content. I haven't seen any transcoding issues, but I also don't watch my server. My server can handle transcoding no problem.

  • zpaolo11xzpaolo11x Posts: 1,229Members, Plex Pass Plex Pass

    @mshoward82 said:
    Really? Seems I have been having a different experience. I think most of my troubles come from the channels.

    That explains the different experience: I never use channels, just my own content :)

    I haven't seen any transcoding issues, but I also don't watch my server. My server can handle transcoding no problem.

    My server can transcode too, I just prefer when it doesn't need to because in that way fast-forwarding is quicker and more responsive, and image quality is a bit better.

    It seems anyway that there are some reporting issues with latest versions of PMS: when playing an h264 file on my iOS plex client it says that the video is direct play, but on the PMS web interface it says it is transcoding. Maybe all the apps are not recognizing the new transcoder correctly

  • zpaolo11xzpaolo11x Posts: 1,229Members, Plex Pass Plex Pass

    Can someone explain if it's normal that a movie that plays correctly from an USB drive connected to my Sony Smart TV doesn't direct-play using the Plex app from Opera TV? What kind of logs should I check?

Sign In or Register to comment.