Hey folks, there is a new Podcast category for forums https://forums.plex.tv/categories/podcasts
If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

How to disable NAT PMP / uPNP

mediamanritmediamanrit Posts: 8Members, Plex Pass Plex Pass

Hi all. This is driving me nuts. My logs are filled with "WARN - NAT: PMP, got an error: Not Supported by gateway.". My router doesn't support uPNP, and I've got manual mappings setup, but it's continuing to try uPNP anyway. Anyone know how to disable it?

Answers

  • BigWheelBigWheel Posts: 10,276Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

    in the remote access setting enter your external port you used in Manually specify public port and check the box to enable it. that tells it you are using manual port forwarding and lets plex.tv know what external port you are using.

    https://support.plex.tv/hc/en-us/articles/200289506-Remote-Access

    Logs > https://support.plex.tv/articles/201869908-log-files/
  • mediamanritmediamanrit Posts: 8Members, Plex Pass Plex Pass

    That's how I have it setup, but the server is still trying to do uPNP based on the logs.

  • razvan.constantinrazvan.constantin Posts: 229Members, Plex Pass Plex Pass
    edited June 2017

    Same problem here.
    Trying to lower SSD writes as much as I can :)
    The URL BigWheel posted states:
    Tip!: If you manually forward a port in your router then you MUST enable this setting or else your Server will continue to try and automatically map the port and will almost certainly fail.
    So I guess this is a bug.

  • gentoo9ballgentoo9ball Posts: 26Members, Plex Pass Plex Pass

    +1 BUMP, same problem here

  • dragonmeldragonmel Posts: 692Members, Plex Pass Plex Pass

    This has NEVER worked on either OS X or linux... manually specifying a port in PMS and a static reservation and port map on my router with upnp turned off and plex still constantly spams the logs with nat PMP not supported on the gateway BS

    I even brought this up with Elan last year and of course it was never addrssed or fixed

  • FoxBJKFoxBJK Posts: 4Members, Plex Pass Plex Pass

    +1 - I reinstalled PMS onto a Linux box last night, and am seeing this error in the log quite a bit:

    WARN - NAT: PMP, got an error: Not Supported by gateway.

    It'd be nice if PMS was smart enough to realize that anyone specifying a port manually doesn't want UPnP attempts being made constantly. This is filling my log with useless errors. Very annoying when trying to debug other problems.

  • dragonmeldragonmel Posts: 692Members, Plex Pass Plex Pass

    been asking for this to be fixed for YEARS....

  • robvanhoorenrobvanhooren Posts: 3Members, Plex Pass Plex Pass

    this is still not fixed, and it's not limited to plex running on fBSD

  • dragonmeldragonmel Posts: 692Members, Plex Pass Plex Pass

    You would think that even a 5 year old would get that if you are specifying a port.. you should not be requesting UPNP....

    But I guess they were fresh out of 5 year olds

  • erikc872erikc872 Posts: 1Validating, Plex Pass Plex Pass

    Bump!! Still an issue - can Plex team make note of this and work on getting it fixed? My Alexa won't work because of this :(

  • FlaxeFlaxe Posts: 9Members ✭✭

    Bump. Plex team, can you please take a look at this and fix it? Issue is on FreeBSD, Linux and OSX (and maybe more).
    If you manually specify a port, Plex should stop doing UPnP requests. It's filling the logs with useless warnings.
    @BigWheel

Sign In or Register to comment.