If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

No AC3 direct play audio on Playstation apps

zdrozdro Posts: 7Members ✭✭

Hi,

I really love the Plex interface and the usability is far better than standard media player on PS.

I just upgraded the server to the latest available for My Cloud EX2. I want to be able to get the AC3 to play as "pass through", because it works well in the default DLNA player, so I changed settings to enable "Allow Direct Play of AC3 Audio". But now I'm wondering if that is only for the web player?

I also changed the player setting to check the AC3 box.

But when I select a video, even though the display says "5.1 DTS", there is no audio. If I switch the player to the AAC track for the file, that works.

I see the same behavior on PS3 and PS4.

Like I said, the PS DLNA client plays with surround sound. Is there something I can do to get it to work with the Plex client?

Thanks very much!

«1

Comments

  • zdrozdro Posts: 7Members ✭✭

    So, am I the only one out there who can't get surround sound on PS? If it works for others, that would be helpful to know.

    I like Plex, but this is kind of a non-starter... :(

  • kay.onekay.one Plex Engineer Vancouver, CanadaPosts: 331Members, Plex Pass, Plex Ninja Plex Ninja

    Have you tried this checkbox?

  • zdrozdro Posts: 7Members ✭✭

    Thank you for the suggestion! Yes I had that checked.

    What I'm seeing now is that when it's checked, there is no audio. But when that option is OFF (i.e. unchecked), it looks like it then transcodes the audio, which increases CPU load significantly.

    Given that straight playback with the PS3's DLNA player plays the sound, shouldn't it work without transcoding in the Plex app too?

    thanks...

  • zdrozdro Posts: 7Members ✭✭

    So, I can live with some CPU usage on the server, because I do get Dolby Digital sound. However, the sound is not going to the correct speakers... All dialog is on the right side!!

  • kay.onekay.one Plex Engineer Vancouver, CanadaPosts: 331Members, Plex Pass, Plex Ninja Plex Ninja

    Do you hear no sound with AC3 checked on PS4 as well?

  • mistercammistercam Posts: 61Members, Plex Pass Plex Pass

    I'm assuming the Plex app on my PS4 updated recently, as all of a sudden I can't hear anything from any of my videos. Reading what was said above, I went into the PS4 settings, and saw that AC3 is checked. The only way I can get sound to come through is to uncheck AC3.

  • kay.onekay.one Plex Engineer Vancouver, CanadaPosts: 331Members, Plex Pass, Plex Ninja Plex Ninja

    @mistercam said:
    I'm assuming the Plex app on my PS4 updated recently, as all of a sudden I can't hear anything from any of my videos. Reading what was said above, I went into the PS4 settings, and saw that AC3 is checked. The only way I can get sound to come through is to uncheck AC3.

    Could you please post the media info XML of the file you had issues with. We did extensive testing of AC3 before releasing and didn't have any issues.

    Also what does your sound system setup look like? Do you have e receiver? Are you using HDMI/optical/pass through etc.

  • mistercammistercam Posts: 61Members, Plex Pass Plex Pass
    edited September 2016

    I have no e-receiver. I'm using HDMI.

    Here is the XML of one of the problematic files

    <Media videoResolution="720" id="45167" duration="5006267" bitrate="4892" width="1278" height="720" aspectRatio="1.78" audioChannels="6" audioCodec="ac3" videoCodec="h264" container="mp4" videoFrameRate="NTSC" optimizedForStreaming="0" has64bitOffsets="0" videoProfile="high">
    <Part accessible="1" exists="1" id="45933" key="/library/parts/45933/1473178082/file.mp4" duration="5006267" file="omitted.mp4" size="3061449778" container="mp4" deepAnalysisVersion="1" has64bitOffsets="0" optimizedForStreaming="0" requiredBandwidths="7817,6432,5362,5050,4928,4928,4928,4928" videoProfile="high">
    <Stream id="60100" streamType="1" default="1" codec="h264" index="0" bitrate="4503" bitDepth="8" cabac="1" chromaSubsampling="4:2:0" codecID="avc1" colorRange="tv" colorSpace="bt709" duration="5006267" frameRate="30.000" frameRateMode="cfr" hasScalingMatrix="0" height="720" level="40" pixelFormat="yuv420p" profile="high" refFrames="4" requiredBandwidths="7433,6048,4978,4665,4544,4544,4544,4544" scanType="progressive" streamIdentifier="1" width="1278"/>
    <Stream id="60101" streamType="2" selected="1" default="1" codec="ac3" index="1" channels="6" bitrate="384" audioChannelLayout="5.1(side)" bitDepth="16" bitrateMode="cbr" codecID="ac-3" dialogNorm="-23" duration="5006240" requiredBandwidths="384,384,384,384,384,384,384,384" samplingRate="48000" streamIdentifier="2"/>
    </Part>
    </Media>
    
  • zdrozdro Posts: 7Members ✭✭
    edited September 2016

    I have the same behavior on both PS3 and PS4. AC3 checked: no sound, AC3 not checked: sound

    PS4 - connected directly to TV via HDMI.
    PS3 - HDMI to TV sound ok with AC3 not checked. Optical to receiver sound off balance with AC3 not checked. No sound to either with AC3 checked.

    <MediaContainer size="1" allowSync="1" identifier="com.plexapp.plugins.library" librarySectionID="1" librarySectionTitle="TV Shows" librarySectionUUID="819fb416-cc59-4201-9fa6-5144d38bda39" mediaTagPrefix="/system/bundle/media/flags/" mediaTagVersion="1473718779"><Video ratingKey="615" key="/library/metadata/615" parentRatingKey="2" grandparentRatingKey="1" guid="com.plexapp.agents.thetvdb://79335/1/1?lang=en" librarySectionID="1" type="episode" title="Pilot" grandparentKey="/library/metadata/1" parentKey="/library/metadata/2" grandparentTitle="Psych" contentRating="TV-PG" summary="a business is born." index="1" parentIndex="1" rating="7.6" viewOffset="812000" viewCount="12" lastViewedAt="1474076672" year="2006" thumb="/library/metadata/615/thumb/1471841885" art="/library/metadata/1/art/1471746299" parentThumb="/library/metadata/2/thumb/1471746298" grandparentThumb="/library/metadata/1/thumb/1471746299" grandparentArt="/library/metadata/1/art/1471746299" grandparentTheme="/library/metadata/1/theme/1471746299" duration="3967647" originallyAvailableAt="2006-07-07" addedAt="1471745907" updatedAt="1471841885" chapterSource="media"><Media videoResolution="480" id="653" duration="3967647" bitrate="1499" width="720" height="480" aspectRatio="1.78" audioChannels="6" audioCodec="ac3" videoCodec="h264" container="mp4" videoFrameRate="24p" optimizedForStreaming="0" has64bitOffsets="0" videoProfile="main"><Part accessible="1" exists="1" id="705" key="/library/parts/705/1471745526/file.m4v" duration="3967647" file="/shares/Video/TV/Show/Season_1/01 - Pilot.m4v" size="743470317" container="mp4" deepAnalysisVersion="1" has64bitOffsets="0" hasChapterTextStream="1" optimizedForStreaming="0" requiredBandwidths="1954,1764,1504,1504,1504,1504,1504,1504" videoProfile="main"><Stream id="1676" streamType="1" default="1" codec="h264" index="0" bitrate="882" anamorphic="1" bitDepth="8" cabac="1" chromaSubsampling="4:2:0" codecID="avc1" colorRange="tv" colorSpace="smpte170m" duration="3967647" frameRate="23.976" frameRateMode="vfr" hasScalingMatrix="0" height="480" level="40" pixelAspectRatio="32:27" pixelFormat="yuv420p" profile="main" refFrames="4" scanType="progressive" streamIdentifier="1" width="720"/><Stream id="1677" streamType="2" selected="1" default="1" codec="ac3" index="1" channels="6" bitrate="448" language="English" languageCode="eng" audioChannelLayout="5.1(side)" bitDepth="16" bitrateMode="cbr" codecID="ac-3" dialogNorm="-27" duration="3967616" samplingRate="48000" streamIdentifier="2"/><Stream id="1678" streamType="2" codec="aac" index="2" channels="2" bitrate="160" language="English" languageCode="eng" bitrateMode="vbr" codecID="40" duration="3967595" profile="lc" samplingRate="48000" streamIdentifier="3"/></Part></Media><Director id="6" tag="Michael"/><Writer id="5" tag="Steve"/><Extras size="0"> </Extras></Video></MediaContainer>

  • kay.onekay.one Plex Engineer Vancouver, CanadaPosts: 331Members, Plex Pass, Plex Ninja Plex Ninja

    Thanks, I'm suspecting the issue is with audioChannels Playstation might not be liking 6 channels of audio. I'll do some more testing and let you know.

  • cameroncameron Posts: 149Members, Plex Pass Plex Pass
    edited September 2016

    This has been a problem for awhile, but glad to see it's getting more attention now that AC-3 is on by default.

  • joshdruckerjoshdrucker Posts: 8Members, Plex Pass Plex Pass

    @cameron said:
    This has been a problem for awhile, but glad to see it's getting more attention now that AC-3 is on by default.

    lol I just replied to that thread because I found it on Google, and then decided to view the main forum and saw this was being discussed elsewhere just this afternoon. So count me in for this issue as well.. PS4 goes straight into TV via HDMI, no receiver. Here is my xml:

    <Media videoResolution="1080" id="21581" duration="10953663" bitrate="9431" width="1920" height="800" aspectRatio="2.35" audioChannels="6" audioCodec="ac3" videoCodec="h264" container="mp4" videoFrameRate="24p" optimizedForStreaming="0" has64bitOffsets="1" videoProfile="high">
    <Part accessible="1" exists="1" id="23191" key="/library/parts/23191/1469391625/file.mp4" duration="10953663" file="/Media/Movies/Movie_Name.mp4" size="12912781725" container="mp4" has64bitOffsets="1" hasChapterTextStream="1" hasChapterVideoStream="1" optimizedForStreaming="0" videoProfile="high">
    <Stream id="47947" streamType="1" default="1" codec="h264" index="0" bitrate="8791" language="English" languageCode="eng" bitDepth="8" cabac="1" chromaSubsampling="4:2:0" codecID="avc1" duration="10953583" frameRate="23.976" frameRateMode="vfr" hasScalingMatrix="0" height="800" level="41" pixelFormat="yuv420p" profile="high" refFrames="5" scanType="progressive" streamIdentifier="1" width="1920"/>
    <Stream id="47948" streamType="2" selected="1" default="1" codec="ac3" index="1" channels="6" bitrate="640" language="English" languageCode="eng" audioChannelLayout="5.1(side)" bitDepth="16" bitrateMode="cbr" codecID="ac-3" dialogNorm="-31" duration="10953663" samplingRate="48000" streamIdentifier="2"/>
    </Part>
    </Media>
    
  • kay.onekay.one Plex Engineer Vancouver, CanadaPosts: 331Members, Plex Pass, Plex Ninja Plex Ninja

    I've been trying to reproduce this locally, but any sample I try seems to play fine with AC3 enabled, could someone that is having issues trying sending me a sample.

  • cameroncameron Posts: 149Members, Plex Pass Plex Pass
    edited September 2016

    @kay.one said:
    I've been trying to reproduce this locally, but any sample I try seems to play fine with AC3 enabled, could someone that is having issues trying sending me a sample.

    Try this: https://mega.nz/#!d0RBiCrL!z2Y_0hP-d_fKHtzU_q_0BIIB4nlPjUrr7hyXZrysVew

    I just tested and this will not play audio while the Dolby Digital selection is checked in Settings.

  • kay.onekay.one Plex Engineer Vancouver, CanadaPosts: 331Members, Plex Pass, Plex Ninja Plex Ninja
    edited September 2016

    Thanks! found the issue, AC3 works for Direct Stream but not direct play, one easy workaround would be to enable AC3 but disable direct play in video settings.

  • mistercammistercam Posts: 61Members, Plex Pass Plex Pass

    I'm sending you a PM with a sample file.

  • cameroncameron Posts: 149Members, Plex Pass Plex Pass

    @kay.one said:
    Thanks! found the issue, AC3 works for Direct Stream but not direct play, one easy workaround would be to enable AC3 but disable direct play in video settings playback.

    Yep, that works!

    I have no need for Direct Play if I can Direct Stream (the end result is the same for me with little overhead), but can this be fixed in a future update for other users?

  • kay.onekay.one Plex Engineer Vancouver, CanadaPosts: 331Members, Plex Pass, Plex Ninja Plex Ninja

    @cameron said:
    but can this be fixed in a future update for other users?

    Absolutely , it will be fixed in our next release.

  • zdrozdro Posts: 7Members ✭✭

    Can't wait! Thanks for looking into this.

    Not sure if this makes any sense, but another video of mine is 4:3 aspect. While testing the audio stuff, I noticed that with AC3 ON, the video was compressed horizontally! i.e. the black sidebars were twice as wide as normal. But with AC3 OFF, the video appeared with the proper aspect.

    Will that potentially be corrected in your fix as well?

    Thanks again.

  • kay.onekay.one Plex Engineer Vancouver, CanadaPosts: 331Members, Plex Pass, Plex Ninja Plex Ninja

    @zdro sorry for the delay, could you post the media xml of the file you are seeing that issue with,

    https://support.plex.tv/hc/en-us/articles/201998867-Investigate-Media-Information-and-Formats

«1
Sign In or Register to comment.