If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

453A behavior issues

69Samael6969Samael69 Posts: 5Members ✭✭

Alright. I had a Plex installation on a Windows Server 2008 NAS and moved it to a QNAP 453A (4G) using these instructions.

https://l.facebook.com/l.php?u=https%3A%2F%2Fsupport.plex.tv%2Fhc%2Fen-us%2Farticles%2F201370363-Move-an-Install-to-Another-System&h=EAQH0GPFG

All seemed to go well, but but I couldn't add any new content. I tried to add a library for Tae Kwon do videos I grabbed from youtube and all I get is "The library has no content yet. Click here to add content to the library.", but the appropriate folder "/share/CACHEDEV1_DATA/More Movies/Small/Taekwondo" has been added to the library (The files are all mp4). Adding new TV shows didn't work either.

Oddly, turning on "Update my library automatically" seems to have fixed the problem in both cases of the TV shows and TKD. I didn't use this on the old server because it was too memory intensive, I would just manually update after adding something, but in the case of the TKD files, they already existed, I just created a new library, but the content didn't come until I changed that setting.

It seems pressing the Update Library button at the top right does not necessarily update the library properly...at least not immediately as I would expect on the Windows server. I changed a bunch of file names, about 80 in two folders, and pressed the button...nothing. I would have expected to see it scan each file. Updating the title itself seemed to help, but perhaps my timing was just good. Even now, the title shows 117 episodes, but there are 118 in the folders. It's an unmatched title, so it should just show everything. I never had problems using the Windows Plex server, but the QNAP one seems a little more flaky. Is it possibly a bug or something I'm doing wrong, or is there an internal service that only adds items every so often, even if the Update Library is run? Does it have difficulties with season sub-folders?

When I add or change things or move things around, I can see that Plex sees it and starts the update process, but it doesn't usually reflect the changes. Manual refresh doesn't help either.

I have a folder "\QNAPHOME\Anime\my_anime\Season 1\" with 26 files

cvt_zx.my_anime.tv.01.divx5.avi
cvt_zx.my_anime.tv.02.divx5.avi
.
.
cvt_zx.my_anime.tv.26.divx5.avi

For some inexplicable reason it found 5-26, but not 1-4. Restarting the NAS seemed to fix this, but upon refreshing the library manually, it lost all of season 2 and now show the TRAKT logo for that season.

On the server side it's running quite high in the memory, but not much of a load average. It has a crapload of stuff running though. Tons of python, mySQL and apache processes running. Seems it may be grinding away at something, but as I say, I've restarted the NAS, so this is only after an hour or so of running.

Mem: 3652904K used, 307220K free, 0K shrd, 565816K buff, 2281412K cached
Load average: 0.27, 0.29, 0.40 (State: S=sleeping R=running, W=waiting)

PID USER STATUS RSS PPID %CPU %MEM COMMAND
4649 admin S 11M 1 0.5 0.2 python
24404 admin S 34M 23096 0.1 0.8 Plex DLNA Serve
3858 admin S 5380 1 0.1 0.1 hal_daemon
23096 admin S 67M 1 0.0 1.7 Plex Media Serv
8846 admin S 49M 8498 0.0 1.2 mysqld
20458 admin S 48M 20088 0.0 1.2 mysqld
24071 admin S 40M 1 0.0 1.0 python
25875 admin S 39M 1 0.0 1.0 python
25622 admin S N 38M 23096 0.0 0.9 Plex Script Hos
25570 admin S 35M 1 0.0 0.9 vm_watcher
25845 admin S 32M 1 0.0 0.8 daemon
25852 admin S 30M 25845 0.0 0.7 daemon
10636 admin S N 20M 1 0.0 0.5 mymediadbserver
12831 admin S 20M 1 0.0 0.5 myupnpmediasvr
12726 admin S N 19M 11619 0.0 0.5 video_gen_thumb
11619 admin S N 18M 1 0.0 0.4 myidbserver
12575 admin S 17M 12573 0.0 0.4 mytranscodesvr
21295 admin S 17M 1 0.0 0.4 dsd
12870 admin S 17M 12868 0.0 0.4 php
13110 admin S 17M 13108 0.0 0.4 php
11142 admin S 16M 11141 0.0 0.4 php-fpm-proxy
21041 admin S 14M 1 0.0 0.3 qnas_console_in
26289 admin S 13M 1 0.0 0.3 python
26292 admin S 13M 26289 0.0 0.3 python
26293 admin S 13M 26289 0.0 0.3 python
26295 admin S 13M 26289 0.0 0.3 python
26296 admin S 13M 26289 0.0 0.3 python
26297 admin S 13M 26289 0.0 0.3 python
982 admin S 11M 10250 0.0 0.3 smbd
11141 admin S 11M 1 0.0 0.2 php-fpm-proxy
9428 admin S 11M 1 0.0 0.2 php-fpm
10250 admin S 11M 1 0.0 0.2 smbd
9429 httpdusr S 10M 9428 0.0 0.2 php-fpm
9430 httpdusr S 10M 9428 0.0 0.2 php-fpm
7922 admin S 9824 1 0.0 0.2 python
25166 admin S 9776 1 0.0 0.2 libvirtd
11143 admin S 9436 11141 0.0 0.2 php-fpm-proxy
26220 httpdusr S 8972 25638 0.0 0.2 httpd
25645 httpdusr S 8004 25638 0.0 0.2 httpd
11828 guest S 7696 1 0.0 0.1 proftpd
11221 admin S < 6468 11213 0.0 0.1 apache_proxy
26383 admin S 6404 1 0.0 0.1 python
25638 admin S 6384 1 0.0 0.1 httpd
12273 admin S 6356 1 0.0 0.1 apache_proxys
9644 admin S 6316 1 0.0 0.1 apache
11219 admin S < 6312 11213 0.0 0.1 apache_proxy
19924 admin S 6204 1 0.0 0.1 porter
21691 admin S 6160 1 0.0 0.1 qboxd
25095 admin S 6100 12529 0.0 0.1 sshd
21684 admin S 6048 1 0.0 0.1 qbox_man
11220 admin S < 5836 11213 0.0 0.1 apache_proxy
10260 admin S 5596 10250 0.0 0.1 smbd
18461 admin S 5540 1 0.0 0.1 bcclient
9609 admin S 5432 1 0.0 0.1 apache-dav
9650 httpdusr S 5288 9644 0.0 0.1 apache
12292 admin S 5288 12273 0.0 0.1 apache_proxys
9651 httpdusr S 5284 9644 0.0 0.1 apache
9652 httpdusr S 5284 9644 0.0 0.1 apache
12288 admin S 5284 12273 0.0 0.1 apache_proxys
Mem: 3654424K used, 305700K free, 0K shrd, 565824K buff, 2281412K cached
Load average: 0.25, 0.29, 0.40 (State: S=sleeping R=running, W=waiting)

Here are the exported PLEX logs.
https://sendspace.com/file/i6xj5t

Any help would be greatly appreciated.

Rob

Comments

  • dane22dane22 Posts: 10,386Members, Plex Pass, Plex Ninja Plex Ninja

    Hi there....

    Well.....Regarding RAM issue, I can only suggest disabling stuff not needed.
    Like DLNA server for Plex, if you don't use it, as well as like MySQL, QNAP's own multimedia stuff etc...

    Regarding your media, I did spot one named:

    Recorded TV/X-Men TAS [HQ] Season 1-5/X-Men TAS [HQ] Season 5 [dummy]/X-Men TAS 503 A Deal With the Devil [dummy].avi

    Above is not following the naming guide, so check out my signature for the relevant naming guide

    And if it still doesn't work, then you need to provide a fresh set of logs, as well as tell me the correct filename of a media not working, so I can narrow it down.

    /T

    I hate bugs - Tommy Lee Jones, MIB
    Join me in developing: epg-dk, str2utf-8, remidx, ExportTools, WebTools
    Support the Samsung Client:Donate
    Guides I use: Media Naming Guide, Local subtitles, Log-Files, QNAP FAQ, The Plex Dance

    NO Support via PM, unless called by me

  • 69Samael6969Samael69 Posts: 5Members ✭✭

    Ironically, that X-Men didn't have any issues, at least on the Windows server (I ported the Plex library over so I didn't have to rematch everything). The issues were related to it just generally not finding things at all. I'd add new stuff, tell it to update and it wouldn't find it. Alternatively, I'd fix file names, it would remove the files from the library, but not add the renamed ones. An example would be say renaming

    cvt_zx.my_anime.tv.01.divx5.avi

    to

    cvt_zx.my_anime.tv.S01E01.divx5.avi

    Changing a whole season like this and I'd be left with the Trakt logo. Restarting the server resolved it.

    As I mentioned previous, I tried to add a library (Home videos library type) for Tae Kwon Do videos I grabbed from youtube to help with patterns and all I got is "The library has no content yet. Click here to add content to the library.", but the appropriate folder "/share/CACHEDEV1_DATA/More Movies/Small/Taekwondo" had been added to the library. The files are all mp4, grabbed from Youtube. Eventually they showed up, but I think it was when I restarted the server.

    Either way, I disabled everything I was sure I could including the Qnap media stuff and that seems to have fixed it. I've also ordered some new memory to bump it to 8G (Memory is cheap these days). The funny thing is that top say the memory is nearly used up, but the QTS system monitor says I have tons free. Is some, or all of QTS running virtual?

Sign In or Register to comment.