Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Plex Media Server Service won't start on nvidia Shield.

LegendOfMaxLegendOfMax Posts: 7Members ✭✭

Hello , I have 2 Plex Media Servers . One is Cloud Sync setup with Google Drive Unlimited and Second one is Nvidia Shield 500GB version with attached external 1TB G Drive .

I was trying to setup the List of IP addresses and networks that are allowed without auth and I saw you have to sign-off from your account in order to take the changes. So I saved the changes and then signed-off from The account on the NVidia Shield TV

Once I did that the Nvidia Shield Plex Server vanished and Cloud sync had no movies any more since the Nvidia Shield is the local plex server that I did the cloud sync from. The Plex Media Server Service was stopped and no matter how many times I tried to enable it would not start.

I tried to :

-Re-enable "Plex Media Server Service " by the Plex app thru nvidia Shield .
- Restart Nvidia Shield
- Clear Cache and data on Plex app and try to sign-in again.
- Disable and enable Plex Media Server.

Any ideas?Do I have to do a fresh reinstall again? Sorry for the long post.

Answers

  • MovieFan.PlexMovieFan.Plex Posts: 15,658Members, Plex Pass, Plex Ninja Plex Employee

    I was trying to setup the List of IP addresses and networks that are allowed without auth and I saw you have to sign-off from your account in order to take the changes.

    Not sure where you saw that, but that isn't correct. You may need to restart PMS.

    Are you sure that the server didn't start? If you were waiting for the wizard to come up, that won't happen since that is only when you do a fresh install. After enabling the server, go to a web browser from a computer on the same network. You should be given the option to claim the server running on the Shield.

  • LegendOfMaxLegendOfMax Posts: 7Members ✭✭

    Thank you for your reply. I have tried Restarting the PMS Service( Which is the Nvidia Shield TV). And the PMS would always show as "STOPPED" , even if I manually tried to enable the service on the nvidia shield It would not budge.

    I would check under my account and would not give me option to claim server. And I had my account signed into the nvidia shield.

  • MovieFan.PlexMovieFan.Plex Posts: 15,658Members, Plex Pass, Plex Ninja Plex Employee
    edited October 2016

    Have you tried restarting the Shield?

    Edit - I did have PMS on the Shield crash on me and a restart of the Shield fixed it.

  • wwwizzarrdrywwwizzarrdry Posts: 220Members, Plex Pass Plex Pass
    edited July 8

    None of that works.

    Same deal trying to set my parents shield up.
    The shield configures itself for running a Plex server just fine, but when you go to settings and "Start" the service, it spins for a minute then just stops and still says, "Stopped".

    We are doing a factory reset at the moment so I'll let you know if it fixes anything.
    I have my own shield and never had this problem . The server started without any issues. The only difference is that I have the original shield and they got the newer version (pro).

    All the other shared ex servers showed up fine for them, as well as the plex server running out their laptop. But the shield just wouldn't start. This is basically a Plex killer for the non-initiated. They would never touch the service again if I wasn't pushing it.

  • MovieFan.PlexMovieFan.Plex Posts: 15,658Members, Plex Pass, Plex Ninja Plex Employee

    You shouldn't need to manually start the server. If this is a new install, when opening the client, you should get the setup wizard for PMS. If you skipped this and trying to start PMS manually, that could be the issue. Also try updating PMS from the play store before setting it up.

  • wwwizzarrdrywwwizzarrdry Posts: 220Members, Plex Pass Plex Pass
    edited July 11

    Yeah, got it working fine on my older Shield model. The one I bought my parents was the new 2017 pro model.

    We just got it working this weekend though. But we had to do the full 2-hour factory reset first. The fast-reset resulted into another setup that wouldn't start the Plex service. Also, grabbed the samba package here: https://play.google.com/store/apps/details?id=com.plexapp.mediaserver.smb

    Maybe that package had something to do with the success. Because we only used the Shield's "update" option for Plex in the Google store prior to that. Perhaps they are different builds? Didn't check before and after version numbers - something to investigate either way.

    *Without the build referenced above, there was no access to the shield's storage from a PC. (The shield settings section, "Storage & Reset" didn't have the option the make the storage available on your network with the standard update option for Plex)

  • MovieFan.PlexMovieFan.Plex Posts: 15,658Members, Plex Pass, Plex Ninja Plex Employee

    Glad you got it working.

    The Shield ships with an older version of PMS, which is why I mentioned updating it first. The version in the store is the same as your link, which is the latest stable release. If the Google account used is in our Shield Beta program, you will get the latest Plex Pass version. You need to check the store from the device itself or pushed from the desktop version. The "update" from Plex Web doesn't work on the Shield.

  • wwwizzarrdrywwwizzarrdry Posts: 220Members, Plex Pass Plex Pass
    edited July 11

    It may or may not be. It could just be how the Google store works, but I watched (from shield TeamViewer) as my dad updated Plex from the shield play store right after a full data reset.

    Then when I went to the play store linked above from his laptop (a second TeamViewer session) it still offered another update. After that it only said "installed" on the play store when he refreshed. So part of me thinks the versions are still different despite what you're saying. Just good to highlight for other users who stumble here.

    We also restarted the Shield after each update (CYA) and the internal shield option to allow remote PC access (under the Sotrage & Reset section) only revealed itself after the remote play store install (done from the laptop).

  • wwwizzarrdrywwwizzarrdry Posts: 220Members, Plex Pass Plex Pass

    Seems like easy steps after re-reading my posts, but if it's confusing to anyone, feel free to comment and ask more questions. Not sure how much of what we did was required because on my model it just worked. But after several attempts with my parents, this is what got it running.

  • wwwizzarrdrywwwizzarrdry Posts: 220Members, Plex Pass Plex Pass

    Too bad Nvidia doesn't have an option to join the beta program right after initial boot or at least first time opening Plex, along with a note from Plex Inc about ensuring you have the latest/correct build to get this working.

    Again, for me it wasn't an issue. Maybe I did things without even knowing it because they are just obvious to me. But for the non-initiated, this definitely did not go that smoothly.

  • MovieFan.PlexMovieFan.Plex Posts: 15,658Members, Plex Pass, Plex Ninja Plex Employee

    Sorry, I wasn't clear about the Beta program. It's Plex's beta program, https://play.google.com/apps/testing/com.plexapp.mediaserver.smb, not the Shield's. They have their own beta but that has nothing to do with Plex.

    Unfortunately, the Shield does not auto-update apps and has to be done manually.

  • wwwizzarrdrywwwizzarrdry Posts: 220Members, Plex Pass Plex Pass
    edited July 11
  • MovieFan.PlexMovieFan.Plex Posts: 15,658Members, Plex Pass, Plex Ninja Plex Employee

    Uh no. The first link is the same regardless. It automatically redirects you if you are in the Plex beta program. You are not in the Beta which is why you only see the stable release. That second link is the sign up. You need to be accepted into the program, but once you are in, you can opt in and out anytime you want. It may take a few minutes for the account to adjust and the stable/plex pass version to be shown. It's automatically handled by Google. You can only run 1 version of PMS.

    Note that if you run the Plex Pass/Beta version, you cannot go back to the stable version until a new update is made or if you uninstall then reinstall PMS and start all over.

  • wwwizzarrdrywwwizzarrdry Posts: 220Members, Plex Pass Plex Pass

    Thanks for the clarification!

  • montanmontan Posts: 1Members, Plex Pass Plex Pass

    My Shield just started having the same problem.
    Worked perfectly until yesterday, but now the server will not start any more.
    Tried rebooting, upgrading, downgrading, etc. with no success.
    Any suggestion before I do a factory reset of the shield?

Sign In or Register to comment.