If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

HiFiBerry Digi+ on RasPlex

booleanboolean Posts: 12Members, Plex Pass Plex Pass

I was wondering if someone managed to get their HiFiBerry Digi+ working on RasPlex. It is working on both OpenELEC 5 and 6 by only adding these lines:

dtoverlay=hifiberry-digi
dtdebug=1

When I add these lines one RasPlex, HiFiBerry is selectable from the setting menu. However, when selected the GUI freezes and a hard reboot is needed to bring it back form the dead.

Best Answer

Answers

  • dawtmaytrikxdawtmaytrikx Posts: 10Members, Plex Pass Plex Pass

    Yep, it works fine with my RasPi 2. The sound will drop for a split second every now and then when I'm using the coax output, but no problems otherwise.
    Have you tried reinstalling RasPlex? That's always fixed any freezes for me.

  • st33lost33lo Posts: 2Members, Plex Pass Plex Pass

    @dawtmaytrikx said:
    Yep, it works fine with my RasPi 2. The sound will drop for a split second every now and then when I'm using the coax output, but no problems otherwise.
    Have you tried reinstalling RasPlex? That's always fixed any freezes for me.

    can you pls explain how you managed to get work.

  • jacriderjacrider Posts: 47Members, Plex Pass Plex Pass

    I have it running from my RasPi2 with the Digi+ to my external DAC. Works just as described above.

    I have been using it for a year or so. Flawless. I started using the Coax connection, but recently changed DAC's and now have the optical connection. I have a HifiBerry Amp+ in another room. Works ok, it struggles with some very high resolution recordings. The Digi+ has never stuttered or anything. I am using hardwire connections for both.

    I would re-install Rasplex. The setup information on the HifiBerry site is helpful.

  • booleanboolean Posts: 12Members, Plex Pass Plex Pass

    @Admin-Schugart said:
    Hello Bolean
    I don't know if you found the answer...
    But initialy a had the same probleme as you.
    The answer is in the config file comment
    You have to comment the line :
    "# dtoverlay=lirc-rpi "
    And it work fine !

    Apparently this was only needed for the Pi3 (which I have) and it worked indeed! I've switched tot an Odroid C2 a while back, but I had to see if your solution actually worked, and it did!

Sign In or Register to comment.