Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Playback of 3D not correct, why is that?

mjewlmjewl Posts: 32Members, Plex Pass Plex Pass

Im trying to play 3D movies with Plex but the output is messed up. Either i get two pictures, side-by-side (see linked image), if i choose auto on my projector. If i choose SBS on the projector the image gets "out-of-sync" as you can see in the included picture.

Side-by-side image: http://imgur.com/pRBz927
Out-of-sync image: http://imgur.com/KsIe5pR

In plex i've tried to change the "playback mode of stereoscopic 3d videos"-setting to both "preferred mode" and "ask me".
On the projector ive tried both "SBS" and "Auto".

the HDMI-cable and receiver are both capable of 3D.

What am i doing wrong? Or am i missing something?

Best Answer

  • mjewlmjewl Posts: 32Members, Plex Pass Plex Pass
    Accepted Answer

    ditched plex for 3d playback and started to use powerdvd instead with iso (mvc). works perfectly and no loss in quality as in encodes.

Answers

  • jmcnaught427jmcnaught427 Posts: 21Members, Plex Pass Plex Pass
    edited December 2016

    I'm having the same issue, running OpenPHT, latest version, on Window 7 with a Core i7 HVEC compatible CPU. Just got a Sony 4K 3D compatible projector (675ES), and played great 3D on the Xbox 1S (even supports Samsung glasses), but no matter what settings I choose in OPHT, I cannot get anything but the side by side images. Manually putting the projector in 3D mode appears to be activating the 2D to 3D capability and giving me 2 images side by side in pseudo 3D.   Yuk.

    Is there a naming requirement (like in the Samsung Plex App) to tell OPHT to play the video in 3D? If so, I've not found it.

    Help!

  • jmcnaught427jmcnaught427 Posts: 21Members, Plex Pass Plex Pass

    OK, figured out an important item in using the new Sony 675ES 4K Projector (Nov 2016) for 3D in OpenPHT.

    If I set the OPHT resolution in settings/system/advanced to 3840x2160p or 4096x2160p and play a 3D movie, the projector refuses to switch to 3D mode via the remote control. IF I change the resolution to 1920x1080i, and play a 3D video, the projector will then allow me to select 3D on the remote (and I must specify SBS), then the 3D works perfectly.

    Is there a way to have OPHT set the display resolution to match the video being played? If so, then I'd expect that the projector would be switched to 4K for the menus and 4K content, then to 1080p for the 3D content, enabling it to be enabled via the remote. Is there a setting in Preferences I'm missing?

    Thanks 

  • jmcnaught427jmcnaught427 Posts: 21Members, Plex Pass Plex Pass

    OK, learning here -- found that if I set the OPHT resolution to 1080, and in settings/playback/advanced video to Adjust display refresh rate to Always, and Pause during refresh rate change to a value of 6, the projector will automatically switch to 1080p for HD content, 1080p for 3D content, and 2160p for 4K content, and the pause feature prevents the movie from playing while the resolution change is occurring on the PC/projector. Now everything works as hoped. Just wish there was a command that OPHT could send to the projector to place it in 3D SBS mode (so I don't have to use the remote).

  • dlanordlanor Posts: 2,215Members, Plex Pass Plex Pass

    One thing that you guys may have missed is that there is a file naming standard defined by Plex Inc for having the PMS server recognize media as being in 3D format and allowing Plex clients which support this usage to send the appropriate HDMI commands that can switch a TV set or projector/receiver into the correct rendering mode.

    Typical usage examples that work with OpenPHT/RasPlex: (used in my own Plex library)

    Avatar (2009).1080p.3D.hsbs.mp4
    Dragon Blade (2015).1080p.3D.htab.mkv
    Skydiving.480p.3D.SBS.wmv
    Skydiving.720p.3D.TAB.wmv

    Here the 'H' in "hsbs" or "htab" stands for "Half", as these formats use normal sized frames to hold both the left and right eye pictures combined but compressed horizontally or vertically (respectively) to half the original size.
    The "tab" and "sbs" formats instead use double-height or double-width sized frames so as to hold both the left and right eye pictures combined without any loss of picture quality.

    There is also a format using sequential frames that alternate between left and right eye pictures, but I am not certain if this mode is supported by OpenPHT.

    Best regards: dlanor

  • mjewlmjewl Posts: 32Members, Plex Pass Plex Pass
    Accepted Answer

    ditched plex for 3d playback and started to use powerdvd instead with iso (mvc). works perfectly and no loss in quality as in encodes.

  • TYRELL CorporationTYRELL Corporation Posts: 9Members

    Did you try this??

    Hi!!
    I did found something wrong here:
    https://support.plex.tv/hc/en-us/articles/203810286-What-media-formats-are-supported-

    "Is 3D playback supported?
    Yes. However, note that there is nothing special that the Plex app can do to instruct the television that a specific video is 3D. You will need to enable the appropriate 3D viewing mode on the television yourself.
    See the Specific Model Differences section for more information."
    WRONG!!!

    If do you have an 3D file you can´t activate the 3D funtion on a Sumsing SmartTV, except :

    • if you put H-SBS like a part of the name of a 3D movie with half-side-by-side format
    • if you put H-TAB like a part of the name of a 3D movie with half-top-and-bottom format

    This means that there is something that the Plex app can do to instruct the television that a specific video is 3D, ONLY is neccessary to ADD "H-SBS" or "H-TAB" to the file name of the 3D movie!!!!
    Without H-SBS or H-TAB inside the name of the movie, I can NOT activate 3D funtion inside Plex application in my Samsung Smart TV H6500. But... with H-SBS or H-TAB inside the movie name.... EUREKA!!!! my smartTV directly activate the 3D funtion only when I press Play opcion inside the Plex app..
    .
    For me this stupid solution did resolve a huge problem with 3D movies!!!!

Sign In or Register to comment.