Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Xbox 360 sync issue regarding videos with mp3

delvirtuddelvirtud Posts: 6Members, Plex Pass Plex Pass

I know there are several of these threads already, but I wanted to attempt to bring more attention to this problem. This has now been going on for 4 months. Completely unacceptable at this point. I have 6 Xbox 360s in my home. Not that my measly $5/month will dent your overall profit margin, but if an effort is not made to remedy this, then there is no use for me to have PlexPass or Plex for that matter. I can use Emby or something else. At least respond acknowledging the issue and let us know whether it will be fixed or NOT.

Best Answer

Answers

  • blundoblundo Posts: 2Members

    I found a solution...

    1) enter Xbox 360
    2) movies & TV
    3) system video player *** make sure to use this and not the Plex app
    4) Plex Media server
    5) movies or TV
    6) select the folder you want and play

    No out of sync issues for me

  • cutcutcutcutcutcut Posts: 19Validating, Plex Pass Plex Pass

    Hmmm, I think that's probably more of a work around then a solution. It would be really great to get some answers around this fault. I too mainly use an xbox 360, and I'm stuck on an old sever version until it's fixed.

  • CurtmanCurtman Posts: 7Members, Plex Pass Plex Pass
    edited November 2016

    @blundo said:
    I found a solution...

    1) enter Xbox 360
    2) movies & TV
    3) system video player *** make sure to use this and not the Plex app
    4) Plex Media server
    5) movies or TV
    6) select the folder you want and play

    No out of sync issues for me

    I've been searching for a solution to this problem too, and I'm hopeful that I can get this to work. Our basement TV for the kids has an Xbox360 for Plex mostly. So many things are unwatchable on it.

    When I open the System Video Player, I see:
    * "Downloaded Videos"
    * "Current Disc" (grayed - no disc is loaded)
    * "Portable Device" (grayed - no usb storage)
    * "Computer" (Not grayed, but says "No computers found."

    Is there some setup I have to do in this app to make it find my Plex Media Server? Or something I have to enable on the server maybe?

    It would be wonderful to make this problem go away.

    ----- EDIT ------

    I found it.. Server settings -> DLNA -> Enable the DLNA server

    This is great that these shows and movies are watchable again. But we lose on-deck, user history, etc?

    Edit2:

    No, this is terrible. Everything that is watched through this DLNA thing appears in my Admin users history, even though it is password protected. :( Now I understand why everything my son watched on his PS3 appeared in my OnDeck, and why when he watched episodes they got marked as watched for me, and why I turned DLNA off.

    Is there source code available for the players? I don't know the first thing about Xbox360 development, but I'm willing to take a crack at it if none of the Plex developers are going to fix this busted player.

  • wichallwichall Posts: 17Members, Plex Pass Plex Pass

    The following command currently works on plex media server on linux - it will remove mp3 from the xbox 360 direct stream profile.
    gawk -i inplace '{gsub(/codec="h264" audioCodec="aac,mp3"/,"codec=\"h264\" audioCodec=\"aac\"");gsub(/codec="h264,mpeg4" audioCodec="aac,ac3,eac3,mp3,pcm"/,"codec=\"h264,mpeg4\" audioCodec=\"aac,ac3,eac3,pcm\"");gsub(/codec="h264" audioCodec="aac,ac3,eac3,mp3,mp2,pcm"/,"codec=\"h264\" audioCodec=\"aac,ac3,eac3,mp2,pcm\"");gsub(/codec="mpeg4,msmpeg4v3,mjpeg" audioCodec="mp3,ac3,eac3,mp2,pcm"/,"codec=\"mpeg4,msmpeg4v3,mjpeg\" audioCodec=\"ac3,eac3,mp2,pcm\"");print}' "/usr/lib/plexmediaserver/Resources/Profiles/Xbox 360 App.xml"; gawk -i inplace '{gsub(/codec="mpeg4" audioCodec="ac3,mp3"/,"codec=\"mpeg4\" audioCodec=\"ac3\"");print}' "/usr/lib/plexmediaserver/Resources/Profiles/Xbox 360.xml"

  • wichallwichall Posts: 17Members, Plex Pass Plex Pass

    The following command currently works on plex media server on linux - it will remove mp3 from the xbox 360 direct stream profile.
    gawk -i inplace '{gsub(/codec="h264" audioCodec="aac,mp3"/,"codec=\"h264\" audioCodec=\"aac\"");gsub(/codec="h264,mpeg4" audioCodec="aac,ac3,eac3,mp3,pcm"/,"codec=\"h264,mpeg4\" audioCodec=\"aac,ac3,eac3,pcm\"");gsub(/codec="h264" audioCodec="aac,ac3,eac3,mp3,mp2,pcm"/,"codec=\"h264\" audioCodec=\"aac,ac3,eac3,mp2,pcm\"");gsub(/codec="mpeg4,msmpeg4v3,mjpeg" audioCodec="mp3,ac3,eac3,mp2,pcm"/,"codec=\"mpeg4,msmpeg4v3,mjpeg\" audioCodec=\"ac3,eac3,mp2,pcm\"");print}' "/usr/lib/plexmediaserver/Resources/Profiles/Xbox 360 App.xml"; gawk -i inplace '{gsub(/codec="mpeg4" audioCodec="ac3,mp3"/,"codec=\"mpeg4\" audioCodec=\"ac3\"");print}' "/usr/lib/plexmediaserver/Resources/Profiles/Xbox 360.xml"

  • CurtmanCurtman Posts: 7Members, Plex Pass Plex Pass
    edited November 2016

    @wichall said:
    The following command currently works on plex media server on linux - it will remove mp3 from the xbox 360 direct stream profile.
    gawk -i inplace '{gsub(/codec="h264" audioCodec="aac,mp3"/,"codec=\"h264\" audioCodec=\"aac\"");gsub(/codec="h264,mpeg4" audioCodec="aac,ac3,eac3,mp3,pcm"/,"codec=\"h264,mpeg4\" audioCodec=\"aac,ac3,eac3,pcm\"");gsub(/codec="h264" audioCodec="aac,ac3,eac3,mp3,mp2,pcm"/,"codec=\"h264\" audioCodec=\"aac,ac3,eac3,mp2,pcm\"");gsub(/codec="mpeg4,msmpeg4v3,mjpeg" audioCodec="mp3,ac3,eac3,mp2,pcm"/,"codec=\"mpeg4,msmpeg4v3,mjpeg\" audioCodec=\"ac3,eac3,mp2,pcm\"");print}' "/usr/lib/plexmediaserver/Resources/Profiles/Xbox 360 App.xml"; gawk -i inplace '{gsub(/codec="mpeg4" audioCodec="ac3,mp3"/,"codec=\"mpeg4\" audioCodec=\"ac3\"");print}' "/usr/lib/plexmediaserver/Resources/Profiles/Xbox 360.xml"

    @wichall said:
    The following command currently works on plex media server on linux - it will remove mp3 from the xbox 360 direct stream profile.
    gawk -i inplace '{gsub(/codec="h264" audioCodec="aac,mp3"/,"codec=\"h264\" audioCodec=\"aac\"");gsub(/codec="h264,mpeg4" audioCodec="aac,ac3,eac3,mp3,pcm"/,"codec=\"h264,mpeg4\" audioCodec=\"aac,ac3,eac3,pcm\"");gsub(/codec="h264" audioCodec="aac,ac3,eac3,mp3,mp2,pcm"/,"codec=\"h264\" audioCodec=\"aac,ac3,eac3,mp2,pcm\"");gsub(/codec="mpeg4,msmpeg4v3,mjpeg" audioCodec="mp3,ac3,eac3,mp2,pcm"/,"codec=\"mpeg4,msmpeg4v3,mjpeg\" audioCodec=\"ac3,eac3,mp2,pcm\"");print}' "/usr/lib/plexmediaserver/Resources/Profiles/Xbox 360 App.xml"; gawk -i inplace '{gsub(/codec="mpeg4" audioCodec="ac3,mp3"/,"codec=\"mpeg4\" audioCodec=\"ac3\"");print}' "/usr/lib/plexmediaserver/Resources/Profiles/Xbox 360.xml"

    Thanks very much for this. I gave it a shot, but had to modify it as mine is installed in /opt.. I will restart and test. Here's some diff's if it helps anyone.

    --- "Xbox 360.xml.BAK"  2016-11-21 16:34:58.566256144 -0600
    +++ "Xbox 360.xml"  2016-11-21 16:37:09.704616689 -0600
    @@ -30,7 +30,7 @@
         <PhotoProfile container="jpeg" />
       </TranscodeTargets>
       <DirectPlayProfiles>
    -    <VideoProfile container="avi" codec="mpeg4" audioCodec="ac3,mp3" />
    +    <VideoProfile container="avi" codec="mpeg4" audioCodec="ac3" />
         <VideoProfile container="avi" codec="h264" audioCodec="aac" />
         <VideoProfile container="mp4,mov" codec="h264,mpeg4" audioCodec="aac,ac3" />
         <VideoProfile container="asf" codec="wmv2,wmv3,vc1" audioCodec="wmav2,wmapro" />
    
    --- "Xbox 360 App.xml.BAK"  2016-11-21 16:35:15.793040780 -0600
    +++ "Xbox 360 App.xml"  2016-11-21 16:37:09.694616814 -0600
    @@ -2,16 +2,16 @@
     <Client name="Xbox 360 App">
       <!-- Author: Plex Inc. -->
       <TranscodeTargets>
    -    <VideoProfile protocol="hls" container="mpegts" codec="h264" audioCodec="aac,mp3" context="streaming" />
    +    <VideoProfile protocol="hls" container="mpegts" codec="h264" audioCodec="aac" context="streaming" />
         <VideoProfile container="mp4" codec="h264" audioCodec="aac,ac3,eac3" context="static" />
         <MusicProfile protocol="hls" container="mpegts" codec="mp3" context="streaming" />
         <PhotoProfile container="jpeg" />
       </TranscodeTargets>
       <DirectPlayProfiles>
    -    <VideoProfile container="mp4,mov" codec="h264,mpeg4" audioCodec="aac,ac3,eac3,mp3,pcm" />
    -    <VideoProfile container="mpegts" codec="h264" audioCodec="aac,ac3,eac3,mp3,mp2,pcm" />
    +    <VideoProfile container="mp4,mov" codec="h264,mpeg4" audioCodec="aac,ac3,eac3,pcm" />
    +    <VideoProfile container="mpegts" codec="h264" audioCodec="aac,ac3,eac3,mp2,pcm" />
         <VideoProfile container="asf" codec="wmv2,wmv3,vc1" audioCodec="wmav2,wmapro,wmavoice" />
    -    <VideoProfile container="avi" codec="mpeg4,msmpeg4v3,mjpeg" audioCodec="mp3,ac3,eac3,mp2,pcm" />
    +    <VideoProfile container="avi" codec="mpeg4,msmpeg4v3,mjpeg" audioCodec="ac3,eac3,mp2,pcm" />
         <MusicProfile container="asf" codec="wmav2,wmapro,wmavoice" />
         <MusicProfile container="mp4" codec="aac" />
         <MusicProfile container="mp3" codec="mp3" />
    

    *** EDIT ***

    This works great! Thank you very much.

  • delvirtuddelvirtud Posts: 6Members, Plex Pass Plex Pass

    Can such a "fix"/"workaround" be applied to the Windows version of the Plex Media Server?

  • delvirtuddelvirtud Posts: 6Members, Plex Pass Plex Pass

    Thanks, Curtman! I have the files from the other thread. I will replace the current files and try it this evening. Cheers!

  • delvirtuddelvirtud Posts: 6Members, Plex Pass Plex Pass

    Worked great. Now I just need to get my friends that share libraries to make the changes too. :\">

  • IvyKillaIvyKilla Posts: 5Members ✭✭

    I hope plex team edit those files and put them in the new update. Many user will be very happy

  • cutcutcutcutcutcut Posts: 19Validating, Plex Pass Plex Pass

    So if I update to the latest server version I will have to go in and edit these xml files? Why can't this just be fixed, it works on the old server (befroe v1.0)?

  • delvirtuddelvirtud Posts: 6Members, Plex Pass Plex Pass

    I am not sure. Has anyone confirmed that the issue exists with the latest PMS update. I will try to confirm this evening. If so, yes, the files will have to be replaced.

  • IvyKillaIvyKilla Posts: 5Members ✭✭

    with todays update i did'nt check if it was ok withonly the update, as soon as i installed the update i repalced the files with the working ones and your trick was still working. by the way thanks alot for that i was looking for months for a fix

Sign In or Register to comment.