If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Playback over secure connection stopped working on Samsung Smart TV

Until recently my Plex App for my Samsung UN55JU6500F was perfectly fine and I was able to stream content without issue.

Starting a few weeks ago however when attempting to play any content, I am now met with the following:

"There seems to be a problem. Playing over a secure connection failed. Disable the use of secure connections or use Direct Streaming or Transcoding."

Connecting to the server and browsing through content works just fine, and any new content or data from the server seems to update normally on the TV (when switching devices, it saves my place on any given video). It is only actually playing things that fails.

I have been forcing secure connection the entire time, and only recently started seeing this error. Plex from all other devices in my household have no issue either. I have also been able to verify through a packet capture (using wireshark) that the TLS connection to the server forms successfully, and is torn down by the app shortly after being established following passing application data.

At this point I have uninstalled/re-installed the app, logged in and out multiple times, bypassed the PIN on login, tried both wired and wireless connections, run every update I have available, and everything else that I have been able to come up with. Nothing has helped and all content is met with this error. To my knowledge nothing has changed with my network or devices or server other than all secure connections are no longer usable.

App version 2.005

Is anyone else experiencing this issue or have found any fix that doesn't make necessary disabling secure connections?

Comments

  • b3m3b3m3 Posts: 74Members, Plex Pass Plex Pass
    edited November 2016

    have a look at this thread:
    https://forums.plex.tv/discussion/243107/connection-difference-when-using-manual-server-entry#latest

    the solution on my side was:

    1. reconfigure PMS to "secure connection preferred"
    2. delete the PMS connection in the Samsung app and manual re-add the PMS by IP.

    And maybe it would be good to update Samsung app to 2.0.0.6

    running plex Transcode Prev 3 on my QNAP TS-251 NAS

  • LamuxLamux Posts: 2Members

    Same problem exists on 2.006 as well.

    Unfortunately, not using secure connections isn't an option.

  • TheMeanCanEHdianTheMeanCanEHdian Posts: 10Members, Plex Pass Plex Pass

    The server Lamux was connecting to was mine. The issue is that his TV was trying to use the Plex Relay feature when it didn't need to (I have noticed this with my android tv and tablet as well).

    On a hunch I followed the below Reddit thread on killing the Plex Relay feature since I don't want it anyways and this did indeed resolve the issue.
    https://www.reddit.com/r/PleX/comments/52ttmt/how_to_disable_plex_relay/

    I hope this thread can be useful to others in the future.

  • kyle.rulekyle.rule Posts: 3Members, Plex Pass Plex Pass

    is there any cure for this, or is it directly related to samsung televisions? i have a ua55mu7000. played fine for maybe 6 weeks then decided it will not play over a secure connection, even though nothing changed that i know of. but i can browse fine.

    is using an unsecure connection ok for the time being as that works fine.

    really enjoying plex at the moment and am keen to get this fixed.

    thanks for any help.

  • OrcaOrca Plex for Samsung Developer Posts: 7,586Members, Plex Pass, Plex Ninja Plex Ninja

    @kyle.rule : You have a different app than the one discussed here.
    The official (Tizen) app's forum is here.

    Have you checked if your answer might be in the User Manual?
    My Samsung environment:

    2010 BD-C5500 Blu-Ray,
    2011 UE46D7000 LED-TV,

    2012 BD-ES6000 Blu-Ray,

    2014 UE55HU8500L UHD LED TV

    If you enjoy this free app, you can buy me a beer by making a Donation

Sign In or Register to comment.