Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Samsung and 5.1 DTS playback

kay.onekay.one Plex Engineer Vancouver, CanadaMembers, Plex Pass, Plex Ninja Posts: 331 Plex Employee

2016 Tizen TVs don't automatically switch from Dolby Digital to DTS when bit streaming the audio track to a receiver.

Using the default settings, TV automatically detects Dolby Digital content and forwards that to the receiver correctly. However, if a DTS movie is played the TV doesn't automatically switch to DTS and just sends the audio as 2 channel PCM to the receiver (Sounds pretty bad).

While a DTS movie is being played, DTS option become available in TV's audio setting menu, and if selected TV starts to correctly forwards the audio to the receiver and receiver shows it as DTS. However, now that the TV is in DTS mode Dolby Digital audio is no longer detected correctly and sent to the receiver as 2 channel PCM.

In summary, by default the TV is in Dolby Digital mode. You can only switch between Dolby Digital and DTS while that particular format audio is being played and while the TV is in one of the modes it plays the other format as 2 channel PCM.

What are going to do to address it:

  • We've filed an issue with Samsung to see if they can either fix the problem or give us the right APIs so we could switch the TV audio mode based on the format that is being played.

  • For the time being, we are adding a new audio setting, "Allow DTS". It will be disabled by default. The setting will force all DTS audio to be transcoded to AAC (Dolby Digital) allowing most users to get 5.1 audio on DTS movies, but it adds another level of conversion which isn't ideal for audio quality but still much better than 2 channel PCM.

If you really want your DTS audio to remain DTS and are ok with changing your TV settings before and after every DTS movie then just check that "Allow DTS" in audio settings and the TV will play DTS audio without trying to transcode it.

Note: The setting is not in 3.0.4 yet, it should be added to the next version.

Update:

I had contacted Samsung to see if they will fix the issue on their side. They got back to us saying that this is pretty much by design. Trust me this makes as much sense to me as it does to you. I'll keep pushing.

Tagged:
«134

Answers

  • mpierce2015mpierce2015 Members Posts: 1

    how do I connect to one of my smart tvs ?

  • deejaymdeejaym Members Posts: 3 ✭✭

    Any news about this issue?

  • kay.onekay.one Plex Engineer Vancouver, CanadaMembers, Plex Pass, Plex Ninja Posts: 331 Plex Employee

    Samsung has approved our release, it should be available later today or tomorrow.

  • cr0w21cr0w21 Members, Plex Pass Posts: 19 Plex Pass

    Works as intended in 3.0.5.. However using DTS on and subtitles (SRT) on, the audio transcodes to aac. Anyone else see this?

  • deejaymdeejaym Members Posts: 3 ✭✭

    Will test it when at home.

  • mail@stefanringel.demail@stefanringel.de Members, Plex Pass Posts: 2 Plex Pass

    @cr0w21 said:
    Works as intended in 3.0.5.. However using DTS on and subtitles (SRT) on, the audio transcodes to aac. Anyone else see this?

    I have the same.

  • hspencerhspencer Members, Plex Pass Posts: 225 Plex Pass

    @cr0w21 said:
    Works as intended in 3.0.5.. However using DTS on and subtitles (SRT) on, the audio transcodes to aac. Anyone else see this?

    This is the current spec so this behaviour is absolutely as intended. DTS will only be passed when Direct Playing a file and the "Allow DTS" tick box is ticked. Selected subtitles cannot be Direct Played (due to Samsung limitations) and so in order to render subtitles the video has to be Direct Streamed over HLS rather than Direct Played over HTTP.

    There is no way to send the DTS audio in HLS (due to Samsung limitations) and so @kay.one is forced to transcode to multichannel AAC to get any audio working at all. AC3 was considered as a transcode target, but ultimately discarded as an option due to greater sound quality degradation.

    So, in short, if you enable subtitles on a file with DTS audio you will get multichannel AAC transcoded at the server and there is nothing currently possible that can be done to amend this situation.

  • deejaymdeejaym Members Posts: 3 ✭✭

    How much quality is loss on the transcoding process?

  • cr0w21cr0w21 Members, Plex Pass Posts: 19 Plex Pass

    @hspencer got it.. makes sense.. Thanks

  • kay.onekay.one Plex Engineer Vancouver, CanadaMembers, Plex Pass, Plex Ninja Posts: 331 Plex Employee
    edited November 2016

    @deejaym said:
    How much quality is loss on the transcoding process?

    It's really up to your ears, quality of your speaker and sound system. If I was gonna make a guess I would say 99% of the people wouldn't be able to tell the difference.

  • hspencerhspencer Members, Plex Pass Posts: 225 Plex Pass

    @deejaym said:
    How much quality is loss on the transcoding process?

    An impossible question to answer, except by saying "some quality" sorry.

    AAC is fundamentally lossy and there's nothing that can be done about that. The DTS source is downmixed (if necessary) to 5.1, then each of those 6 channels gets its own 128Kbit/sec AAC channel ... this is directly equivalent to the same audio quality iTunes Plus gives and exceeds the quality of many commercially purchased digital downloads.

    Worth also mentioning that any DTS source with more than 6 channels will also be transcoded to AAC, irrespective of subtitles being engaged or not. This is due to another Samsung limitation.

    tl;dr - if you want a full-on home theatre audio experience, you're not going to get it without investing in full-on home theatre player hardware, which a Smart TV is not.

  • mail@stefanringel.demail@stefanringel.de Members, Plex Pass Posts: 2 Plex Pass

    This is the current spec so this behaviour is absolutely as intended. DTS will only be passed when Direct Playing a file and the "Allow DTS" tick box is ticked. Selected subtitles cannot be Direct Played (due to Samsung limitations) and so in order to render subtitles the video has to be Direct Streamed over HLS rather than Direct Played over HTTP.

    It's not true. AVPlay have subtitle subport (direct play ... ). You can send it (subtitle) as download to the TV and use AVPlay method setExternalSubtitlePath. And you can direct play with AVPlay . more under https://www.samsungdforum.com/TizenApiGuide/tizen3001/index.html , https://www.samsungdforum.com/TizenGuide/tizen3761/index.html , https://www.samsungdforum.com/TizenGuide/tizen3971/index.html (dash) and https://www.samsungdforum.com/TizenGuide/tizen3451/index.html (AVPlay API .... Content streamed from HTTP/HTTPS Server).

  • Dan GoughDan Gough Members, Plex Pass Posts: 15 Plex Pass
    edited November 2016

    I bought a Samsung KS7000 yesterday and am getting the issues described here. However I'm getting the same issue when going between a Bluray player outputting DTS and a movie on the built in Freeview tuner in DD, so it's an issue with the Samsung software rather than Plex or Tizen apps in general. For example:

    • Bluray player hooked up to TV over HDMI and TV connected to receiver via optical.
    • Set TV to output in DD and live TV and apps work as expected.
    • If I try to play a disc on my Bluray player with a DTS track, it comes out as stereo PCM unless I switch the digital output to DTS in the TV settings.
    • After that any DD content comes out as stereo. I have to go back into the settings and select DD and restart the video / change TV channel for the receiver to get DD again.

    I am gonna raise this with Samsung as it's incredibly annoying, basics like this should just work in 2016!

    Looks like I am going to have to let Plex transcode DTS to DD and configure my Bluray player to output in DD. I'd rather not transcode and would rather have the higher bitrate of DTS-HD but to be honest I probably wouldn't notice the difference anyway and I'd rather do that than have to fiddle each time I play a video!

  • szpak4szpak4 Members Posts: 1

    I have old model of samsung TV es6100. This same situation with changing DTS, DD source in menu of TV:/ so I doubt if samsung fix this problem i ks series. I consider to buy himedia q10pro for playing mkv with HDR, ATMOS DTS-HD etc:]

  • rosendotraviesorosendotravieso Members, Plex Pass Posts: 1 Plex Pass

    @DanGough any Samsung contact/ form to share so i can complain to Samsung as well ..

  • DarkReality360DarkReality360 Members, Plex Pass Posts: 3 Plex Pass

    I am still having issues with this.
    I have a Samsung UE55KS7000, Yamaha HTR-3067 and Plex 3.0.5.
    When I play a video with DTS-HD the option for DTS is still grayed out in the Sound Settings.
    I have ticked DTS(DCA) in the Plex Audio menu.
    The only options I have are PCM, DD and DTS NEO 2:5.
    Am I doing something wrong?

  • MagenofMagenof Members, Plex Pass Posts: 18 Plex Pass

    @DarkReality360 you can't have any subtitles selected either I think

  • wesmanwesman Members, Plex Pass Posts: 601 Plex Pass

    @kay.one Did samsung respond to the orginal issue or mention any update on thier end to fix the underlaying issue?

  • DarkReality360DarkReality360 Members, Plex Pass Posts: 3 Plex Pass

    @Magenof I don't require subtitles for anything I watch, so I dont have them activated.

  • kay.onekay.one Plex Engineer Vancouver, CanadaMembers, Plex Pass, Plex Ninja Posts: 331 Plex Employee

    I updated the original post with Samsung's response. spoiler, it's not good.

«134
Sign In or Register to comment.