If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Apple TV 4 transcoding multi-channel AAC audio to AC3

tproencatproenca Posts: 28Members, Plex Pass Plex Pass

Hi,

I'm not sure why but my Apple TV is always transcoding multi-channel AAC audio to AC3. Even though "Surround Sound" on the Apple TV Audio and Video Preferences is set to "Best Quality Available".

Shouldn't the Plex Player support multi-channel AAC audio on AppleTV natively?

Thank you,
-- Tiago

Best Answer

  • tproencatproenca Posts: 28Members, Plex Pass Plex Pass
    Accepted Answer

    I found a solution.

    Copy ${PLEX HOME}/Resources/Profiles/tvOS.xml to ${your home folder}/Library/Application Support/Plex Media Server/Profiles (Create the directory if it doesn't exist.

    Open tvOS.xml and change the line:

    <UpperBound name="audio.channels" value="2" /> 
    

    to

    <UpperBound name="audio.channels" value="6" />
    

    It is working now without transcoding audio. :)

Answers

  • SVXDAN83SVXDAN83 Posts: 41Members, Plex Pass Plex Pass

    Try changing the setting from "Best Quality Available" to Dobly Digital Surround (or whatever the wording for that setting is). You would THINK that "Best Quality Available" should automatically equate to use multi-channel if it is available, but this is definitely NOT the case. It was this was on the ATV3 as well as ATV4, and incredibly stupid IMO.

    It is worth mentioning this setting could create the same problem in other apps besides Plex. I think HBO NOW was also mixing everything down to AC3 before I changed it. Hope this helps!

  • tproencatproenca Posts: 28Members, Plex Pass Plex Pass
    Accepted Answer

    I found a solution.

    Copy ${PLEX HOME}/Resources/Profiles/tvOS.xml to ${your home folder}/Library/Application Support/Plex Media Server/Profiles (Create the directory if it doesn't exist.

    Open tvOS.xml and change the line:

    <UpperBound name="audio.channels" value="2" /> 
    

    to

    <UpperBound name="audio.channels" value="6" />
    

    It is working now without transcoding audio. :)

  • Mike's Plex Media ServerMike's Plex Media Server Posts: 28Members, Plex Pass Plex Pass

    Maybe I'm dumb, but I cannot find the tvOS.xml file on my Mac. When I go to ~/Library/Application Support/Plex Media Server/ I do not have a Resources directory. Any ideas? Thanks in advance!

  • bsmith120276bsmith120276 Posts: 47Members, Plex Pass Plex Pass

    Its in the Application itself. Go to your Applications folder, right click on the Plex Media Server.app and select "Show Package Contents".

    Server: Late 2014 Mac Mini [2.6 GHz i5, 8GB RAM, 128GB Flash]
    Storage: USB 3.0 Seagate 4TB HDD
    Clients: AppleTV 4, IOS, PMP (Mac & Windows 10), Web
    3 x HDHomeRun (Extend, Connect, Dual)

Sign In or Register to comment.