Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Server not found

jbarker.nejbarker.ne Members, Plex Pass Posts: 2 Plex Pass

Not sure what is going on since the last Xbox one update but every time I try to watch plex on the Xbox it always pops up server not found. But on any other device (apple, android, pc) plex works perfectly fine. Any ideas on how to get plex working again on the Xbox?

«1

Answers

  • jaimon.john@gmail.comjaimon.john@gmail.com Members, Plex Pass Posts: 2 Plex Pass

    I am kinda having the same issue with Plex on my Xbox One. Since the last server update its been flaky and now its broken. I open the app on Xbox and then its just spinning.
    Steps that I took so far:
    Uninstalled app from Xbox One
    Updated Plex app
    Reinstalled Plex App
    Repaired Plex server
    uninstalled Plex Server
    Reinstalled Plex Server
    Still no luck.

    But the Plex app works on my Surface.
    Emailed Plex and they directed me here.

  • The Crab NebulaThe Crab Nebula Members, Plex Pass Posts: 3 Plex Pass

    Same issue here. This is getting very frustrating. I have tried most of the steps listed above to no avail as well. Xbox One is my main player and it has been buggy for as long as I can remember, but this makes it entirely unusable. I would love some support from the Plex team...

  • MoussaMoussa Members, Plex Employee, Plex Pass, Plex Ninja Posts: 1,336 Plex Employee

    If you visit https://plex.tv/api/resources do you see your server connected and with a publicly reachable address? Can you try visiting this address from Edge on your Xbox One? This is the address the XB1 Plex app will try to use to reach your server.

  • The Crab NebulaThe Crab Nebula Members, Plex Pass Posts: 3 Plex Pass

    Although I am not trying to hijack this thread, I would like to take the opportunity to get some support.

    I am seeing my server through the API, and its connection through port 32400 is verified as open though canyouseeme.org.

    The Xbox One is connected to the same LAN as the server, and the server can be connected to locally and remotely by all my other devices.

    I have tried all the steps listed by the user above, and I have also tried every other option I have seen listed in other threads, and the Plex support pages referring to similar issues. Nothing has worked thus far. Any help would be greatly appreciated.

  • MoussaMoussa Members, Plex Employee, Plex Pass, Plex Ninja Posts: 1,336 Plex Employee

    Can you check what the fallback to insecure connections option in the app settings is set to, and try changing it to other values?

  • The Crab NebulaThe Crab Nebula Members, Plex Pass Posts: 3 Plex Pass

    I have tried that a few times, with no change whatsoever. I even went as far as restarting the server and the app with each change of the setting...

  • TebaldTebald Members Posts: 4 ✭✭

    Kind of similar problem here.
    Either the App is spinning and I avee to close it via the controller, or it says that it coulnd not establish a secure connection.
    My Server (ubuntu server 16.04) is not reachable through the internet, so secure connection is not necessary. Secure connnection is disabled in the server settings. In the Xbox-App-Settings fallback to insecure connection is allowed.
    Every other plattform works fine (Web, PS4, Android), very frustrating cause Xbox is my main plattform in the livingroom. Even the native Media Player App on the Xbox works better with the Plex Server than the dedicated Plex App.

  • MoussaMoussa Members, Plex Employee, Plex Pass, Plex Ninja Posts: 1,336 Plex Employee

    Can you enable logging to server in the app settings and post server logs when trying to connect to your server?

  • TebaldTebald Members Posts: 4 ✭✭

    Is this what you're looking for?

    ec 02, 2016 06:45:25.100 [0x7ffbddffd700] DEBUG - Request: [192.168.178.30:49834 (Subnet)] GET / (7 live) GZIP Signed-in Token (Tebald)
    Dec 02, 2016 06:45:25.101 [0x7ffbddffd700] DEBUG - (Capabilities) Platform 'Xbox One' not matched by plugin platform requirements
    Dec 02, 2016 06:45:25.101 [0x7ffbddffd700] DEBUG - It took 0.0 sec to serialize a list with 19 elements.
    Dec 02, 2016 06:45:25.102 [0x7ffbe67fe700] DEBUG - Completed: [192.168.178.30:49834] 200 GET / (7 live) GZIP 2ms 1117 bytes
    Dec 02, 2016 06:45:25.260 [0x7ffbddffd700] WARN - [Plex for Xbox One] skipSignIn is not in PersistentWebStorage
    Dec 02, 2016 06:45:25.719 [0x7ffbddffd700] ERROR - [Plex for Xbox One] ScopedStorageModel received an unknown attribute: currentLanguage. All attributes must be defined in sessionAttrs, syncedAttrs, sessionRelations, or syncedRelations.
    Dec 02, 2016 06:45:25.990 [0x7ffbddffd700] INFO - [Plex for Xbox One] [Connections] Active connection to plex.tv is https://plex.tv
    Dec 02, 2016 06:45:26.164 [0x7ffbccffe700] INFO - [Plex for Xbox One] [Companion] Registering player with plex.tv, clientID="71ckqkdjt2iu"
    Dec 02, 2016 06:45:27.304 [0x7ffbe67fe700] DEBUG - Auth: We found auth token (xxxxxxxxxxxxxxxxxxxx), enabling token-based authentication.
    Dec 02, 2016 06:45:27.304 [0x7ffbe67fe700] DEBUG - Auth: authenticated user 1 as Tebald
    Dec 02, 2016 06:45:27.304 [0x7ffbe67fe700] DEBUG - Auth: Came in with a super-token, authorization succeeded.
    Dec 02, 2016 06:45:27.305 [0x7ffbddffd700] DEBUG - Request: [192.168.178.30:49834 (Subnet)] GET /player/proxy/poll?deviceClass=pc&protocolVersion=1&protocolCapabilities=timeline%2Cplayback%2Cnavigation%2Cmirror%2Cplayqueues (7 live) GZIP Signed-in Token (Tebald)
    Dec 02, 2016 06:45:27.305 [0x7ffbddffd700] DEBUG - [CompanionProxy] registered new player: 71ckqkdjt2iu (192.168.178.30)
    Dec 02, 2016 06:45:27.306 [0x7ffbddffd700] DEBUG - Beginning read from two-way stream.
    Dec 02, 2016 06:45:27.671 [0x7ffbccffe700] INFO - [Plex for Xbox One] [Connections] Active connection to homeserver is http://192.168.178.36:32400
    Dec 02, 2016 06:45:27.772 [0x7ffbccffe700] INFO - [Plex for Xbox One] [Primary Server] homeserver is now the primary server
    Dec 02, 2016 06:45:27.879 [0x7ffbccffe700] INFO - [Plex for Xbox One] [Connections] Active connection to plex.tv is https://plex.tv
    Dec 02, 2016 06:45:27.931 [0x7ffbccffe700] INFO - [Plex for Xbox One] [Connections] Active connection to plex.tv is https://plex.tv
    Dec 02, 2016 06:45:28.086 [0x7ffbccffe700] INFO - [Plex for Xbox One] [Connections] Active connection to plex.tv is https://plex.tv
    Dec 02, 2016 06:45:28.248 [0x7ffbddffd700] INFO - [Plex for Xbox One] [Companion] Found proxy homeserver
    Dec 02, 2016 06:45:28.302 [0x7ffbccffe700] INFO - [Plex for Xbox One] [Companion] Opening long poll to homeserver at http://192.168.178.36:32400/
    Dec 02, 2016 06:45:28.356 [0x7ffbddffd700] INFO - [Plex for Xbox One] [Companion] Registered player with plex.tv, clientID="71ckqkdjt2iu"
    Dec 02, 2016 06:45:32.289 [0x7ffbddffd700] INFO - [Plex for Xbox One] [Companion] Poll connection established successfully

  • MoussaMoussa Members, Plex Employee, Plex Pass, Plex Ninja Posts: 1,336 Plex Employee

    Are there more logs? Also is your system language set to something other than English? Could you try quitting the app, switching it to English and launching it again?

  • TebaldTebald Members Posts: 4 ✭✭

    Since I'm from Germany, systemlanguage is of course german.
    I switched it to english and now it works without the warning and without the note that voice commands are only available in english.
    But this is not what I'm looking for. Now i get english keyboard layout and english language in games. Think I can live with that, but the PS4 for example runs also in german and there aere no problems whatsoever on that plattform. So I guess the problem lies within the Xbox One-App?
    And yes there are more logs, plenty of them. wich one is needed.

  • stresspuppystresspuppy Members Posts: 1

    I had a similar problem with my xbox one, log out of your plex app on the xbox one and link ito again with your plex account. That is how I solved my problem.

  • MoussaMoussa Members, Plex Employee, Plex Pass, Plex Ninja Posts: 1,336 Plex Employee

    @Tebald Just trying to rule out any potential issues. Could you post your complete Plex Media Server.log

  • Peeta83Peeta83 Members Posts: 6 Plex Pass

    hi there. same problem here for month. every time when i start plex on xbox there is the unsecurley error message. and then it still not found my server, which will works fine on all other plattforms, like android tablet, iphone and ps4.

    sometimes it helped, to reboot my router but this cant be the solution, everytime to reboot my complete home network.

  • Peeta83Peeta83 Members Posts: 6 Plex Pass

    hmm thats nice. i am still paying for plex pass but no support here for payed members`?

  • obiwanseanobiwansean Members Posts: 6 ✭✭

    I have just recently, last night, started getting this same error. I noticed that it started after I updated my server to Version 1.3.2.3112 . It worked completely fine without any of the "fixes" before hand. I have since tried every fix that I can find both present and past fixes. Short of uninstalling my server and reinstalling version 1.2.7.2987-1bef33a. I still cannot get my Xbox one to connect. I can access my server remotely without any issues.

  • obiwanseanobiwansean Members Posts: 6 ✭✭

    I just tried logging into my server through Edge on my Xbox one and it connects with an warning of limited connection (not directly connected to the server)

  • obiwanseanobiwansean Members Posts: 6 ✭✭
    edited December 2016

    @Moussa I visited https://plex.tv/api/resources and following is the results.
    MediaContainer size="3">
    Device name="Cerberus-Home PC" product="Plex Media Server" productVersion="1.3.2.3112-1751929" platform="Windows" platformVersion="10.0 (Build 14393)" device="PC" clientIdentifier="3130df897e11d606ca1b68b6c8254d9ed3f0e76a" createdAt="1445381113" lastSeenAt="1481576976" provides="server" owned="1" publicAddress="75.162.65.58" httpsRequired="0" synced="0" relay="1" publicAddressMatches="1" presence="1">

    Device name="Plex Web (Chrome)" product="Plex Web" productVersion="2.12.3" platform="Chrome" platformVersion="54.0" device="Windows" clientIdentifier="a9lrw3if1l6usor" createdAt="1447727504" lastSeenAt="1481597982" provides="player" owned="1" publicAddress="75.162.65.58" publicAddressMatches="1" presence="0">

    /Device>
    Device name="Plex for Vizio (Vizio MTK)" product="Plex TV" productVersion="2.12.1" platform="Opera" platformVersion="0" device="Vizio (Vizio MTK)" clientIdentifier="m60km4dyh1h" createdAt="1465621189" lastSeenAt="1481503187" provides="player" owned="1" publicAddress="75.162.65.58" publicAddressMatches="1" presence="0">

    /Device>
    /MediaContainer>

  • MoussaMoussa Members, Plex Employee, Plex Pass, Plex Ninja Posts: 1,336 Plex Employee

    @Peeta83 It sounds like a home network issue. If you look at https://plex.tv/api/resources you should see the IP address of your server. It sounds like your Xbox One is having trouble reaching that IP address.

    @obiwansean The Xbox One app does not have relay support, so if you cannot connect directly to the server you won't be able to connect at all. The limited connection warning means your Xbox One cannot connect to your server directly for some reason. I don't know your network setup but is the Xbox One and router on the same subnet?

  • obiwanseanobiwansean Members Posts: 6 ✭✭
    edited December 2016

    @Moussa They should be. I have a router in bridge mode connected to my Gateway. Both my server and the Xbox are connected to the Router. As I said, I have never had an issue until I updated my server to the latest update. How do I check if they are on the same subnet?

    My server is running on wifi, and the Xbox is hard-lined. All other devices connect to the server no problems.

«1
Sign In or Register to comment.