Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Direct Connection not working on LAN

ZavoqZavoq Posts: 15 Plex Pass

I have Plex Media Server running on a Window 10 box. For some reason when I try to connect from my iPhone, while connected to the same network that the Server is connected to, I get an error saying "Direction Connection Unavailable." Strangely, It will connect via indirectly via relay, and remotely when on an external network. Just can't get the Direct connect working. Any ideas?

Here are some details in case they help:

Windows Version: 10 Home 64bit
Plex Server Version: 1.2.7.2987-1bef33a
Plex Player version: iOS V4.5
Router: Pace PLC 5286ac

Best Answer

Answers

  • jackmeatjackmeat Posts: 53 ✭✭

    @OttoKerner whatever that links is, since i was curious to read it, says:
    Permission Problem

    You don't have permission to do that.

  • OttoKernerOttoKerner Posts: 21,157 Plex Ninja

    Oh, sorry, this was a Plex Pass-only forum.

    Copy of this post follows:

    3 potential reasons:

    1) 'client isolation' is activated on your router (on some router called differently). It prevents direct communications between the wired and the wireless part of the network
    2) 'DNS rebinding protection' is active in your router. create an exemption for subdomains of *.plex.direct https://support.plex.tv/hc/en-us/articles/206225077-How-to-Use-Secure-Server-Connections
    3) unreliable resolution of host names on the .direct TLD. You may try to switch DNS servers from those of your ISP to Google's public DNS servers (8.8.8.8 + 8.8.4.4). It is a setting in your router.

    If you can't find no solution with any of these 3 options above, you may need to disable 'Secure Connections'.
    1) in the client under Settings - Web - General - 'Allow Fallback to Insecure Connections'
    2) on the server Settings - Server - Network - 'Secure connections' (server restart required)

  • ZavoqZavoq Posts: 15 Plex Pass

    Thanks for the response Otto,

    It doesn't seem as if those solutions worked. I looked at my router (which is the Pace PLC 5386a that is supplied with Uverse), here is what I found:

    1. That router does not seem to have a way to enable (or disable) AP isolation. Also, I can access items the NAS drives that are wired from the Wireless devices, which tells me that AP Isolation is probably not active.

    2. DNS Rebinding Protection does not seem to be a feature of this router. If it is, there seems to be no way to add exceptions.

    3. I can't find a way to change the DNS on this router.

    All that said, before I set off to purchase a new router (with less restrictions) I decided it would be prudent to test it on other devices. Here is what I found:

    When I connect from my Windows Laptop, A MacBook Pro and even my iPad, the connection seems to work. Under the server it says "nearby" which I assume means that is directly connected. The only device that seems to be effected is the iPhone. Looks like it is something with that device. What do you think? Any other ideas?

  • OttoKernerOttoKerner Posts: 21,157 Plex Ninja

    @greg.others@gmail.com said:
    The only device that seems to be effected is the iPhone. Looks like it is something with that device.

    And your iPhone is indeed logged in to your home WiFi and not still on mobile data?

  • ZavoqZavoq Posts: 15 Plex Pass

    @OttoKerner said:

    And your iPhone is indeed logged in to your home WiFi and not still on mobile data?

    Yes. And if I switch to LTE, it connects to the server Remotely as it should.

  • ZavoqZavoq Posts: 15 Plex Pass

    @greg.others@gmail.com said:

    @OttoKerner said:

    And your iPhone is indeed logged in to your home WiFi and not still on mobile data?

    Yes. And if I switch to LTE, it connects to the server Remotely as it should.

    Also, just tested it on my Wife's iPhone 6 and it works. Seems to be only my iPhone 6s that is having the issue. Uninstall/Reinstall/Reboot had no effect.

  • OttoKernerOttoKerner Posts: 21,157 Plex Ninja

    If you word it that way, I think it is safe to conclude that this is an iOS issue.
    I have no direct experience with the iOS app.

    Let me move this thread into the iOS subforum for you.

  • ZavoqZavoq Posts: 15 Plex Pass

    @OttoKerner said:
    If you word it that way, I think it is safe to conclude that this is an iOS issue.
    I have no direct experience with the iOS app.

    Let me move this thread into the iOS subforum for you.

    It now seems that way to me as well. Thanks for the help Otto!

  • ZavoqZavoq Posts: 15 Plex Pass

    I'm still searching for an answer to this. Anyone have any ideas?

  • Running into the same problem here, difference is I am using the Plex Android client. No way to connect direct, same subnet, same wifi router, tried manual connections, other ports, windows firewall off/on, etc. no way. connects nicely indirect though. Sucks big time.

  • brisimmons105brisimmons105 Posts: 42 Plex Pass
    edited March 19

    Any resolution to this? I'm starting to think this is due to the uverse 5268ac router...

  • ZavoqZavoq Posts: 15 Plex Pass

    Still no resolution to this issue. I gave up for a while but I am now back at it and perplexed as ever.

  • OttoKernerOttoKerner Posts: 21,157 Plex Ninja

    Have you tried to disable 'Secure Connections'? (Restart of server and all clients is required after changing this preference)

  • ZavoqZavoq Posts: 15 Plex Pass
    edited May 19

    @OttoKerner said:
    Have you tried to disable 'Secure Connections'? (Restart of server and all clients is required after changing this preference)

    I just tried this and I think there is a clue in what happened. With "Secure Connections" in the Plex "Network" settings set to "Disabled," the affected iPhone 6s (the one that can not make Direct Connections) will not connect at all. It shows the server as Offline. Meanwhile, the iPhone 6 (the one that CAN make Direct connections) is still able to make a direct connection.

    When I reset the "Secure Connections" to "Preferred", the 6s can once again make "Indirect" connections.

  • OttoKernerOttoKerner Posts: 21,157 Plex Ninja

    It may be, that 'Indirect/Relay' connections must always be 'secured'.
    I am still awaiting confirmation on that.

    But if this hunch is true:
    I'd look on the iPhone which doesn't work directly, for software which inserts itself into the network stack, or at least manipulates the network preferences.
    Like VPN, or TOR, or Proxy software, or AntiVirus, or AdBlocker...

  • ZavoqZavoq Posts: 15 Plex Pass

    There must be something different on this specific iPhone, I just can't for the life of me figure out what it is. No VPN setup, no ad blockers, antivirus or the like.

    The reason I gave up on this in the past is that I realized that the only use case affected was if I was within my local network, trying to stream via one specific device. Even then, indirect connection works, given the screen size on the phone, honestly there was no noticeable impact on image quality. It is more a curiosity that anything. For this reason, it's probably best if I stop worrying about it again.

    Thanks for the help. If I ever figure it out, I'll post it here.

  • OttoKernerOttoKerner Posts: 21,157 Plex Ninja
    Accepted Answer
  • ZavoqZavoq Posts: 15 Plex Pass

    That app update solved the issue! Thanks Otto.

Sign In or Register to comment.