Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

green artifact during streaming [x265 10bit] [AAC 5.1] [MKV]

fawzi@breidi.comfawzi@breidi.com Members, Plex Pass Posts: 9 Plex Pass
edited December 2016 in NVIDIA SHIELD

If I open the file from the file manager I can play it normally using mx player. But it wont stream without having green artifact and stuttering.

I tried to disable direct play and all other options. I also tried optimizing and syncing (converting to different format) in hopes to make it work but always the same result. Video plays with audio but badly stutters with green artifact.

Devices tried: S7, ipad air 2, PC (all same results)

Below is file details. Is there a way to file those files?


Source file MediaInfo

Complete name
Format : Matroska
Format version : Version 4 / Version 2
File size : 196 MiB
Duration : 22mn 36s
Overall bit rate : 1 209 Kbps
Encoded date : UTC 2016-02-29 04:43:35
Writing application : mkvmerge v8.4.0 ('A better way to fly') 64bit
Writing library : libebml v1.3.1 + libmatroska v1.4.2
DURATION : 00:22:31.976000000
NUMBER_OF_FRAMES : 800
NUMBER_OF_BYTES : 2605348
_STATISTICS_WRITING_APP : mkvmerge v8.4.0 ('A better way to fly') 64bit
_STATISTICS_WRITING_DATE_UTC : 2016-02-29 04:43:35
_STATISTICS_TAGS : BPS DURATION NUMBER_OF_FRAMES NUMBER_OF_BYTES

Video
ID : 1
Format : HEVC
Format/Info : High Efficiency Video Coding
Format profile : Main 10@L4@Main
Codec ID : V_MPEGH/ISO/HEVC
Duration : 22mn 36s
Width : 1 440 pixels
Height : 1 080 pixels
Display aspect ratio : 4:3
Frame rate mode : Constant
Frame rate : 23.976 fps
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 10 bits
Writing library : x265 1.7+497-975352b2c022:[Windows][GCC 5.2.0][64 bit] 10bit
Encoding settings : wpp / ctu=64 / min-cu-size=8 / max-tu-size=32 / tu-intra-depth=1 / tu-inter-depth=1 / me=1 / subme=2 / merange=57 / no-rect / no-amp / max-merge=2 / temporal-mvp / no-early-skip / rdpenalty=0 / no-tskip / no-tskip-fast / strong-intra-smoothing / no-lossless / no-cu-lossless / no-constrained-intra / no-fast-intra / open-gop / no-temporal-layers / interlace=0 / keyint=250 / min-keyint=23 / scenecut=40 / rc-lookahead=20 / lookahead-slices=0 / bframes=4 / bframe-bias=0 / b-adapt=2 / ref=3 / limit-refs=0 / weightp / no-weightb / aq-mode=1 / qg-size=32 / aq-strength=1.00 / cbqpoffs=0 / crqpoffs=0 / rd=3 / psy-rd=0.30 / rdoq-level=0 / psy-rdoq=0.00 / signhide / deblock / sao / no-sao-non-deblock / b-pyramid / cutree / rc=2 / pass / bitrate=992 / qcomp=0.60 / qpmin=0 / qpmax=51 / qpstep=4 / cplxblur=20.0 / qblur=0.5 / ipratio=1.40 / pbratio=1.30
Default : Yes
Forced : No

Audio
ID : 2
Format : AAC
Format/Info : Advanced Audio Codec
Format profile : HE-AAC / LC
Codec ID : A_AAC
Duration : 22mn 36s
Channel(s) : 6 channels
Channel positions : Front: L C R, Side: L R, LFE
Sampling rate : 48.0 KHz / 24.0 KHz
Compression mode : Lossy
Delay relative to video : 40ms
Language : English
Default : Yes
Forced : No

Text
ID : 3
Format : PGS
Muxing mode : zlib
Codec ID : S_HDMV/PGS
Codec ID/Info : Picture based subtitle format used on BDs/HD-DVDs
Language : English
Default : No
Forced : No

Best Answer

«1

Answers

  • fawzi@breidi.comfawzi@breidi.com Members, Plex Pass Posts: 9 Plex Pass

    thank you sir. keep up the good work!

  • TwistedEndzTwistedEndz Members, Plex Pass Posts: 231 Plex Pass

    @MovieFan.Plex said:
    There is a bug in the current PMS release on the Shield so that when transcoding 10-bit video (either H265 or H264) you get those green artifacts. We are aware of the issue and hope to have a fix in a future PMS update.

    there is also a bug where in "photo" you can only view Thumbnail you cannot see any photo's you click on it's stays black with like a camera icon on it...

  • MovieFan.PlexMovieFan.Plex Members, Plex Pass, Plex Ninja Posts: 15,475 Plex Employee

    @TwistedEndz said:

    @MovieFan.Plex said:
    There is a bug in the current PMS release on the Shield so that when transcoding 10-bit video (either H265 or H264) you get those green artifacts. We are aware of the issue and hope to have a fix in a future PMS update.

    there is also a bug where in "photo" you can only view Thumbnail you cannot see any photo's you click on it's stays black with like a camera icon on it...

    I am not aware of this issue. Is there a thread about this?

  • TwistedEndzTwistedEndz Members, Plex Pass Posts: 231 Plex Pass
    edited December 2016

    @MovieFan.Plex said:

    @TwistedEndz said:

    @MovieFan.Plex said:
    There is a bug in the current PMS release on the Shield so that when transcoding 10-bit video (either H265 or H264) you get those green artifacts. We are aware of the issue and hope to have a fix in a future PMS update.

    there is also a bug where in "photo" you can only view Thumbnail you cannot see any photo's you click on it's stays black with like a camera icon on it...

    I am not aware of this issue. Is there a thread about this?

    i haven't seen a thread about it ..
    here is what the pictures looks like

    and this is what it does when we click on it

  • MovieFan.PlexMovieFan.Plex Members, Plex Pass, Plex Ninja Posts: 15,475 Plex Employee

    Can you start a new thread with more details?

    Is this on the Shield PMS? What version.
    Does it work on other clients?
    Provide the log from the client app. https://support.plex.tv/hc/en-us/articles/201573117-Android-and-GoogleTV-Logs

  • TwistedEndzTwistedEndz Members, Plex Pass Posts: 231 Plex Pass

    @MovieFan.Plex said:
    Can you start a new thread with more details?

    Is this on the Shield PMS? What version.
    Does it work on other clients?
    Provide the log from the client app. https://support.plex.tv/hc/en-us/articles/201573117-Android-and-GoogleTV-Logs

    it's done

  • jonrstoreyjonrstorey Members, Plex Pass Posts: 9 Plex Pass

    I know you're aware of this plex but words like 'hope to' and 'future' seem to be kicking it into the long grass! Plex website is full of promises to play 4k hevc files, mentions transcoding if incompatible, but neglects to highlight this issue with 10 bit files not playing and it leaves customers feeling conned

  • KarlDagKarlDag Members, Plex Pass Posts: 1,675 Plex Pass
    edited December 2016

    @MovieFan.Plex said:
    There is a bug in the current PMS release on the Shield so that when transcoding 10-bit video (either H265 or H264) you get those green artifacts. We are aware of the issue and hope to have a fix in a future PMS update.

    It's nice that acknowledge it, but we were told you (Plex) were aware and that a fix would be done months ago... And that's not on Nvidia's shoulders like external storage apparently is.

  • Vilhelm.83Vilhelm.83 Members, Plex Pass Posts: 12 Plex Pass

    Month later. Still running into this issue. Has there been any steps taken to fix it? When can we expect a new release with the issue addressed?

  • MovieFan.PlexMovieFan.Plex Members, Plex Pass, Plex Ninja Posts: 15,475 Plex Employee

    Sorry guys, no news. We are still looking into the issue.

  • KarlDagKarlDag Members, Plex Pass Posts: 1,675 Plex Pass

    @MovieFan.Plex said:
    Sorry guys, no news. We are still looking into the issue.

    As in... Don't know what the issue is yet?

  • MovieFan.PlexMovieFan.Plex Members, Plex Pass, Plex Ninja Posts: 15,475 Plex Employee

    As in the transcoder is the HW transcoder in the Shield, which we don't control. Looking to verify and look for solution.

  • Vilhelm.83Vilhelm.83 Members, Plex Pass Posts: 12 Plex Pass

    I've noticed every once in awhile if I try some of the HEVC files, they'll work 5% of the time on my AppleTV or XBOX ONE. Of course the same file usually doesn't work the next time I try it, but it does randomly work. Not sure if that helps, but any info I can share to help get this sorted.

  • elvidielvidi Members Posts: 1

    @MovieFan.Plex said:
    As in the transcoder is the HW transcoder in the Shield, which we don't control. Looking to verify and look for solution.

    The same movies work just fine in KODI playing directly from Shield. If the problem was only from the transcoder, the movies should play just fine in Direct Play, and they don't.

  • KarlDagKarlDag Members, Plex Pass Posts: 1,675 Plex Pass

    @elvidi said:

    @MovieFan.Plex said:
    As in the transcoder is the HW transcoder in the Shield, which we don't control. Looking to verify and look for solution.

    The same movies work just fine in KODI playing directly from Shield. If the problem was only from the transcoder, the movies should play just fine in Direct Play, and they don't.

    Not so sure. Playback in Kodi is "decoding", while transcoding required re-encoding. Also, Kodi uses its own media playback engine, so it's probably completely different.

  • MovieFan.PlexMovieFan.Plex Members, Plex Pass, Plex Ninja Posts: 15,475 Plex Employee

    ^^ correct. If you can get the file to direct play in something that supports H265 10-bit, like the Plex for Android app on the Shield, you won't see these artifacts. It only happens when transcoder down to H264.

  • fawzi@breidi.comfawzi@breidi.com Members, Plex Pass Posts: 9 Plex Pass

    i wonder why we ever need to transcode any file? mx player with extra codecs can play any file. i wonder why plex on tv doesnt allow such features.

  • KarlDagKarlDag Members, Plex Pass Posts: 1,675 Plex Pass
    edited January 29

    @fawzi@breidi.com said:
    i wonder why we ever need to transcode any file? mx player with extra codecs can play any file. i wonder why plex on tv doesnt allow such features.

    If your client supports the file format/codecs you don't need to transcode. If you're using a client limited in terms of codecs support, like iOS/tvOS devices, then your server has to transcode the files so they're playable on that device.

  • fawzi@breidi.comfawzi@breidi.com Members, Plex Pass Posts: 9 Plex Pass

    @KarlDag said:

    @fawzi@breidi.com said:
    i wonder why we ever need to transcode any file? mx player with extra codecs can play any file. i wonder why plex on tv doesnt allow such features.

    If your client supports the file format/codecs you don't need to transcode. If you're using a client limited in terms of codecs support, like iOS/tvOS devices, then your server has to transcode the files so they're playable on that device.

    i know they rely a lot on the client to play the videos but why they dont invest in adding codecs like other popular video players. for example i am using nvidia shield and more often than not, it have to transcode AC3 format

«1
Sign In or Register to comment.