If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

PMP not following Windows Scaling

RyokenRyoken Posts: 11Members ✭✭

I installed the new version today on my Surface, and immediately ran into this issue. By default Windows is set to scale everything to 150%, due to the high DPI, but PMP ignores this, and launches at the native resolution. It makes the UI very small, and unfriendly (especially the libraries along the side become very hard to select with precision).

Could we get this to follow the system setting by default? Or at least a setting somewhere to get it to respect it?

Windows 10 Pro, Current PMP.

Tagged:

Best Answer

Answers

  • RyokenRyoken Posts: 11Members ✭✭

    I should add that I am referring to when the App is NOT full screen, but Windowed.

  • stephen.hstephen.h Posts: 9Members, Plex Pass Plex Pass
    edited December 2016

    Same issue here though on a Dell XPS 15 9550. Also when viewing the "wrapped" Web App in Plex Media player the UI remains comically tiny no matter the window size. Marking the app's Properties, Compatibility, "Disable display scaling on high DPI settings" has no effect either.

  • plexuserrobplexuserrob Posts: 14Members, Plex Pass Plex Pass

    same problem here. Any fixes?

  • asilentnoizeasilentnoize Posts: 4Members, Plex Pass Plex Pass
    edited March 2017

    Seems numerous people have ran into the same issue I am facing. Like the rest of the people have stated, if by any chance you have scaling set above 100% in windows, it makes PMP useless... can't even use it as a paper weight. It would be nice to hear from the Plex team on if this will be addressed anytime soon.

  • franmorganfranmorgan Posts: 63Members, Plex Pass Plex Pass

    Experiencing this issue. How do you implement the above suggestion? Is this in the config file in App Data on Windows?

  • sean2078sean2078 Posts: 1Members

    In your Windows shortcut, add the flag that @vlang mentioned such as:

    "C:\Program Files\Plex\Plex Media Player\PlexMediaPlayer.exe" --scale-factor=

    Worked great - Thanks @vlang !

  • sha256sha256 Posts: 176Members, Plex Pass Plex Pass

    I have a 13" screen with 2560x1440 resolution on it. Setting my shortcut's "target" to "C:\Program Files\Plex\Plex Media Player\PlexMediaPlayer.exe" --scale-factor=1.5 --desktop

    Worked perfectly for me! It was so tiny before but 1.5 scale is great. Devs: might you consider making this easier to figure out? It's great you have the parameters coded into the .exe but novices probably wouldn't know to search for "dpi scaling parameters" and other such related keywords.

  • vampyrenvampyren Posts: 57Members, Plex Pass Plex Pass
    edited July 2017

    Wanted to check if this was fixed already, i guess not :disappointed:
    Windows dont seem to be priority for the dev team. Without proper scaling the windows player is really bad, text is soooo small.
    Any ETA on the fix ?

  • vlangvlang Posts: 1,648Members, Plex Pass, Plex Ninja Plex Ninja

    We disabled HIDPI support temporarily because it caused other problems, but want to switch back as soon as they are fixed. It actually depends on the Qt update, which broke something else on Embedded.

    Not at Plex anymore. I'm not a Ninja either.

  • asmconasmcon Posts: 1Members, Plex Pass Plex Pass

    HiDPI still not in the main release, but now that I've found this thread I can use PMP again on my 4k laptop (no idea why I bought a 4k laptop in the first place - seemed like a good idea at the time!)
    Thanks for the solution, and hopefully this gets back into the main release soon.

Sign In or Register to comment.