Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Why can't PMP stay full screen (Windows 10) (Not answered as stated :( )

ffhjansenffhjansen Members, Plex Pass Posts: 187 Plex Pass
edited December 2016 in Plex Media Player

A time ago plex had an annoying issue that it wasn't staying full screen after turning off and on the tv and or receiver and that issue seems to be back? After closing PMP and starting it up again it directly goes to full screen again.
Also Only toggle the "full screen" option in settings menu fixes how the screen looks.

Is there anyway to prevent this?

Tagged:

Best Answers

  • Xen0sysXen0sys Members, Plex Pass Posts: 536 Plex Pass
    Accepted Answer

    Append --tv --fullscreen to the shortcut.

«13456711

Answers

  • Xen0sysXen0sys Members, Plex Pass Posts: 536 Plex Pass
    Accepted Answer

    Append --tv --fullscreen to the shortcut.

  • ffhjansenffhjansen Members, Plex Pass Posts: 187 Plex Pass

    @Xen0sys said:
    Append --tv --fullscreen to the shortcut.

    Thanks @Xen0sys for the "solution".

    Keep wondering why there are multiple ways to say PMP has to be fullscreen?
    Can someone explain?

  • ffhjansenffhjansen Members, Plex Pass Posts: 187 Plex Pass

    Seems the solution from @Xen0sys worked a couple of times but now it's doing the same thing as before!

    What can i do about it?

  • patrikrpatrikr Members, Plex Pass Posts: 37 Plex Pass

    FWIW I have this issue as well. Worked fine until v1.2.0 and I have my Win10 PC connected to an AVR as well.

  • Xen0sysXen0sys Members, Plex Pass Posts: 536 Plex Pass

    @ffhjansen said:

    @Xen0sys said:
    Append --tv --fullscreen to the shortcut.

    Thanks @Xen0sys for the "solution".

    Keep wondering why there are multiple ways to say PMP has to be fullscreen?
    Can someone explain?

    Plex recently added an alternative Web/Desktop UI mode for PMP which you can switch between with F11 & Shift+F11. Using --tv --fullscreen still works for me. There are also --desktop & --windowed flags you can use interchangeably.

  • KaraokeAmericaKaraokeAmerica Members, Plex Pass Posts: 177 Plex Pass

    @Xen0sys said:

    Plex recently added an alternative Web/Desktop UI mode for PMP which you can switch between with F11 & Shift+F11. Using --tv --fullscreen still works for me. There are also --desktop & --windowed flags you can use interchangeably.

    What is the difference between the "TV" flag and the "desktop" flag? I found that when I used the "--desktop --fullscreen" flags I could get PMP to play full screen on my TV so it kind of behaved like the pre 1.2 version, but perhaps there is something going on I don't understand yet.

  • Xen0sysXen0sys Members, Plex Pass Posts: 536 Plex Pass

    @KaraokeAmerica said:

    @Xen0sys said:

    Plex recently added an alternative Web/Desktop UI mode for PMP which you can switch between with F11 & Shift+F11. Using --tv --fullscreen still works for me. There are also --desktop & --windowed flags you can use interchangeably.

    What is the difference between the "TV" flag and the "desktop" flag? I found that when I used the "--desktop --fullscreen" flags I could get PMP to play full screen on my TV so it kind of behaved like the pre 1.2 version, but perhaps there is something going on I don't understand yet.

    --desktop uses the Web/Desktop UI while --tv forces the standard PMP TV UI.

  • ffhjansenffhjansen Members, Plex Pass Posts: 187 Plex Pass

    Getting a bit sick of these command line arguments!
    I just want my PMP to stay full screen and on top.
    Full screen worked in previous versions so let it work again now!

  • Xen0sysXen0sys Members, Plex Pass Posts: 536 Plex Pass
    edited December 2016

    @ffhjansen said:
    Getting a bit sick of these command line arguments!
    I just want my PMP to stay full screen and on top.
    Full screen worked in previous versions so let it work again now!

    You can try tweaking C:\Users\[USER]\AppData\Local\PlexMediaPlayer\plexmediaplayer.conf

    "preventSystemScreensaver": true,
    "alwaysOnTop": true,
    "fullscreen": true,

  • KaraokeAmericaKaraokeAmerica Members, Plex Pass Posts: 177 Plex Pass

    @Xen0sys said:

    --desktop uses the Web/Desktop UI while --tv forces the standard PMP TV UI.

    I'm going to have to play with this more. Right now I'm using the --desktop flag and it looks like it did prior to this latest update. What is the difference between "TV" UI and "Desktop" UI?

  • Xen0sysXen0sys Members, Plex Pass Posts: 536 Plex Pass

    @KaraokeAmerica said:

    @Xen0sys said:

    --desktop uses the Web/Desktop UI while --tv forces the standard PMP TV UI.

    I'm going to have to play with this more. Right now I'm using the --desktop flag and it looks like it did prior to this latest update. What is the difference between "TV" UI and "Desktop" UI?

    Yeah I don't think your flag is being recognized.

  • ffhjansenffhjansen Members, Plex Pass Posts: 187 Plex Pass

    @Xen0sys said:

    @ffhjansen said:
    Getting a bit sick of these command line arguments!
    I just want my PMP to stay full screen and on top.
    Full screen worked in previous versions so let it work again now!

    You can try tweaking C:\Users\[USER]\AppData\Local\PlexMediaPlayer\plexmediaplayer.conf

    "preventSystemScreensaver": true,
    "alwaysOnTop": true,
    "fullscreen": true,

    Thanx @Xen0sys for your advise but the options were already on.

  • Xen0sysXen0sys Members, Plex Pass Posts: 536 Plex Pass

    @ffhjansen said:

    @Xen0sys said:

    @ffhjansen said:
    Getting a bit sick of these command line arguments!
    I just want my PMP to stay full screen and on top.
    Full screen worked in previous versions so let it work again now!

    You can try tweaking C:\Users\[USER]\AppData\Local\PlexMediaPlayer\plexmediaplayer.conf

    "preventSystemScreensaver": true,
    "alwaysOnTop": true,
    "fullscreen": true,

    Thanx @Xen0sys for your advise but the options were already on.

    Submit an issue: https://github.com/plexinc/plex-media-player/issues

  • KaraokeAmericaKaraokeAmerica Members, Plex Pass Posts: 177 Plex Pass

    @Xen0sys said:

    @KaraokeAmerica said:

    @Xen0sys said:

    --desktop uses the Web/Desktop UI while --tv forces the standard PMP TV UI.

    I'm going to have to play with this more. Right now I'm using the --desktop flag and it looks like it did prior to this latest update. What is the difference between "TV" UI and "Desktop" UI?

    Yeah I don't think your flag is being recognized.

    I am traveling for business right now. I'll look into it more when I get home the end of the week.

  • ffhjansenffhjansen Members, Plex Pass Posts: 187 Plex Pass

    I programmed a button which presses CTRL+SHIFT+F but wish it wasn't necessary.

    https://support.plex.tv/hc/en-us/articles/208052807-Controlling-the-App

  • ffhjansenffhjansen Members, Plex Pass Posts: 187 Plex Pass

    @tobiashieta is this issue being solved in the next release also?

  • KaraokeAmericaKaraokeAmerica Members, Plex Pass Posts: 177 Plex Pass

    @ffhjansen said:
    I programmed a button which presses CTRL+SHIFT+F but wish it wasn't necessary.

    https://support.plex.tv/hc/en-us/articles/208052807-Controlling-the-App

    I haven't tried this, but for any key-combo to work, wouldn't the Plex window still have to be in "focus" in Windows vernacular?

  • jmelz28jmelz28 Members Posts: 14 ✭✭

    F11 works for what I want, but would rather have hit alt-enter. Oh well.

  • wayned42wayned42 Members, Plex Pass Posts: 252 Plex Pass

    In 1.2.1 you can set Layout to "TV" (instead of Auto) and then backslash will switch between windowed mode & full-screen like it did in older versions.

  • mglairdmglaird Members, Plex Pass Posts: 69 Plex Pass

    Just installed 1.2.1 and saw that. So I set it to TV, turned off my HT system, and left for a bit. Just got back home, turned system back on and PMP was super zoomed in. All I could see was the top left quarter of the screen. Had to completely exit and re-launch to restore back to a normal looking fullscreen. I dunno what's happened but when it was still beta, it worked just fine. Ever since it went official and had a "stable" release, every time I turn my system on to watch Plex, PMP is always windowed and I have to go to settings and uncheck/check Fullscreen to get it to go back to normal. I was hoping this next update would fix that but obviously not. I have half a mind to just rollback to the last beta release since it was working 100% for me.

«13456711
Sign In or Register to comment.