We will be performing plex.tv database server maintenance starting 22:00 Pacific Time on Thursday, June 22 (05:00 GMT, June 23). It is expected to last ~1.5 hours. See http://status.plex.tv/incidents/w98nwqyk43pv
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Subtitles on synced content always on

ovqovq Members, Plex Pass Posts: 145 Plex Pass
edited December 2016 in iOS

Hi,

I can't remember how long I've had this problem, but I am deeply frustrated by it.

All my synced stuff on my iOS device plays with subtitles. I can switch it on/off, it won't matter. They always show. I can switch languages alright, but not switch them off entirely.

I also checked my relevant media. Audio tracks display English as detected language in Plex web, not "unknown" or something like that.

This only happens on synced content on iOS.
Everything plays fine on Plex Web or streaming on iOS.

Any clues?

«1

Answers

  • ovqovq Members, Plex Pass Posts: 145 Plex Pass

    Bump.
    Am I really the only poor Plex user who's having this issue?

  • lantrixlantrix Members, Plex Pass Posts: 11 Plex Pass
    edited April 3

    Hey @ovq I've started having the exact same problem. iOS v4.8 all my synced content I can not turn off subtitles; even if I choose off.

    This has come only weeks after changing subtitle settings on plex server to start fetching subtitles for non English speaking member of our household.

    Therefore I get both French and English subtitles on all my synced content. Can change the language but off always defaults to English.

  • lantrixlantrix Members, Plex Pass Posts: 11 Plex Pass
    edited April 3

    I should mention when playing on the Xbox one client subtitles now show by default; maybe due to my settings change on the server but I can turn them off on the Xbox client

    I just can't turn them off on my iOS synced content.

    Actually I double checked and playing any content even streaming from server when it's nearby shows the subtitles that can't be turned off.

  • ovqovq Members, Plex Pass Posts: 145 Plex Pass

    @lantrix: same thing with my AppleTV as on your Xbox. I do get subtitles, but can turn them off. I have selected "Auto" on my Plex-AppleTV and strangely, even just reselecting "Auto" does turn them off.

    iOS however is completely subtile-enforced. No way to switch them off.

  • DannyboyayyoDannyboyayyo Members, Plex Pass Posts: 23 Plex Pass

    There have been plenty of posts about this but no updates from Devs.

  • ovqovq Members, Plex Pass Posts: 145 Plex Pass

    ...which is strange for once, as well as frustrating.

  • kevdude10kevdude10 Members, Plex Pass Posts: 25 Plex Pass

    I as well am having Subtitles always showing, synced/ not synced content for ios devices - always updated to latest software. On rare occoasion I can select to have subtitles on or off but a lot of the times , Subtitles are automatic and are on.

    Even on the server side, theres no option for NO subtitles, its just allows for burn-in or automatic.

    devs, please check this forum and help us, I really dont want to have to find another streaming service

  • DannyboyayyoDannyboyayyo Members, Plex Pass Posts: 23 Plex Pass

    Any dev comments??

  • picklepickle Members, Plex Pass Posts: 1 Plex Pass

    bump. this drives me nuts.

  • lantrixlantrix Members, Plex Pass Posts: 11 Plex Pass

    Still happening with iOS 4.9 version.

  • spoilsspoils Members, Plex Pass Posts: 28 Plex Pass

    I've had this for several weeks now and I figured it would get patched out by now so I didn't worry about it. But it's getting old having subtitles on all the time.

  • DannyboyayyoDannyboyayyo Members, Plex Pass Posts: 23 Plex Pass

    Please take off the answered label for this thread because it's an ongoing issue.

  • ovqovq Members, Plex Pass Posts: 145 Plex Pass

    This thread is from Dec 16 - the problem is actually much older than the thread, and not a single Plex dev/employee bothers to even comment on it :/

  • lantrixlantrix Members, Plex Pass Posts: 11 Plex Pass

    @ovq I couldn't find any older threads.
    I still have the idea that this is occurring due to the subtitle settings I've changed on the Plex Server.

  • DannyboyayyoDannyboyayyo Members, Plex Pass Posts: 23 Plex Pass

    I can probably find 5 other threads besides one.

    It shouldn't matter what setting the server has. If we set the option to no in the iOS app then there should be no subtitles shown.

  • ktdktd Members, Plex Pass Posts: 324 Plex Pass

    Please fix this ASAP!!!

  • DannyboyayyoDannyboyayyo Members, Plex Pass Posts: 23 Plex Pass

    New IOS plex update did NOT fix the issue. Another perplexing issue with these subtitles is that for me, they are not in sync with the audio and sometimes the subs are from another show entirely. Very annoying. Everything works fine on the computer/xbox.

  • ketchup71ketchup71 Members, Plex Pass Posts: 4 Plex Pass

    Same here. Especially annoying since the subtitles may not even match the picture. ;)

    I usually have at least two subtitles per movie (different languages). If I do want a subtitle, it is displayed, otherwise it seems like the first one is selected. These are not the subtitles embedded into the movie files, but subtitles downloaded automatically by the server (which explains the occasional mismatch).

    As far as I remember, there is no subtitle problem when I stream directly from the server to the iOS client (can't do that right now, so I can't verify), but there are always subtitle problems for the synced files on iOS. (Android client on a Fire tablet seems to work fine.)

  • ovqovq Members, Plex Pass Posts: 145 Plex Pass

    This is almost spooky.
    Why doesn't any of the Plex employees even comment on the problem? The bug has been around forever now...

  • ketchup71ketchup71 Members, Plex Pass Posts: 4 Plex Pass

    Yesterday I tried another movie. Same iOS app version (4.10), same network, but this time: No enforced subtitles. Which is a good thing, in a way, but is very annoying, as the problem isn't that easy to reproduce. I'm very confused.

    The client can contact the server, at least indirectly, but I'm not sure if there was a server update between the syncs, so I'm fresh out of ideas, again. The only clue I can provide is that the subtitles displayed where not those in the movie subtitle stream, but obviously came from opensubtitles.org (which is configured in my server as an "agent" under "Agents/Movie/Plex Movie" and "Agents/Shows/TheTVDB").

«1
Sign In or Register to comment.