Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Subtitles on synced content always on

ovqovq Posts: 140Members, Plex Pass Plex Pass
edited December 2016 in iOS

Hi,

I can't remember how long I've had this problem, but I am deeply frustrated by it.

All my synced stuff on my iOS device plays with subtitles. I can switch it on/off, it won't matter. They always show. I can switch languages alright, but not switch them off entirely.

I also checked my relevant media. Audio tracks display English as detected language in Plex web, not "unknown" or something like that.

This only happens on synced content on iOS.
Everything plays fine on Plex Web or streaming on iOS.

Any clues?

Answers

  • ovqovq Posts: 140Members, Plex Pass Plex Pass

    Bump.
    Am I really the only poor Plex user who's having this issue?

  • lantrixlantrix Posts: 9Members, Plex Pass Plex Pass

    Hey @ovq I've started having thre exact same problem. iOS v4.8 all my synced content I can not turn off subtitles; even if I choose off.

    This has come only weeks after changing subtitle settings on plex server to start fetching subtitles for non English speaking member of our household.

    Therefore I get both French and English subtitles on all my synced content. Can change the language but off always defaults to English.

  • lantrixlantrix Posts: 9Members, Plex Pass Plex Pass

    I should mention when playing on the Xbox one client subtitles now show by default; maybe due to my settings change on the server but I can turn them off on the Xbox client

    I just **can't turn them off on my iOS synced content. **

    Actually I double checked and playing any content even streaming from server when it's nearby shows the subtitles that can't be turned off.

  • ovqovq Posts: 140Members, Plex Pass Plex Pass

    @lantrix: same thing with my AppleTV as on your Xbox. I do get subtitles, but can turn them off. I have selected "Auto" on my Plex-AppleTV and strangely, even just reselecting "Auto" does turn them off.

    iOS however is completely subtile-enforced. No way to switch them off.

  • DannyboyayyoDannyboyayyo Posts: 18Members, Plex Pass Plex Pass

    There have been plenty of posts about this but no updates from Devs.

  • ovqovq Posts: 140Members, Plex Pass Plex Pass

    ...which is strange for once, as well as frustrating.

  • kevdude10kevdude10 Posts: 25Members, Plex Pass Plex Pass

    I as well am having Subtitles always showing, synced/ not synced content for ios devices - always updated to latest software. On rare occoasion I can select to have subtitles on or off but a lot of the times , Subtitles are automatic and are on.

    Even on the server side, theres no option for NO subtitles, its just allows for burn-in or automatic.

    devs, please check this forum and help us, I really dont want to have to find another streaming service

  • DannyboyayyoDannyboyayyo Posts: 18Members, Plex Pass Plex Pass

    Any dev comments??

  • picklepickle Posts: 1Members, Plex Pass Plex Pass

    bump. this drives me nuts.

  • lantrixlantrix Posts: 9Members, Plex Pass Plex Pass

    Still happening with iOS 4.9 version.

Sign In or Register to comment.