If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Undefined error -2140536828 on PS4 after update to 1.3.3.3148

124»

Answers

  • flyingdutchguyflyingdutchguy Posts: 5Members ✭✭

    ps. like others, the streaming works fine when I do either of the following:

    • play without subtitles
    • set the Streaming quality on remote access to 'original'
  • zvennnzvennn Posts: 1Members, Plex Pass Plex Pass

    Hi, I got the same issue, and playing TV shows or movies without subtitles is not a solution, but a workaround. So Plex, could you please fix this.

    Streaming quality remoote: roiginal doesn't work for me :(

  • BigWheelBigWheel Posts: 9,992Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

    the error -2140536828 is SCE_AVPLAYER_ERROR_NOT_SUPPORTED which is a PS4 error that means the file is not supported in some manner.

    I am assuming all of your servers can transcode correct? subtitles need to be burned in
    can you enable logging in PS4 app then grab server logs after the error appears

    Logs > https://support.plex.tv/hc/en-us/articles/201869908-Log-Files
  • flyingdutchguyflyingdutchguy Posts: 5Members ✭✭

    Hm, I can't reproduce the error anymore. I've tried changing the settings back, but now it plays files with subtitles without trouble. I'll upload logs if the error appears again.

  • axeldiazaxeldiaz Posts: 6Members

    Hello,

    I am trying to find a resolution to this "Undefined error -2140536828". I'm experiencing this issue on my PS4 as well. It appears the short-term fix is to turn off subtitles; however, I am unable to find the menu option in Settings to turn them off. There is an option for subtitle size, but no option to turn them on or off.

    When I try turning off the subtitles from within a started movie or show, I still receive the Undefined error -2140536828.

    Does anyone have insight on how I can resolve this undefined error issue?

    Thank you!

    Plex version 3.80
    PS4 version 01.55

  • mansnetmansnet Posts: 2Members, Plex Pass Plex Pass

    I too have exactly the same problem with subtitles on PS4. Everything works fine, but once I turn subtitle on for any video, I get this "unknown" error.

    I tried SRT and VTT and they both gave the same error. I think it's a problem with transcoding, because the PS4 plays native files very well. When Plex transcodes the files to burn subtitles on the picture, it streams unsupported video format to the PS4.

    The Plex player has just been installed on the PS4 for the first time, so I suppose I have the latest version. My server is running CentOS 7 and Plex Server ver. 1.9.1.4272.

  • axeldiazaxeldiaz Posts: 6Members

    Hello,

    I believe my error was due to a "double NAT" situation. I removed the router and plugged my PS4 directly into the modem, and I no longer have this issue.

    Best regards.

  • psychowoodpsychowood Posts: 7Members, Plex Pass Plex Pass

    @mansnet said:
    I tried SRT and VTT and they both gave the same error. I think it's a problem with transcoding, because the PS4 plays native files very well. When Plex transcodes the files to burn subtitles on the picture, it streams unsupported video format to the PS4.

    It's not related to transcoding because if I force a lower quality, that forces transcoding and the video plays correctly: it only happens when enabling subtitles, both in original quality and in lower ones.

  • SilentMonotoneSilentMonotone Posts: 7Members, Plex Pass Plex Pass

    I’m getting this error when I try to put subtitles on my shows, too. Has anyone reliably fixed it?

  • r0cky0ngr0cky0ng Posts: 13Members ✭✭

    nope and i think it’s safe to think that there won’t be any in the near future. just to set expectation and not hopeful

  • deadlydatadeadlydata Posts: 6Members ✭✭

    I faced this same issue with my Plex Media Server on shield, things worked fine when I was using my PC as my PMS.

    Some how deleting logs pretty much was my fix, other than playing with some settings here and there that initially made no sense through trial and error.

    I faced pretty much about the same issue everyone else here did with every other device but the PS4 working, To re-cap though I went through an enabled logs on the ps4 in order to re-produce the issue and try and see what could be going on.

    Upon doing so, I realized my PMS logs were flooded so deleted all of em. Went to re-produce issue... content started playing fine with subtitles no more error.

    Baffled by this I had a (remote) friend try his PS4 and he was met with same result any media was now working fine. No conversion of media or optimization and hardly any server changes.

    The only other things I can think of that I had done was, I turned off and back on the hardware transcoder for trial and error purposes and I had also noticed at the time that my library had finished 'refreshing' meta-data once things started to work. I also deleted all old devices under my linked devices but this didn't seem to have any immediate impact.

    Hope this helps someone else.

  • flyingdutchguyflyingdutchguy Posts: 5Members ✭✭

    I got the error again and think I have some server logs to post. Where do I send them to? Or would you like me to paste them here?

  • ThorgrothThorgroth Posts: 1Members

    i also had the same error message all of a sudden in the middle of a video, i changed my subs to small, restarted the video and it worked, then i changed the subs back to normal size and now everything is working fine again

  • SoarindragonSoarindragon Posts: 2Members

    The fix seems to be all over the map, I had changed my server to show subs and select them automatically, changing that back to manually selecting subs fixed the issue for me. Oh well no subs for me tonight at least.

  • SoarindragonSoarindragon Posts: 2Members

    Oh forgot to mention, Synology NAS here too.

  • saphidsaphid Posts: 2Members, Plex Pass Plex Pass

    Restarting the server fixed it for me. That's weird, My first thought was something weird about space for the transcode but I had plenty of room. I'd love to know what the issues actually is.

124»
Sign In or Register to comment.