Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

(ONLY FOR SERIOUS TESTERS) Bleeding Edge Testing Releases

keithahkeithah Posts: 1,294Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee
edited April 7 in Plex for Kodi

Who this is for

Please, unless you are used to testing stuff, don't use these builds. We want most people to use the builds that are included in the Kodi repo, but we need some help getting the missing features and enhancements we want out to the public, so a few testers would be great.

A few folks have shown interest in helping us test releases before we push them out to Kodi's repo.

Eventually we want to have a testing repo, but for now I will post a .zip file in a thread below with the release notes of what we fixed/changed/etc.

Rules of testing

Please focus on the stuff mentioned in the release notes. I will delete posts that aren't on topic.

If you do come across a something that is different than is the currently released version, please downgrade your add-on and verify that it is fact different, and if you can give us logs of both the release version and the testing version, that would be best and we really appreciate it.

Please post a debug log for every issue you're reporting, the first time and be technical enough to tell us the Kodi version, Skin, what platform, etc

Installation

Please install the .zip the standard way, which is a repo zip.. If you don't know how to do this, please stick to the released version in the Kodi repo.

New updates will be pushed via this zip file, and automatically applied. Once an update is applied, please restart Kodi in order to make sure its functioning properly.

Downgrading

Under Video --> Add-ons highlight Plex and select i, or long press and goto Information.
Select 'Update' and pick the version to install, preferably the add-on repository one, unless testing for a specific issue.

Source Code

All of our development work happens in the 'develop' branch and is pushed to master, and all source is publicly available, unless we're working on a unreleased feature.

Thanks guys! I hope this is helpful for everyone and gives you a little more visibility into the process, we appreciate your help!

«13456719

Comments

  • keithahkeithah Posts: 1,294Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee
    edited August 28

    script.plex-0.0.102a1:

    • Added a testing repo!
    • Add Czech translation
    • Handle connection errors on link screen polling
    • Handle skip next/prev when playing video playlists
    • Add ability to view episodes/albums in library view

    script.plex-0.0.102b2:

    • Fixed library view not remembering sorting and unwatched
    • Add German translations (thanks to coffinbearer)
    • Friendly name now includes hostname to differentiate Kodi devices (thanks to andyblac)

    script.plex-0.0.102b3:

    • Fixed multi-part playback and improved timeline reporting
    • Possible fix for the actor images issue
    • Added Hungarian translations (thanks vampywiz17!)

    script.plex-0.0.102b4:

    • Fixed an issue with some server decisions failing

    script.plex-0.1.0:

    • Improved hub vertical scrolling animation
    • Fix issue causing error when marking devices as refreshed
    • Improved exception handling for some errors
    • Fix (#87): Switching between managed users causes Kodi to crash
    • Fix (#119): Occasional crashes when exiting the add-on
  • HitsVilleHitsVille Posts: 399Members, Plex Pass Plex Pass

    Running LibreElec 7.90.010 (updated today in tandem with updating the add on.)
    Kodi 17.0 Beta 7 (embedded Intel) Estuary skin.
    Kodi add on 0.0.100a4

    Not all of the fixes are for things I have noticed myself...but for the things I have
    Home hub squares being smaller... I cannot say I particularly noticed having only one system to test on. If they are "marginally" smaller then perhaps. Upgrading then downgrading then upgrading I'm not seeing a huge difference but then again It's not really something that I had an issue with.

    Text cut off seems improved.. It now seems to only affect items with a very long synopsis. Until we get scrolling text its probably as good as it can get (especially with the info button being available for long synopsis.) Again no huge deal for me.

    Startup times are incredible. From hitting restart in Kodi to Plex being loaded again was 14 seconds and at least half of that was Kodi shutting down. No massive boost for me again sadly...Its simply so fast now that my network card hasn't initialised in time and so I get "no servers found" for a couple of seconds.

    Finally although it's not mentioned in the notes for this release, resume times for part watched media is definitely improved despite being great anyway. Certainly faster than anything I experienced in PMP.

    HitsVille

  • keithahkeithah Posts: 1,294Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

    Thanks for the feedback. We're really focused on issues/problems you might have with this build, so if anything comes up let us know.

  • mini.PLEXmini.PLEX Posts: 289Members, Plex Pass Plex Pass
    edited December 2016

    just got around to testing this .100a4 release... I am having an issue with access via the PLEX user selection.

    thought I was going mad for a while (very possible), but it seems that 'enter/select' is not working when trying to select a user from plex addon launch (the button press sound is recognised by kodi)

    seems that I did manage to access my admin account just once, but could not regain access after I backed out, to any user accounts, even the admin.

    I have back tracked to .99 and all is working as intended.

    .100a4 logs here... http://paste.ubuntu.com/23709068/

    EDIT: have tested on a MacMini and a MacBookPro both running latest Sierra OS X - Kodi Beta 7 and both have the same results, cannot enter from user selection (its like the enter button is not working). defo not my keyboard

     Mac mini | mac OSX Sierra V10.12.6 | 2.6GHz Dual-Core Intel Core i5 | 16GB 1600MHz LPDDR3 SDRAM
    Server: PMS 1.8.2.4209
    Clients: PMP 2.1.0.74 | iOS iPhone 6s | apple TV4
    Clients: Kodi 17.4 | Plex for Kodi addon v0.1.1 | PlexKodiConnect v1.8.11
    Storage: 4x WD 4TB USB 3.0 Hard Drives
    Receiver: Panasonic Viera TX-50DX700B | Pioneer AV SX-SW55

  • HitsVilleHitsVille Posts: 399Members, Plex Pass Plex Pass
    edited December 2016

    @mini.PLEX said:
    just got around to testing this .100a4 release... I am having an issue with access via the PLEX user selection.

    thought I was going mad for a while (very possible), but it seems that 'enter/select' is not working when trying to select a user from plex addon launch (the button press sound is recognised by kodi)

    seems that I did manage to access my admin account just once, but could not regain access after I backed out, to any user accounts, even the admin.

    I have back tracked to .99 and all is working as intended.

    .100a4 logs here... http://paste.ubuntu.com/23709068/

    EDIT: have tested on a MacMini and a MacBookPro both running latest Sierra OS X - Kodi Beta 7 and both have the same results, cannot enter from user selection (its like the enter button is not working). defo not my keyboard

    Yep just home from night shift after seeing your post. I tested this and see the same thing. (Embedded Intel )
    Initially exactly as @Mini.Plex encountered. Now after a reboot it either does the same again or crashes the add on or even on occasions crashes and exits to the LibreElec loading page.
    Really need sleep so will gather logs later today.

    HitsVille

  • Buttzy10169Buttzy10169 Posts: 74Members, Plex Pass Plex Pass

    I havent tried this version yet but I am having an issue with 0.99 earlier to I think 0.96 was first version I tried.

    The issue is when starting kodi 1 of the servers connected to my account comes up as offline (a remote one not on my home network) and switching user makes it show as online and become accessible.

    The remote server is now down (out of my control) so I am unable to get a log. Though I am currently seeing this error (again on 0.99):

    10:52:27.326 T:139675256784640 ERROR: CCurlFile::Stat - Failed: Couldn't connect to server(7) for https://192.168.2.223:32400/library/metadata/67019/thumb/1474089329?X-Plex-Token=****

    And there is no Server on my network at that address and never was as far as I remember.

  • keithahkeithah Posts: 1,294Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

    Thanks for reporting the enter not being recognized issue! I'll look into it tomorrow.

    @Buttzy10169 as this is a testing thread please open up another thread with that issue and full logs.

  • danjames92danjames92 Posts: 3,200Members, Plex Pass Plex Pass

    @keithah said:
    Thanks for reporting the enter not being recognized issue! I'll look into it tomorrow.

    @Buttzy10169 as this is a testing thread please open up another thread with that issue and full logs.

    You could always maintain separate branches which is the standard on github. Then people could report issues there so it doesn't get buried in the noise of these forums.

    Mac Mini (2.7GHz, Late 2012, Windows 10, Kodi DSPlayer) | SATV 16GB | Panasonic TX-P50GT50B | Yamaha RX-V675 | Q Acoustics 2010i (FL, FR, Left S, Right S), Q2000ci Center, Q2070si Sub

     

  • keithahkeithah Posts: 1,294Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

    I don't consider this much noise, personally, which is why I asked for the issues here. On github its more clutterly (esp since many folks aren't used to using it) and I prefer to keep github as clean as possible.

    But I want this thread to stay focused on the bleeding edge test builds, and not generic issues that the entire rest of the sub-forum is for. If I had the power, I would move the discussion, but I don't, so I ask them to please repost.

    We do maintain separate branches, in the manner projects such as ours normally does: one for public release, and one for private, and push from private to public upon release. We do it this way because it's common for us to get features before they're out, or have to test something that might get changed before its official. I'm trying to keep it as open as I can.

  • superdxsuperdx Posts: 111Members, Plex Pass Plex Pass

    I think this is occuring in both live and beta: When an movie/show finishes playing, it just replays from the same show from the last resume point. New symptom is that that CPU just goes to 100% on the re-playback and there's also no sound. Is it possible to just disable the autoplay? I don't actually want Kodi to be continually playing stuff without any input.

  • keithahkeithah Posts: 1,294Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

    Yes, its an option in Settings to disable auto play.

    Also we'd love to see a log with it not working so we can investigate:
    https://forums.plex.tv/discussion/246913/getting-kodi-logs#latest

  • superdxsuperdx Posts: 111Members, Plex Pass Plex Pass

    Excellent, I have turned it off!

  • danjames92danjames92 Posts: 3,200Members, Plex Pass Plex Pass

    @keithah said:
    I don't consider this much noise, personally, which is why I asked for the issues here. On github its more clutterly (esp since many folks aren't used to using it) and I prefer to keep github as clean as possible.

    But I want this thread to stay focused on the bleeding edge test builds, and not generic issues that the entire rest of the sub-forum is for. If I had the power, I would move the discussion, but I don't, so I ask them to please repost.

    We do maintain separate branches, in the manner projects such as ours normally does: one for public release, and one for private, and push from private to public upon release. We do it this way because it's common for us to get features before they're out, or have to test something that might get changed before its official. I'm trying to keep it as open as I can.

    Fair enough Keith. Maybe at least the changelog could appear on github as I'm sure some would appreciate that?

    Mac Mini (2.7GHz, Late 2012, Windows 10, Kodi DSPlayer) | SATV 16GB | Panasonic TX-P50GT50B | Yamaha RX-V675 | Q Acoustics 2010i (FL, FR, Left S, Right S), Q2000ci Center, Q2070si Sub

     

  • keithahkeithah Posts: 1,294Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

    @mini.PLEX Sorry for the delay! Finally catching up from the holidays. You always seem to find the Home bugs! I do see a python exception, which is causing a problem with Home users, which is being presented to you as an issue with Enter (since its blocking your ability to login to the user)

    We're not sure why yet, but I'll open up a github issue for it. Thanks for reporting!

    @danjames92 the changelog is on github: https://github.com/plexinc/plex-for-kodi/blob/master/changelog.txt

  • finagle69finagle69 Posts: 76Members, Plex Pass Plex Pass

    I'd love to test these versions, but it fails to link to my Plex.tv account. The version from the official repo links correctly.

  • mini.PLEXmini.PLEX Posts: 289Members, Plex Pass Plex Pass

    @keithah said:
    @mini.PLEX Sorry for the delay! Finally catching up from the holidays. You always seem to find the Home bugs!

    @keithah - just glad I can help :D

     Mac mini | mac OSX Sierra V10.12.6 | 2.6GHz Dual-Core Intel Core i5 | 16GB 1600MHz LPDDR3 SDRAM
    Server: PMS 1.8.2.4209
    Clients: PMP 2.1.0.74 | iOS iPhone 6s | apple TV4
    Clients: Kodi 17.4 | Plex for Kodi addon v0.1.1 | PlexKodiConnect v1.8.11
    Storage: 4x WD 4TB USB 3.0 Hard Drives
    Receiver: Panasonic Viera TX-50DX700B | Pioneer AV SX-SW55

  • keithahkeithah Posts: 1,294Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee
  • keithahkeithah Posts: 1,294Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

    @HitsVille Hey can we get a log if you're still experiencing the Home issue that @mini.PLEX was? We're having some issues tracking it down, so more info the better. If you could actually give us logs from both .99 and .100a4, that'd be awesome.

    You too @mini.PLEX, if you could also give us brand new logs from it working in .99 and not working in .100a4, it'd help tremendously. Thanks!

  • mini.PLEXmini.PLEX Posts: 289Members, Plex Pass Plex Pass

    @keithah said:
    @HitsVille Hey can we get a log if you're still experiencing the Home issue that @mini.PLEX was? We're having some issues tracking it down, so more info the better. If you could actually give us logs from both .99 and .100a4, that'd be awesome.

    You too @mini.PLEX, if you could also give us brand new logs from it working in .99 and not working in .100a4, it'd help tremendously. Thanks!

    Will do @keithah (shall get those over in an hour or so)... FYI: the strange thing is .100a4 seems to work fine from my iMac (2011), but not from my Macbook Pro or Mac Mini.

    Shall send you logs from all through should it assist the greater cause :)

     Mac mini | mac OSX Sierra V10.12.6 | 2.6GHz Dual-Core Intel Core i5 | 16GB 1600MHz LPDDR3 SDRAM
    Server: PMS 1.8.2.4209
    Clients: PMP 2.1.0.74 | iOS iPhone 6s | apple TV4
    Clients: Kodi 17.4 | Plex for Kodi addon v0.1.1 | PlexKodiConnect v1.8.11
    Storage: 4x WD 4TB USB 3.0 Hard Drives
    Receiver: Panasonic Viera TX-50DX700B | Pioneer AV SX-SW55

  • keithahkeithah Posts: 1,294Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

    Ok we think we found a bug in the Home stuff, so can you guys try .100a5?

    Thanks!

«13456719
Sign In or Register to comment.