Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

OpenPHT uses ~30% CPU when idle

Christopher RungChristopher Rung Members, Plex Pass Posts: 20 Plex Pass

After I leave OpenPHT open for some time, the plexhometheater process' CPU usage jumps from 1-2% to ~30%.

I looked at ~/.plexht/temp/plexhometheater.log after enabling debug log output (pastebin output here), and saw that it was failing to connect to a friend's account.

I also felt that this line was telling:

WARNING: CPlexManualServerManager::OnJobComplete failed to find a server on http://127.0.0.1:32400/

Has anyone else seen this issue or know how to remediate? Thank you!

Ubuntu 14.04.5 LTS
OpenPHT 1.7.1.137-b604995c - installed deb
PMS 1.3.3.3148

Answers

  • askvictoraskvictor Members Posts: 3

    I get about 10% usage when idle; irrespective how long its been running for; I'm trying to figure out why - did you get anywhere? I'm running Ubuntu 14.04, OpenPHT 1.8

  • Christopher RungChristopher Rung Members, Plex Pass Posts: 20 Plex Pass
    edited July 27

    Unfortunately no, and since I posted this, I have updated my software. Currently:

    • Ubuntu 16.04.02 LTS
    • OpenPHT 1.8.0.148-573b6d73 - installed deb
    • PMS 1.7.6.4058

    When nothing is happening, I see the plexhometheater process consuming 8% CPU consistently.

  • wally007wally007 Members, Plex Pass Posts: 1,220 Plex Pass

    try playing with dirty regions in the OpenPHT settings (explanation what each setting means can be found in Kodi docs)

Sign In or Register to comment.