If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Plexconnect stuck on 'accessing trailers'

emmanouil.xenosemmanouil.xenos Posts: 8Members, Plex Pass Plex Pass

Atv3 - 7.2.1 (8011)
DNS: 192.168.1.87
DNS for PlexConnect 192.168.1.87
Device/OS that PlexConnect is installed on: Ubuntu Linux 16.04 - 4.4.0-57-generic on x86_64 running on HP Microserver
Device and OS PMS is installed on: same as above
PMS version: 1.3.3.3148
Settings.cfg
[PlexConnect]
enable_plexgdm = True
ip_pms = 192.168.178.87
port_pms = 32400
enable_dnsserver = True
port_dnsserver = 53
ip_dnsmaster = 8.8.8.8
prevent_atv_update = True
enable_plexconnect_autodetect = True
ip_plexconnect = 192.168.1.87
hosttointercept = trailers.apple.com
port_webserver = 80
enable_webserver_ssl = True
port_ssl = 443
certfile = ./assets/certificates/trailers.pem
loglevel = Normal
logpath = .

Issue: Since yesterday PlexConnect does not open any libraries - neither the ones on my server nor the shared libraries
After going through the 'Trailers' app and the first 'accessing trailers' prompt, I select 'Library' and it is always stuck on 'accessing trailers'
Thanks in advance for your help!

Answers

  • mschlotzmschlotz Posts: 218Members, Plex Pass Plex Pass

    I have found that dedicated IP's work better. Notice the 'False' parts below as well. Both my PMS & Plexconnect are running on the same system. In addition, the latest PMS I believe requires you to list ip address of your atv inside settings of PMS. see bottom of page 2 here: https://forums.plex.tv/discussion/230173/plexconnect-no-plex-library-available/p2

    Here is the setting.cfg I use:
    [PlexConnect]
    enable_plexgdm = False
    ip_pms = 192.168.1.131 <dedicated ip for iMac running PMS
    port_pms = 32400
    enable_dnsserver = True
    port_dnsserver = 53
    ip_dnsmaster = 192.168.1.1 <my router's ip
    prevent_atv_update = True
    enable_plexconnect_autodetect = False
    ip_plexconnect = 192.168.1.131 <dedicated ip for iMac running Plexconnect
    hosttointercept = trailers.apple.com
    port_webserver = 80
    enable_webserver_ssl = True
    port_ssl = 443
    certfile = ./assets/certificates/trailers.pem
    allow_gzip_atv = False
    allow_gzip_pmslocal = False
    allow_gzip_pmsremote = True
    loglevel = Off
    logpath = .

    The Listing in PMS for my atv3 (dedicated ip): 192.168.1.148/255.222.255.0.
    I believe I read somewhere that you can use a masking format which covers all addresses but haven't tried it yet. Goes something like 192.168.1.1/24. Guess I should try it.... OR maybe somebody here can confirm or correct?

  • emmanouil.xenosemmanouil.xenos Posts: 8Members, Plex Pass Plex Pass

    Thank you for your prompt answer.
    As per your suggestions and some other posts I have read here, I have done the following 3 things:

    1) Updated my PlexConnect Settings.cfg file as follows:

    [PlexConnect]
    enable_plexgdm = False
    ip_pms = 192.168.1.87 (the static / dedicated IP of my PMS server)
    port_pms = 32400
    enable_dnsserver = True
    port_dnsserver = 53
    ip_dnsmaster = 192.168.1.254 (the IP of my router)
    prevent_atv_update = True
    enable_plexconnect_autodetect = False
    ip_plexconnect = 192.168.1.87 (the static / dedicated IP of my PMS server)
    hosttointercept = trailers.apple.com
    port_webserver = 80
    enable_webserver_ssl = True
    port_ssl = 443
    certfile = ./assets/certificates/trailers.pem
    allow_gzip_atv = False
    allow_gzip_pmslocal = False
    allow_gzip_pmsremote = True
    loglevel = Off

    2) Added the Atv3's static / dedicated IP to the 'Network' tab of the PMS server under 'List of IP addresses and networks that are allowed without auth' as well as the PMS server's IP (I read that somewhere).
    192.168.1.66/255.255.255.0, 192.168.1.87/255.255.255.0

    3) Made sure I am signed in to MyPlex through PlexConnect settings in the Atv3

    Result so far:
    -'Trailers' on Atv3 open much faster from the home screen (guess that it is not 'looking' for the server anymore, but goes directly and pings it at its dedicated IP)
    -I can see the 'channels' from my PMS server and the 'Shared Libraries' that other users have shared with me.
    -Still no joy with my 'Library'; when I click on that one it is always stuck on 'Accessing Trailers' with the familiar 'loading' animation, so the original problem unfortunately persists.

    On a side note, I am running version 0.5-dev-110616 of PlexConnect, which I believe is the latest one.

    Any other ideas on what might be going wrong?

  • emmanouil.xenosemmanouil.xenos Posts: 8Members, Plex Pass Plex Pass

    Set Logging to 'High' and found this:
    13:03:43 PlexAPI: No Response from Plex Media Server
    13:03:43 PlexAPI: We failed to reach a server. Reason: timed out
    13:03:43 PlexAPI: Traceback:
    Traceback (most recent call last):
    File "/usr/local/lib/PlexConnect/PlexAPI.py", line 432, in getXMLFromPMS
    response = urllib2.urlopen(request, timeout=20)
    File "/usr/lib/python2.7/urllib2.py", line 154, in urlopen
    return opener.open(url, data, timeout)
    File "/usr/lib/python2.7/urllib2.py", line 429, in open
    response = self._open(req, data)
    File "/usr/lib/python2.7/urllib2.py", line 447, in _open
    '_open', req)
    File "/usr/lib/python2.7/urllib2.py", line 407, in _call_chain
    result = func(*args)
    File "/usr/lib/python2.7/urllib2.py", line 1241, in https_open
    context=self._context)
    File "/usr/lib/python2.7/urllib2.py", line 1198, in do_open
    raise URLError(err)
    URLError:
    Don't understand why there is no response from PMS...
    Any ideas?

  • moody_bluemoody_blue Posts: 2,899Members, Plex Pass, Plex Ninja Plex Ninja

    Is PlexWeb able to see the library ?

    QNAP TS-253A 4G QTS 4.3.4.0411 (beta3) + PMS 1.10.1.4561 (beta) + QPython2 2.7.12.0 + PlexConnect 0.5-dev-161017

    TV Sony KDL-32V2500 (720p) + aTV3 Rev. A firmware 7.2.2 + Denon AVR-1604 A/V Receiver 5.1 + Harmony Touch

    Portables 1x iPad4, 2x Android phone, 1x Android tablet, 2x PMP on Win10

    No support via PM unless requested by me

  • emmanouil.xenosemmanouil.xenos Posts: 8Members, Plex Pass Plex Pass

    I can see my library from all devices and clients other than the ATV3 via PlexConnect.
    The Web app on Chrome, the iOS app on an iPad, the Android app on a smart phone, everything works, so I am quite sure that it is something related specifically to PlexConnect and PMS not playing well together. I wish I had kept my previous PMS version. Now I have the latest PlexPass PMS version, but cannot use my ATV...

  • emmanouil.xenosemmanouil.xenos Posts: 8Members, Plex Pass Plex Pass

    Signed out of MyPlex on PlexConnect and started Trailers on ATV3; my Library appeared and is working fine.
    Tried signing back in and when I do my Library stays stuck on 'Accessing Trailers'.
    Only downside to staying logged out is not having access to Shared Libraries, which is no good.
    This does not make sense... :-(

  • mschlotzmschlotz Posts: 218Members, Plex Pass Plex Pass

    Agreed not making much sense, kinda has the air of a network permissions issue but can't tell.
    Hmm... router at 192.168.1.254 ??? more common is 1.1 and set to support 100 addresses or so, i.e. all the way to 192.168.1.100

    Is your atv3 ip: 192.168.1.66 set as a dedicated ip? You might also try in PMS's 'List of IP's' 192.168.1.1/24 vs what's in there.
    Is plexconnect physically running on the same server as PMS like it shows in the config?
    Is your PMS 'logged in'?

  • emmanouil.xenosemmanouil.xenos Posts: 8Members, Plex Pass Plex Pass

    Agreed not making much sense, kinda has the air of a network permissions issue but can't tell.

    I am wondering if the permissions issue has to do with MyPlex & PlexConnect as logging in to MyPlex causes the Library to 'disappear' and time out.

    Hmm... router at 192.168.1.254 ??? more common is 1.1 and set to support 100 addresses or so, i.e. all the way to 192.168.1.100

    Yes, my router is at 192.168.1.254

    Is your atv3 ip: 192.168.1.66 set as a dedicated ip?

    Yes atv3 is on a dedicated IP

    You might also try in PMS's 'List of IP's' 192.168.1.1/24 vs what's in there.

    Tried it; same behaviour as with the other config. MyPlex signs in and I see the Channels and the Shared Libraries, but my Library gets stuck on Accessing Trailers. Signed out of MyPlex, my Library loads up right away, but lose the Shared Libraries since I am not signed in...

    Is plexconnect physically running on the same server as PMS like it shows in the config?

    Yes

    Is your PMS 'logged in'?

    Yes
    Thanks for helping to try to figure this out...

  • mschlotzmschlotz Posts: 218Members, Plex Pass Plex Pass

    By any chance, could you be signed in on PMS with one id but signed in on the atv via plexconnect with a different id ?
    Just grasping at straws here....

  • moody_bluemoody_blue Posts: 2,899Members, Plex Pass, Plex Ninja Plex Ninja
    edited January 7

    There is an old thread where Baa announced this change. If PlexConnect is signed to MyPlex, then PMS must be signed in as well. This has to do with discovery (how PlexConnect discovers where PMS is).

    QNAP TS-253A 4G QTS 4.3.4.0411 (beta3) + PMS 1.10.1.4561 (beta) + QPython2 2.7.12.0 + PlexConnect 0.5-dev-161017

    TV Sony KDL-32V2500 (720p) + aTV3 Rev. A firmware 7.2.2 + Denon AVR-1604 A/V Receiver 5.1 + Harmony Touch

    Portables 1x iPad4, 2x Android phone, 1x Android tablet, 2x PMP on Win10

    No support via PM unless requested by me

  • emmanouil.xenosemmanouil.xenos Posts: 8Members, Plex Pass Plex Pass
    edited January 7

    Thanks for your replies. I connect to both PMS and PlexConnect using the same MyPlex ID.
    I tried signing out from both, signing in to one and not the other and signing back in to both same result.
    When signed-in to PlexConnect I cannot see my library, but can see the shared ones; when not signed-in to PlexConnect the inverse.
    Head-scratcher this one...

  • emmanouil.xenosemmanouil.xenos Posts: 8Members, Plex Pass Plex Pass

    Turned on my atv just now and all the thumbnails were wrong... I am ready to give up on the whole story and decommission this little black box for good...

Sign In or Register to comment.