Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Plex and OpenPHT on localhost (offline)

zpaolo11xzpaolo11x Members Posts: 988 ✭✭✭
edited January 9 in OpenPHT

I think this can be done, let me explain the scenario: on my local wi-fi network I have a Plex server on a nuc with 1TB hard drive, I can easily connect to that with my clients, or I can hook it to a TV via HDMI and launch OpenPHT on the nuc to use the "box" as both a "server" and "player". All this works when there's a wi-fi connection.
I need to use the same "box" in a place where no wi-fi is available, I checked with a VM some times ago and it worked, I mean, I was able to use OpenPHT and Plex offline, using 127.0.0.1 as server address. Recently I brought my box on the field, with OpenPHT 1.7.1 and latest PMS, and although at the beginning I could see my library, at a second boot only the "Search" menu was there, even if I selected "Scan for localhost".
I don't know if there's some settings on OpenPHT side, therefore I'm posting it here, I know with latest PMS versions you need to be signed in to make it work, so not only wi-fi but network access is needed, but is there a way to use, on the same machine, OpenPHT client and PMS server (both on localhost) without network access or wi-fi local network, and therefore no sign-in?

Best Answer

Answers

  • zpaolo11xzpaolo11x Members Posts: 988 ✭✭✭

    @benjaminwolf said:
    On OpenPHT enable auto-login. This will save your plex authication token.

    This is probably the missing step, I have to check, I think auto-login was enabled and for that reason it tried to connect. Maybe if I log out from PMS itself it will help?

  • zpaolo11xzpaolo11x Members Posts: 988 ✭✭✭
    edited January 20

    I was playing with an Ubuntu VM that has no network at all, I remember in the past I was able to have PMS running and OpenPHT connecting to it using 127.0.0.1 as server address, but right now when I try OpenPHT is stuck on "search". Maybe I'm missing something, I swear it used to work in the past... server 0.9.6 and OpenPHT 1.6.1

Sign In or Register to comment.