Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

PlexConnect Failing to Reach PMS: Unauthorized

Apple TV: ATV3 V7.2.2
Apple TV DNS: 192.168.2.40
Local IP: 192.168.2.40

PlexConnect and Plex Media Server both installed on Mac Mini running MacOS Sierra V10.12
Plex Media Server Version: 1.3.3.3148

PlexConnect downloaded from GitHub today (January 10, 2017)

I have installed plexConnect and Plex Media Server on a new Mac Mini. I am able to connect to PlexConnect through the trailers App on my apple tv, however there is no media available. Under my Library tab on the apple tv it says "PlexConnect - No Plex Library Sections Available". After looking through the logs a bit I see where it says

"PlexAPI: No Response from Plex Media Server"
"PlexAPI: We failed to reach a server. Reason: Unauthorized"

This is really my only clue as to what is going on. Any help would be greatly appreciated.

23:11:25 PlexConnect: ***
23:11:25 PlexConnect: PlexConnect
23:11:25 PlexConnect: Press CTRL-C to shut down.
23:11:25 PlexConnect: ***
23:11:25 PlexConnect: started: 23:11:25
23:11:25 PlexConnect: Version: 0.5-dev-110616
23:11:25 PlexConnect: Python: 2.7.10 (default, Jul 30 2016, 18:31:42)
[GCC 4.2.1 Compatible Apple LLVM 8.0.0 (clang-800.0.34)]
23:11:25 PlexConnect: Host OS: darwin
23:11:25 PlexConnect: PILBackgrounds: Is PIL installed? False
23:11:25 PlexConnect: IP_self: 192.168.2.40
23:11:25 DNSServer: started: 23:11:25
23:11:25 DNSServer: ***
23:11:25 DNSServer: DNSServer: Serving DNS on 192.168.2.40 port 53.
23:11:25 DNSServer: intercept: ['trailers.apple.com'] => 192.168.2.40
23:11:25 DNSServer: restrain: ['mesu.apple.com', 'appldnld.apple.com', 'appldnld.apple.com.edgesuite.net'] => 127.0.0.1
23:11:25 DNSServer: forward other to higher level DNS: 8.8.8.8
23:11:25 DNSServer: ***
23:11:25 WebServer: started: 23:11:25
23:11:25 WebServer: ***
23:11:25 WebServer: WebServer: Serving HTTP on 192.168.2.40 port 80.
23:11:25 WebServer: ***
23:11:25 WebServer: started: 23:11:25
23:11:26 WebServer: ***
23:11:26 WebServer: WebServer: Serving HTTPS on 192.168.2.40 port 443.
23:11:26 WebServer: ***
23:11:32 DNSServer: DNS request received!
23:11:32 DNSServer: Source: ('192.168.2.25', 56091)
23:11:32 DNSServer: Domain: p55-buy.itunes.apple.com
23:11:32 DNSServer: **forward request
23:11:32 DNSServer: -> DNS response from higher level
23:11:34 DNSServer: DNS request received!
23:11:34 DNSServer: Source: ('192.168.2.25', 63723)
23:11:34 DNSServer: Domain: se.itunes.apple.com
23:11:34 DNSServer: ***forward request
23:11:35 DNSServer: -> DNS response from higher level
23:11:35 DNSServer: DNS request received!
23:11:35 DNSServer: Source: ('192.168.2.25', 56510)
23:11:35 DNSServer: Domain: trailers.apple.com
23:11:35 DNSServer: ***intercept request
23:11:35 DNSServer: -> DNS response: 192.168.2.40
23:11:35 WebServer: serving /js/application.js
23:11:35 WebServer: serving .xml: /
23:11:35 PlexAPI: ***
23:11:35 PlexAPI: PlexGDM - looking up Plex Media Server
23:11:35 PlexAPI: ***
23:11:36 PlexAPI: GDM: Servers discovered: 1
23:11:36 PlexAPI: Servers (local, plex.tv, MyPlex): 2
23:11:37 WebServer: serving .xml: /PlexConnect.xml
23:11:37 WebServer: serving /js/utils.js
23:11:37 WebServer: serving /js/handlePlexConnectNavbar.js
23:11:37 WebServer: serving .xml: /library/sections
23:11:37 PlexAPI: No Response from Plex Media Server
23:11:37 PlexAPI: We failed to reach a server. Reason: Unauthorized
23:11:38 PlexAPI: Traceback:
Traceback (most recent call last):
File "/Applications/PlexConnect-master/PlexAPI.py", line 432, in getXMLFromPMS
response = urllib2.urlopen(request, timeout=20)
File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/urllib2.py", line 154, in urlopen
return opener.open(url, data, timeout)
File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/urllib2.py", line 437, in open
response = meth(req, response)
File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/urllib2.py", line 550, in http_response
'http', request, response, code, msg, hdrs)
File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/urllib2.py", line 475, in error
return self._call_chain(
args)
File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/urllib2.py", line 409, in _call_chain
result = func(*args)
File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/urllib2.py", line 558, in http_error_default
raise HTTPError(req.get_full_url(), code, msg, hdrs, fp)
HTTPError: HTTP Error 401: Unauthorized

23:11:38 WebServer: serving /js/utils.js
23:11:38 WebServer: serving /js/sectionHoldSelect.js
23:20:17 DNSServer: DNS request received!
23:20:17 DNSServer: Source: ('192.168.2.25', 61832)
23:20:17 DNSServer: Domain: init.itunes.apple.com
23:20:17 DNSServer: ***forward request
23:20:18 DNSServer: -> DNS response from higher level
23:20:18 DNSServer: DNS request received!
23:20:18 DNSServer: Source: ('192.168.2.25', 64688)
23:20:18 DNSServer: Domain: xp.apple.com
23:20:18 DNSServer: ***forward request
23:20:19 DNSServer: -> DNS response from higher level
23:20:19 DNSServer: DNS request received!
23:20:19 DNSServer: Source: ('192.168.2.25', 55041)
23:20:19 DNSServer: Domain: apps.itunes.com
23:20:19 DNSServer: ***forward request
23:20:19 DNSServer: -> DNS response from higher level

Best Answer

Answers

  • jhovey619jhovey619 Members Posts: 3

    I tried adding the IP of my apple tv to the "List of IP addresses and networks that are allowed without auth" but I am still seeing the same behavior...

  • jhovey619jhovey619 Members Posts: 3

    I solved this issue by logging in to myPlex on my apple tv after adding the IP to the list on my Plex Media Server. The answer was right in front of me! Thank you very much for your help!

  • moody_bluemoody_blue Members, Plex Pass, Plex Ninja Posts: 2,410 Plex Ninja
    edited January 12

    See this announcement https://forums.plex.tv/discussion/comment/1244304/#Comment_1244304

    One example of "List of IP addresses and networks that are allowed without auth" 192.168.1.0/255.255.255.0,10.10.10.0/255.255.255.0

    Logging in the ATV to MyPlex does not requires the above PMS parameter, it only requires PMS to be logged in as well.

Sign In or Register to comment.